Replay Source

Replay Source 1.6.8

jegadk

New Member
I've been using this plugin for a while now, and it's always worked fantastically! I thank you for this!

I use it to provide replays on live-streamed ice hockey games, and then would compile the resulting "replay" files into a recap to play prior to the start of the third period (while they Zamboni the ice). Unfortunately, these saved "replay" files are no longer saved on my hard drive that I can find, and so I can no longer compile them.

I'm not even sure where to look in settings to get them to save again.

Also, I save a recording of the entire broadcast (in case I need to upload the game because of crappy internet), so I'd rather not lose that ability. But I had the capability to BOTH keep the entire broadcast, and the replays, so I'd like to figure this out.

Any idea where I might have screwed this up, or perhaps the latest revision of OBS caused it?

Thanks in advance.

I had a similar problem with saving replay clips. It worked before, but suddeltly it dosen't.
If i created a new videocapture source then it worked, but not on the old. Today i reinstalled the OBS and now it can save replay again

Regards.
Jesper - Icehockey video manager.
 

jegadk

New Member
Have updated to newest version of replay, with the windows installer, and still only a green video.

To others.If you don't want to save replay files i flv, choose "Looseless" and it will save in avi
 

pehmonippe

New Member
I love this plugin, but also having problems with saving. Here's my error report.

I have two camera setup with capture cards where Cam 1 is Sony camcorder with Magewell USB Capture HDMI 4K+ as Video Capture Device and Cam 2 Panasonic camcorder with BMD UltraStudio Mini Recorder. Both cameras are set to output full HD. Cam 1 is outputting 1920x1080p50 and Cam 2 as 1920x1080i50.

Cam 1 with Magewell is seen as webcam in Windows 10. Cam 2 requires driver sw from BMD. Under normal circumstances everything work perfectly fine, all replays from both cameras work well - no issue there. Replays during live streaming are perfect. I am using short recordings as my workaround to save game highlights, it works, but ...

With version 1.6.6 I am able to save something, but only from one cam. When saving - to my surprise - it is only the Cam 2 that can produce output file (to my understanding it is working in synchronous mode). Cam 1 has issues. I've been only succeeded to save some file once or twice, but most of the times I can see only this message in the logs:

[replay_source: 'Replay Source CAM 1'] Save replay pressed

and nothing else. Log output from cam 2 would tell start saving, encoder settings, aac settings etc.

With playing around with settings I can have some changed, but in general I have not been able to track any pattern to reproduce the error in a systematic way. I have tried following:
  • re-create the replay-source
  • changed the video source from direct video capture device (async) to a scene with embedded video capture device (sync as I use BMD)
  • changed to use another video source (i.e. integrated laptop webcam) and changed back
  • disable & enable video source
  • changed all source and replay-source properties
  • having cam2 or not has no impact
  • and if any of these made me to go saving phase or even made output it will not happen again if I restart obs and I need to start doing some magic again to reproduce the results.
  • video from integrated webcam won't save either.
  • during and after all these operations in-memory replays works as charm
Sometimes I might get little bit further and get this message:

23:06:15.485: [replay_source: 'Replay Source CAM 1'] Load replay pressed
23:06:15.486: [replay_source: 'Replay Source CAM 1'] replay added of 8.00 seconds
23:06:23.030: [replay_source: 'Replay Source CAM 1'] Save replay pressed
23:06:23.040: [replay_source: 'Replay Source CAM 1'] start saving '2020-11-20 23.06.23-test.flv'
23:06:23.041: ---------------------------------
23:06:23.041: [x264 encoder: 'replay_h264_recording'] preset: veryfast
23:06:23.041: [x264 encoder: 'replay_h264_recording'] profile: high
23:06:23.041: [x264 encoder: 'replay_h264_recording'] settings:
23:06:23.041: rate_control: CRF
23:06:23.041: bitrate: 0
23:06:23.041: buffer size: 0
23:06:23.041: crf: 23
23:06:23.041: fps_num: 50
23:06:23.041: fps_den: 1
23:06:23.041: width: 1920
23:06:23.041: height: 1080
23:06:23.041: keyint: 250
23:06:23.041:
23:06:23.044: ---------------------------------
23:06:23.045: [FFmpeg aac encoder: 'aac'] bitrate: 128, channels: 0, channel_layout: 0
23:06:23.045:
23:06:23.052: error: Unsupported channel layout "0 channels"
23:06:23.052: [FFmpeg aac encoder: 'aac'] Failed to open AAC codec: Invalid argument
23:06:23.052: [replay_source: 'Replay Source CAM 1'] error output start: Failed to open AAC codec: Invalid argument
23:06:23.082: [replay_source: 'Replay Source CAM 1'] stopped saving


As far as I understand it is about the audio, but no matter what I select as audio source for the replay it does not help.

I'll add few logs from today from my testing, in case they're helpful. System info can be found from the logs and I'm using version 1.6.6 of replay-source installed with Windows installer.

I'll do some additional testing later to find a way to reproduce these issues.
 

Attachments

AlpineSkate

New Member
Trying to get this to save the replay. If I select lossless it creates an .avi file in the folder, but is only 5.56k in length. If I don't select lossless I get nothing in the folder. Looking in the logs, I can see this error:


21:59:30.440: [replay_source: 'Replay Source'] Save replay pressed
21:59:30.449: [replay_source: 'Replay Source'] start saving '2020-05-29 21.59.30.flv'
21:59:30.461: ---------------------------------
21:59:30.462: [x264 encoder: 'replay_h264_recording'] preset: veryfast
21:59:30.462: [x264 encoder: 'replay_h264_recording'] profile: high
21:59:30.462: [x264 encoder: 'replay_h264_recording'] settings:
21:59:30.462: rate_control: CRF
21:59:30.462: bitrate: 0
21:59:30.462: buffer size: 0
21:59:30.462: crf: 23
21:59:30.462: fps_num: 60
21:59:30.462: fps_den: 1
21:59:30.462: width: 2560
21:59:30.462: height: 1440
21:59:30.462: keyint: 250
21:59:30.462:
21:59:30.469: ---------------------------------
21:59:30.469: [FFmpeg aac encoder: 'aac'] bitrate: 128, channels: 0, channel_layout: 0
21:59:30.469:
21:59:30.469: [FFmpeg aac encoder: 'aac'] Failed to open AAC codec: Invalid argument
21:59:30.469: [replay_source: 'Replay Source'] error output start: Failed to open AAC codec: Invalid argument
21:59:30.482: [replay_source: 'Replay Source'] stopped saving

The obvious error there is "Failed to open AAC codec: Invalid argument", but don't know what that would mean. I'm guessing I have some other incompatible setting somewhere?
Hi Adjstreams, Did you ever get a reply to this question? I have exactly the same problem. I would prefer to save my replays as .flv.
I'm using the latest version of OBS, so 26.0.2, and the latest Replay Source, 1.6.6, on Ubuntu 20.04. I also haven't selected an "Audio Source" for my Replay Source. At least lossless works just fine. :-)
 

pehmonippe

New Member
Finally had the change to test. And, yes, now saving works, but... the saved image is green. No matter of format, always green cast over the image. Other than that everything else works as expected. Does anyone have any idea why the output image is green?

My setup is fullHD 50p.
 
Hi everyone! I broadcast sporting events and I'd like to know if there's any chance to use extra camera for replay while streaming the event with the primary one? A wide shot broadcast and a close-up replay in other words. I can do this with two laptops but only is available to me presently.
 

Exeldro

Active Member
@barnie_beadarcher I have 4 video capture devices with replay buffer and 4 replay sources. By setting the same hotkeys on all 4 replay sources they work synchronized. So 1 single hotkey loads 4 replays at exactly the same moment. The same way is used for the play, pause and restart hotkeys on the replays.
The multiview is used to display the 4 live scenes and the 4 replay scenes to be able to switch between them at the correct moment.
 

Deedge1go

New Member
Hello @Exeldro, i used to manage quite well with replay buffer, but now i need to make replays with 2 cameras more. I have never had any issues with your plugins. But i stumbled now. I followed every step when watching both tutorials by you and andilippi, but all i get is either a freeze frame or a black screen with mouse turning to cursor that changes size when on it. Did i miss something?
 

Exeldro

Active Member
A freeze frame you get when the duration is 1ms. Does the replay work when using the button in the properties?
 

lcalder

New Member
So, if I delete replay-source.dll and replay-source.pdb from my obs-plugins\64bit folder then I can launch and exit OBS without error.
But if I reinstall the replay source files (all the zip contents included in both data and obs-plugins folders) and launch the load replay hotkey, it shows all kinds of strange behavior in the replay - which I will describe below - and then when I try to exit OBS it will always crash (in websocket.dll) as you point out.
If I make no other change, but delete the dll and pdb above, then my OBS will no longer crash when exiting...

The replay source is set up like this: or sometimes I try a Start Delay of 2000ms because on looping the audio is always not aligned with the video... BUT THEN THE PROBLEMS BEGIN....
replay setup.png

So, at first my hotkeys will work and I can switch from one index to another using hotkeys and they will play fine. Then, if I mess with the replay source dialog (the Start Delay field is most suspect) it then rapidly turns to garbage... the videos just show an image and don't replay, and the "%TIME%" formatter for the Text Source, instead of showing 0.0 up to 5.0, will show 18446744071.71 and then switch to 0.03 seconds without really playing anything. This now happen every time, even if I quit and relaunch OBS (which will produce a crash now).
If I remove the replay-source.dll and pdb files the crashes will stop occurring.
This is a picture of the results produced by the following text format:
%PROGRESS% @ %SPEED%
%TIME%s of %DURATION%s
%INDEX% of %COUNT%

(I TRIED POSTING A PICTURE, BUT IT KEEPS FAILING TO SHOW HERE) I WILL TRY TO POST SEPARATELY BELOW...


I had posted this yesterday:
Great Ideas. But just cannot get it to work without crashing. I keep deinstalling and working without it because crashes are so frequent. But then I keep coming back to it to try to see if bugs fixed because it really is a cool plugin...

I just spent quite a bit of time creating some simple scenes to try to replicate the bug. For sure if you use the "Start Delay" field (I used two seconds) the %INDEX% starts to show some really long floating point numbers and then it will crash soon after.

I have posted the scene collection, crash log and log files at this dropbox link if it helps: https://www.dropbox.com/sh/vid78x9w0tglnie/AAATVBBQV3K5zd4LkxFvTxAAa?dl=0

Thanks
replay setup.png
 
Top