Replay Source

Replay Source 1.6.8

Kilu2020

New Member
i try to get the "replay source" plugin in my OBS Studio.
I have version 25.0.8 64 bit and i tried to install the replay source 1.6.4
I have also tried with version 23.0.2.
after download, i copy the "data" and "obs-plugins" folder in the obs folder .....program(x86)/obs-studio/
But if want to use the plugin under "add new source", i cannot find the replay source.

whats wrong?
 

Kilu2020

New Member
i try to get the "replay source" plugin in my OBS Studio.
I have version 25.0.8 64 bit and i tried to install the replay source 1.6.4
I have also tried with version 23.0.2.
after download, i copy the "data" and "obs-plugins" folder in the obs folder .....program(x86)/obs-studio/
But if want to use the plugin under "add new source", i cannot find the replay source.

whats wrong?
Here is from Log File

14:56:06.881: [obs-browser]: Version 2.8.6
14:56:06.885: NVENC supported
14:56:06.903: LoadLibrary failed for '../../obs-plugins/64bit/replay-source.dll': (null) (126)
14:56:06.903: Module '../../obs-plugins/64bit/replay-source.dll' not loaded

14:56:06.908: VLC found, VLC video source enabled
14:56:06.919: A DeckLink iterator could not be created. The DeckLink drivers may not be installed
14:56:06.920: No blackmagic support
 

NikkoToska

New Member
Is it possible to "Load Replay" by any other method than a hotkey? Would it be possible to trigger it on activating the source or switching to a scene with the source on it?
 

euristico

New Member
when i close the obs, and reopen, i have to reconfigure replay source, if not the video is freeze... I don't know how to show it... bue every time to work i have to reprogram all.
 

JesperBon

New Member
I had trouble getting this plugin to appear after I installed the new version until i found out it was because i needed to update visual c++ redistributable for visual studio 2019. Just wanted to mention, if anybody has the same problem.

However I have never been able to save a replay. I use the same hotkey for shifting to the scene and to load the replay. That works fine. But ifI assign the same hotkey to "save replay" nothing i saved. Do I have to do it different?
 

JesperBon

New Member
i try to get the "replay source" plugin in my OBS Studio.
I have version 25.0.8 64 bit and i tried to install the replay source 1.6.4
I have also tried with version 23.0.2.
after download, i copy the "data" and "obs-plugins" folder in the obs folder .....program(x86)/obs-studio/
But if want to use the plugin under "add new source", i cannot find the replay source.

whats wrong?
Have you tried to update visual c++ redistributable for visual studio 2019. That helped for me. Before the plugin did not show up but after it does.
 

Roby1O

New Member
I have a lot of problems... I tryed boht OBS Studio version (latest 25.0.8.64 and even in 26 rc1)

First time i set and use all looks fine, then i start having no reason trouble with freeze replay, some completely random crash with no error, or simply nothing happen.

In the log file i see "load replay pressed" but scene remains black. Other times it says "load replay pressed", then "Loaded replay of 0.0 seconds". Tryed reinstall, clear all make completely new scene or set of scenes, but I can't make it to simply run correctly and constantly.


I'm so sorry because this is the best obs plugin.
 

nelpix

New Member
Hi,
Plugin works great, except for the replays are saving as .flv with a green cast on them.. Is there a way to fix this?? I don't know why it's doing this because when I try saving with other replay scripts they save the video file fine. When the replay is loaded it plays fine as well. What could be going wrong?? Everything is working great apart from this saving to a green cast file. When choosing lossless it has the same issue..
 

Attachments

cabostrike

New Member
I decreased the instant replay to 50%. In the program it plays in slowmotion. But When i record on OBS, the video file plays in fullspeed. How can i make sure that the recorded video still plays the replays in slowmotion.
 

willA

New Member
I love this plugin it does exactly what I needed... Apart from saving replays. I have setup a hotkey to save the replay and a directory is set but on pushing the hotkey.... Nothing happens, the keypress is registered in the obs log but no file appears in the set directory (or anywhere else as far as I can tell) and no further action in the log. I saw that others have had similar issues but no answers is there a fix? Or am I missing something?
 

Javier Luis

New Member
With version 26 of OBS the plugin doesn't work, does the same thing happen to you?

It won't let me have the playback buffer active
 

Tero

New Member
I've been using OBS Software in figure skating competition live streaming. I'm planning to add replays of the program and found this add-in. By watching introduction video is it so that I need to pre-define replay clip length? A program consists of jumps and spins which are duration of individual elements vary so ideally I would like to have a hotkey to start capturing replay and then hit a key to end it as well.
 

Marlos Padilha

New Member
Olá! Muito Bom o plugin me ajudou muito . Eu estava com a versão 25.0.8 funcionando muito bem, porem quando veia a atualização 26 deu erro . reinstalei do zero , e tentei aplicar o plugin de replay , mas ele nao aparece, acredito q o plugin não esteja preparado para a nova versão , alguém poderia me ajudar ?
 

LorenaMS

New Member
Hi,
Plugin works great, except for the replays are saving as .flv with a green cast on them.. Is there a way to fix this?? I don't know why it's doing this because when I try saving with other replay scripts they save the video file fine. When the replay is loaded it plays fine as well. What could be going wrong?? Everything is working great apart from this saving to a green cast file. When choosing lossless it has the same issue..
Hi!
We have the same problem. We have five Video Capture Device sources and only one replay is saved in the folder as .flv and with green cast (from Elgato Cam link 4k device). All sources have the same hotkeys for load and save. All are loaded correctly but only one is saved with this problem. Do you fixed the problem? Do We have to use "Video capture device with replay buffer" source instead of "Video capture device" source?

Thanks in advance and sorry about my basic english
 

DevilDogSoldier

New Member
I've been using this plugin for a while now, and it's always worked fantastically! I thank you for this!

I use it to provide replays on live-streamed ice hockey games, and then would compile the resulting "replay" files into a recap to play prior to the start of the third period (while they Zamboni the ice). Unfortunately, these saved "replay" files are no longer saved on my hard drive that I can find, and so I can no longer compile them.

I'm not even sure where to look in settings to get them to save again.

Also, I save a recording of the entire broadcast (in case I need to upload the game because of crappy internet), so I'd rather not lose that ability. But I had the capability to BOTH keep the entire broadcast, and the replays, so I'd like to figure this out.

Any idea where I might have screwed this up, or perhaps the latest revision of OBS caused it?

Thanks in advance.
 

Pacmam

New Member
Hi,
Plugin works great, except for the replays are saving as .flv with a green cast on them.. Is there a way to fix this?? I don't know why it's doing this because when I try saving with other replay scripts they save the video file fine. When the replay is loaded it plays fine as well. What could be going wrong?? Everything is working great apart from this saving to a green cast file. When choosing lossless it has the same issue..
Had the same problem and "fixed" it by reverted to OBS version 25
No more green, for now atleast. My guess it has something to do with FFmpeg... i tried compiling it myself but its too damn hard. Kept running into obstacles.
 
Top