Everything appears to work, but the I have to call the overall experience quite dysfunctional. Documentation is poor, leaves out large portions of information that the programmer seems to think is "too obvious" to tell us (or something, I'm guessing. Point is there's steps missing). Best to start with the presets and reverse engineer them to make your controller work (assuming of course that one of the presets doesn't suit your needs simply as-is).

Didn't play well with my retro controller. I used JoyToKey to remap it to different keyboard keys and set the overlay map as a keyboard overlay with the retro controller images. Speaking of which, the background image, the base controller, can't be included in either the OBS plugin or the (more importantly) the provided web tool to generate the .json file for your controller, for what reason I have yet to fathom. You just have to guess where the controller buttons should land and push them a few pixels at a time this way, a few more that way, until they sit properly on the base image. The image swap on the button presses is also a lot more cryptic than it needs to be. He's got this 3 pixel gap thing going on that seems to work fine in the videos but somehow it doesn't work that way when setting up your own controllers.

[sigh] ... all that said... if you can get through all those roadblocks, or, if one of the presets suits your needs, it appears to work just fine. I am satisfied with the final result, at least. It has not broken so far... knock on wood.
Keyboard presets work just fine on arch linux but the mouse presets crash obs studio. using v5.0.4
Splendid and does the job perfectly!
Really good but the web creation tool seems a bit buggy with gamepad inputs. I can't get it to work with my Fightbox and Arrow keys work in the web editor, but not in the actual overlay. Am I doing something wrong?
It's precisely what it needs to be and does it well. with the advent of its io_client, it's perfect for any stream set-up. it is fully customizable and works cleanly. The only con is that it is not for the plug-n'-play user (hopefully not too many on here for this to apply).
hello universallp I see 3 folders one that is data and one that is obs plugins and the other that says io client and there is a program do you know what that program is for
It's for people that use multiple computers when streaming. It sends inputs from one computer to another.
This is really great for tutorials! I used the input-history preset and it's great! It's so easy to use set up! Enabled WebSocket forwarding, disabled gamepad hook, added input-history browser source, BAM! Thank you so much for this!
Only the mouse and keyboard work for me, not the gamepad and by the way I like your universallp plugins
Yeah there are some issues with gamepads. A few work (mine does) but I'm looking into using a more reliable library for gamepad input
Thank you so much
Used this about a month ago, created the textures, exported the .jsons, loaded them up, everything worked fine.
Now the plugin asks for .ini files rather than .js? Something that isn't exported by YOUR tool. So until fixed cannot really recommend.
you're most likely using an outdated version
great, but iI didnot found the source json file in any obs folder...where is this file (not is js folder, there only js files)
Amazing plugin! I use it alot.
This is a great program...
Hi,This is a really useful.I'm very enjoy it in my Final Fantasy XIV live stream. Config creation tool is very powerful. But I can't create key 6,7,ESC and ~ , because the textures png without that key!!!
Can I ask you to create that key textures in the wasd.png?
I really need it.
Worked for a while, but recently doesn't seem to detect any input whatsoever. May not be compatible with newer version of OBS anymore.
Doesn't actually seem to do anything. I've yet to find an instance in which this actually responds to keypresses or mouse buttons. It's just a picture you put in OBS.
i Enjoy it a lot i just wish i could show more of the keys that i use when playing certain games.
Works perfectly fine, maybe should be more clear about the config editor though! Perhaps I am also just blind idk, but I found the config editor and a video, that explains it roughly. It was not hard to understand if you have experience in coding, though. Simply editing a JSON file shouldn't be an issue, either, if you want to do this kind of stuff.

I am glad, there is still a dedicated plugin for this that is still supported! No clue what the guy below is on about, seems like they never used GitHub before and want to have class a technical support to walk them through primary school. :)

Great Plugin 6/5, once you understand how it is set up, you can make custom texture pretty darn ez.
Software seems great, but lack of support simply kills this. It is a download page with instructions which do not help at all. When you go to developer's tutorial, you find it to be outdated where he installs his plug ins to a master folder. I follow his instructions until I install his plug in into a obes program.

I load this plug in successfully and then he casually asks us to direct program to graphical files for this plug in which does not exist! This plug in looks like something which I might eventually figure out how to install. However, developer offers abysmal technical support to people here and the only feedback from him is not supportive, but rather combative and defensive rhetoric back.

I'm sorry, but this thing ruins experience for so many people and I want to this to be made painfully clear. Why I must to spend hours figuring out how to solve something which should be easily done via help of an installer?
Have you tried following the instructions on this page? https://github.com/univrsal/input-overlay/wiki/Installation I've made it a bit clearer where to get the presets.
The program took a while to adapt to, but it was well worth the effort as this also allowed for quite some flexibility on how one can design their overlay.
Though a small complaint I have is how the Numpad keys aren't working for the plugin.. even when they still appeared to function in io-cct. I hope this will be fixed soon.