Question / Help Why Does OBS Lag No Matter How Low I Set Things?

#1
OBS always lags out even though my game did not, I don't have the best PC, but it runs most modern games, for instance My Hero Academia: One's Justice runs fine as a game, but my recordings of it are so laggy, I don't know what settings to have it on and I'm getting a bit frustrated after a few weeks of experimenting with no success, here's my specs if you need more let me know:

CPU: AMD FX(tm)-870K Quad Core Processor 3.60 GHz
RAM: 16 GB
GPU: AMD Radeon (TM) R7 350
log file: https://obsproject.com/logs/lJGEosGjaKI58Kd0
 

Narcogen

Active Member
#2
You're overloading your GPU, sometimes by a little, sometimes by a bit more than that:

14:39:26.980: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 535 (0.4%)
14:43:39.209: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 1630 (11.3%)
14:55:48.714: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 290 (1.1%)

Adding recording with OBS always introduces more GPU load. The easiest way to obviate this is to cap the framerate your game runs at to make sure OBS has resources to work with.

You also have some Windows features on that should be turned off, as they can degrade OBS' performance:

12:51:50.767: Windows 10 Gaming Features:
12:51:50.767: Game DVR: On

https://www.windowscentral.com/how-disable-and-remove-game-bar-windows-10-creators-update

https://www.tenforums.com/tutorials/75936-turn-off-game-mode-windows-10-a.html#option1

Game Mode in specific makes OBS run poorly, and if you have it on, you should turn it off.

Lastly, it may just be that you can't record well in 60fps which is demanding. I am sure you could probably record this game in 720p30 without issue.
 
#3
I did everything you recommended, capped my game to 30fps, recorded in 720p30, disabled windows gaming features, and now my recordings are still laggy, but whats new is its trapped in the upper corner, which is not shown in the OBS preview, so i know its not the red box and it says my screenshots too large to upload so :/
heres the log: https://obsproject.com/logs/scJ5_TlMMSfyUNDL
 

Harold

Active Member
#4
And you changed the preset from medium to slow which INCREASES system load.

Switch your output mode back to simple
Change your recording quality to indistinguihsable
Change your recording encoder to software (X264, low cpu usage preset, increased file size)
Change your recording format to FLV.
 
Top