BrokeWeeaboo

New Member
Note: This thread is aimed primarily at fixing black screens for AMD Laptop users and also Multi-Adapter Graphics Laptop Thingies. Basically, your device has a lot of graphics cards.

Ok. So a while ago I used OBS and it worked fine. No black screen, no OBS (Oh this is so B*llShit) moments, no nothin'. Just good recording. However, a while back I started getting the infamous OBS black screen. I couldn't fix it. It was impossible. I did everything. I reinstalled my drivers. I even clicked page 2 on Google (that's REAL dedication). After some intense research, I have fixed my black screen and have compiled a list of fixes for this black screen.

Fix #1 (My fix): Go to AMD settings. Go to system, then switchable graphics. There you should see a bunch of running applications, and OBS should be among them (you should have OBS running BTW). Click it, and set it to power saving. If for whatever reason it switches back to High Performance and doesn't save, then here is how you fix it (this is what happened to me).
Go to your power plan. Just type Power or Power Plan in your windows search bar
Screenshot (80).png
Then go into that Power Plan. It should look a little something like this:
Screenshot (81).png

After that, change your setting to look a little bit like this:
Screenshot (82).png
You want to have pretty much every setting related to AMD and your graphics to be at Power Saving, forced Power Saving, etc. Now just click apply and you're pretty much good to go. Your AMD Setting will run OBS on Power Saving by default. Note that this will force AMD to run EVERYTHING on power saving (Games included) so expect a pretty heavy performance debuff.

You might be able to still run OBS on Power Saving by setting your power plan to run at Normal or whatever but I've never tried that before. Honestly, the performance debuff probably won't even be that noticeable.


FIx #2: Ok this isn't for AMD but f*ck it, I don't give a care. Go to your Nvidia GPU settings. There you should be able to go to switchable graphics or something like that. I've never used Nvidia before. There, set OBS as power saving. You might have to change your power plan for this too.

FIx #3: Go run OBS as Administrator. Never did anything for me but hey it might fix it for you.

FIx #4: Go take a look at your antivirus. If you have a super-sensitive or just straight-up weird antivirus, chances are, it might've messed up OBS. Go see if it has deleted some of OBS's files or whatever. If it did, restore those files and set an exception to your antivirus.

FIx #5: Reinstall OBS. You may have accidentally deleted some of the files or whatever. Whatever the cause, reinstalling OBS should be able to fix pretty much everything. This is a last-ditch effort, however, so caution is advised.

FIx #6: Ok so you still have the Black Screen. The only real way to capture anything at this point is to give up on Display Capture and use Windowed or Game Capture. Go to OBS. Remove Display Capture. Now, I'll teach you how to use Game/Window capture.

Add Game Capture. On the properties page, you should see an option called "SLI Crossfire (slow)" or something like that. Enable it, and pray to Jesus that your OBS will run normally. Note that this will take a chunk out of your performance. I heard there's a way to mitigate that but f*ck that, this is a thread for fixing Black Screens.

If Game Capture doesn't work add Window Capture. This will be a guaranteed capture (not a really great way to capture your stuff but beggers can't be choosers). First up add Window Capture. In the properties page, there should be an option called "Multi-Adapter Compatability." Check that, and select the window you want to be capturing. You should be able to capture stuff now. This is inefficient and definitely not a great way to capture games. I do not recommend going this far just to get OBS running. You should really just ditch OBS and go find another screen recorder to work with at this rate.

If somehow none of these work just go sit and cry in a corner. After that, uninstall OBS and go find another screen recorder. If that doesn't work break your computer and realize that you just broke your computer because some dumb weeb told you to. Now question your life and cry slowly in a corner.
 

Search Titans

New Member
Hey Broke,

THANK YOU! This fix worked perfectly for me. I have had this problem for a while now. Your instructions worked exactly as you said they would. Thanks again!

Dave
 

marcospb19

New Member
This post is based on what Broke said above, just a complement.

Here's the fix to my problem (very bad solution, makes you need to open Power Plan Options every time you open OBS)

DISCLAIMER:
THIS SOLUTION IS FOR LAPTOPS WITH 2 GPUs, you were advised.
My laptop has 2 GPUs, if you have more that this (wtf), the final solution is expected to work, but I can't guarantee.

Sorry if I mistake some technical name, you guys can correct me (I am not an expert, I just happened to find a working solution for me).

-------------------------------------------------------------------------------------

You need to force OBS to be ran with your integrated graphics card instead of your dedicated graphics card, I already had problems with this on my machine before with another applications.

It is reasonable that your system tries to use your best GPU to work with OBS, as it's a very resource demanding application, but the black screen problem is sadly there.

Here's a look into my GPUs, keep in mind that R5 is the integrated GPU, and R7 the dedicated GPU.

1584569452346.png


So, there are two GPUs in my computer, and I need force my computer to use the first one (Radeon R5 /Integrated).

Try using AMD Radeon software to correct this problem, as it is the best solution, if you can't, keep reading.

-------------------------------------------------------------------------------------

The new AMD Adrenaline Radeon Software (released now in 2020), don't have the option to control which card will each application use, you can try your luck on newer versions (as I don't know when you're reading this!!).

But there's an option inside of Windows Graphics Settings that should do it for you.

1584568470511.png


Here, you can browse and select an application executable (in our case, obs64.exe) and set it to work with one of the two graphic card options.

When I click on "Options", this shows up:
1584569009195.png


There's a HUGE PROBLEM HERE, Windows thinks that there's only one option for both cases, so it doesn't matter which one I choose, it's the same thing.

But that's not actually true, my computer has 2 GPU options, but... wait... the option Windows is showing me is the correct one I want... why this doesn't work??????

Radeon R5 IS MY INTEGRATED GPU, IT'S CORRECT!!

Microsoft??
...

Ok, so what's happening is the following: this menu just doesn't work on my computer, Windows says "Hey, use the R5 Integrated GPU" and then the AMD drivers just try to outsmart and help by using the R7 Dedicated GPU, we all can see the reason.

If you can solve your problem here, on this menu (as a lot of people on other forums related to be able to), that's awesome, else, keep reading.

-------------------------------------------------------------------------------------

Yeah, you're already tired of this post, what else can we do?

---------- ---------- ---------- Actually the solution that worked for me ---------- ---------- ----------

Ok, so there's a MASTER STUPID way of forcing your computer to use your "Power Saving" option, the integrated GPU instead of the dedicated GPU.

Open Power Options
1584570458893.png


Go to your power plan settings, for the power plan you actually use
1584570553603.png


Then
1584570596410.png


Now you can scroll down the list and see Swichable Dynamic Graphics
1584570888923.png


There's this option Force Power-Saving Graphics.

W
hile this option is active, it will force your less power-consuming GPU to be used on any applications you open (normally, the used GPU is fixed at the program start, it shouldn't change, but that's possible).

The bad part of enabling this, is that it makes your dedicated GPU totally useless for any program opened after.


So, what I do EVERY TIME I NEED TO OPEN OBS :
Set FORCE POWER-SAVING GRAPHICS,
Then I open OBS,
And finally, I set the MAXIMIZE PERFORMANCE option, so the games I open can use my dedicated GPU.



I really hope this can help someone, leave any questions below and tell me what of the 3 solutions worked for you.
:D
 

6uVXIHUulc

New Member
This post is based on what Broke said above, just a complement.

Here's the fix to my problem (very bad solution, makes you need to open Power Plan Options every time you open OBS)

DISCLAIMER:
THIS SOLUTION IS FOR LAPTOPS WITH 2 GPUs, you were advised.
My laptop has 2 GPUs, if you have more that this (wtf), the final solution is expected to work, but I can't guarantee.

Sorry if I mistake some technical name, you guys can correct me (I am not an expert, I just happened to find a working solution for me).

-------------------------------------------------------------------------------------

You need to force OBS to be ran with your integrated graphics card instead of your dedicated graphics card, I already had problems with this on my machine before with another applications.

It is reasonable that your system tries to use your best GPU to work with OBS, as it's a very resource demanding application, but the black screen problem is sadly there.

Here's a look into my GPUs, keep in mind that R5 is the integrated GPU, and R7 the dedicated GPU.

View attachment 52105

So, there are two GPUs in my computer, and I need force my computer to use the first one (Radeon R5 /Integrated).

Try using AMD Radeon software to correct this problem, as it is the best solution, if you can't, keep reading.

-------------------------------------------------------------------------------------

The new AMD Adrenaline Radeon Software (released now in 2020), don't have the option to control which card will each application use, you can try your luck on newer versions (as I don't know when you're reading this!!).

But there's an option inside of Windows Graphics Settings that should do it for you.

View attachment 52102

Here, you can browse and select an application executable (in our case, obs64.exe) and set it to work with one of the two graphic card options.

When I click on "Options", this shows up:
View attachment 52103

There's a HUGE PROBLEM HERE, Windows thinks that there's only one option for both cases, so it doesn't matter which one I choose, it's the same thing.

But that's not actually true, my computer has 2 GPU options, but... wait... the option Windows is showing me is the correct one I want... why this doesn't work??????

Radeon R5 IS MY INTEGRATED GPU, IT'S CORRECT!!

Microsoft??
...

Ok, so what's happening is the following: this menu just doesn't work on my computer, Windows says "Hey, use the R5 Integrated GPU" and then the AMD drivers just try to outsmart and help by using the R7 Dedicated GPU, we all can see the reason.

If you can solve your problem here, on this menu (as a lot of people on other forums related to be able to), that's awesome, else, keep reading.

-------------------------------------------------------------------------------------

Yeah, you're already tired of this post, what else can we do?

---------- ---------- ---------- Actually the solution that worked for me ---------- ---------- ----------

Ok, so there's a MASTER STUPID way of forcing your computer to use your "Power Saving" option, the integrated GPU instead of the dedicated GPU.

Open Power Options
View attachment 52108

Go to your power plan settings, for the power plan you actually use
View attachment 52109

Then
View attachment 52110

Now you can scroll down the list and see Swichable Dynamic Graphics
View attachment 52112

There's this option Force Power-Saving Graphics.

W
hile this option is active, it will force your less power-consuming GPU to be used on any applications you open (normally, the used GPU is fixed at the program start, it shouldn't change, but that's possible).

The bad part of enabling this, is that it makes your dedicated GPU totally useless for any program opened after.


So, what I do EVERY TIME I NEED TO OPEN OBS :
Set FORCE POWER-SAVING GRAPHICS,
Then I open OBS,
And finally, I set the MAXIMIZE PERFORMANCE option, so the games I open can use my dedicated GPU.



I really hope this can help someone, leave any questions below and tell me what of the 3 solutions worked for you.
:D
OMG, I registered just to say this:

Thank you SO SO MUCH. You're a life-saver.

I honestly can't believe that AMD. It's bad enough that they force such a shoddy driver on people and keep changing the setting names. But the least they could do is document their changes.

And this isn't a case of some minor feature on an obscure piece of software. It's a piece of core functionality that people require to do their jobs.

AMD, for the love of god, test your damn software!
 

manfilho

New Member
Thank you so much. Here it's working just matching the both configuration settings: AMD and OBS on Windows Configuration! Thank you for your help!

1595862868624.png
 

Exygon

New Member
This post is based on what Broke said above, just a complement.

Here's the fix to my problem (very bad solution, makes you need to open Power Plan Options every time you open OBS)

DISCLAIMER:
THIS SOLUTION IS FOR LAPTOPS WITH 2 GPUs, you were advised.
My laptop has 2 GPUs, if you have more that this (wtf), the final solution is expected to work, but I can't guarantee.

Sorry if I mistake some technical name, you guys can correct me (I am not an expert, I just happened to find a working solution for me).

-------------------------------------------------------------------------------------

You need to force OBS to be ran with your integrated graphics card instead of your dedicated graphics card, I already had problems with this on my machine before with another applications.

It is reasonable that your system tries to use your best GPU to work with OBS, as it's a very resource demanding application, but the black screen problem is sadly there.

Here's a look into my GPUs, keep in mind that R5 is the integrated GPU, and R7 the dedicated GPU.

View attachment 52105

So, there are two GPUs in my computer, and I need force my computer to use the first one (Radeon R5 /Integrated).

Try using AMD Radeon software to correct this problem, as it is the best solution, if you can't, keep reading.

-------------------------------------------------------------------------------------

The new AMD Adrenaline Radeon Software (released now in 2020), don't have the option to control which card will each application use, you can try your luck on newer versions (as I don't know when you're reading this!!).

But there's an option inside of Windows Graphics Settings that should do it for you.

View attachment 52102

Here, you can browse and select an application executable (in our case, obs64.exe) and set it to work with one of the two graphic card options.

When I click on "Options", this shows up:
View attachment 52103

There's a HUGE PROBLEM HERE, Windows thinks that there's only one option for both cases, so it doesn't matter which one I choose, it's the same thing.

But that's not actually true, my computer has 2 GPU options, but... wait... the option Windows is showing me is the correct one I want... why this doesn't work??????

Radeon R5 IS MY INTEGRATED GPU, IT'S CORRECT!!

Microsoft??
...

Ok, so what's happening is the following: this menu just doesn't work on my computer, Windows says "Hey, use the R5 Integrated GPU" and then the AMD drivers just try to outsmart and help by using the R7 Dedicated GPU, we all can see the reason.

If you can solve your problem here, on this menu (as a lot of people on other forums related to be able to), that's awesome, else, keep reading.

-------------------------------------------------------------------------------------

Yeah, you're already tired of this post, what else can we do?

---------- ---------- ---------- Actually the solution that worked for me ---------- ---------- ----------

Ok, so there's a MASTER STUPID way of forcing your computer to use your "Power Saving" option, the integrated GPU instead of the dedicated GPU.

Open Power Options
View attachment 52108

Go to your power plan settings, for the power plan you actually use
View attachment 52109

Then
View attachment 52110

Now you can scroll down the list and see Swichable Dynamic Graphics
View attachment 52112

There's this option Force Power-Saving Graphics.

W
hile this option is active, it will force your less power-consuming GPU to be used on any applications you open (normally, the used GPU is fixed at the program start, it shouldn't change, but that's possible).

The bad part of enabling this, is that it makes your dedicated GPU totally useless for any program opened after.


So, what I do EVERY TIME I NEED TO OPEN OBS :
Set FORCE POWER-SAVING GRAPHICS,
Then I open OBS,
And finally, I set the MAXIMIZE PERFORMANCE option, so the games I open can use my dedicated GPU.



I really hope this can help someone, leave any questions below and tell me what of the 3 solutions worked for you.
:D
ok bro so, i have the same issue and i know i'm a bit late, but i hope i can introduce a new way (perfect i may add) to fix this problem.
many of us that own a laptop with an AMD processor and both integrated and dedicated graphics card use the latest graphics driver (which is, if i remember correctly, Radeon Software, that can come in variants like ReLive and such, but aside from that...), but the thing is, like you said, there's no way, using that software, to choose which graphics card a specific program should use.
well, if you replace that software with the latest CCC (Catalyst Control Center), you can solve that problem. some people have issues with this program too, but that's just because it's not the latest version. the latest version lets you customize litterally everything, including for example, for each power plan, the processor frequency both when on battery and when connected to the power supply.
the link is this: https://www.amd.com/en/support/kb/release-notes/rn-rad-win-15-7-1
i think it's the latest version, anyway i'll list the steps you have to complete in order to make OBS (or any other screen capture software for that matter) working:

uninstall Radeon Software if you have it installed. i think you can do it after installing CCC, too
1. download CCC from this link (i'll put it here too): https://www.amd.com/en/support/kb/release-notes/rn-rad-win-15-7-1
2. complete the installation
3. go to energy -> switchable graphics cards settings (i think that's what it's called, my software is in italian)
1631487673497.png

4. you'll see two tabs: recent apps and all the apps. you have to add OBS if you don't see it there and put power-save.
that's it! that should work! also, my software is in italian, i'm too lazy to change system language or to crop the screenshot, it's late and i have work tomorrow good night guys i hope this helped.
 

Exygon

New Member
ok bro so, i have the same issue and i know i'm a bit late, but i hope i can introduce a new way (perfect i may add) to fix this problem.
many of us that own a laptop with an AMD processor and both integrated and dedicated graphics card use the latest graphics driver (which is, if i remember correctly, Radeon Software, that can come in variants like ReLive and such, but aside from that...), but the thing is, like you said, there's no way, using that software, to choose which graphics card a specific program should use.
well, if you replace that software with the latest CCC (Catalyst Control Center), you can solve that problem. some people have issues with this program too, but that's just because it's not the latest version. the latest version lets you customize litterally everything, including for example, for each power plan, the processor frequency both when on battery and when connected to the power supply.
the link is this: https://www.amd.com/en/support/kb/release-notes/rn-rad-win-15-7-1
i think it's the latest version, anyway i'll list the steps you have to complete in order to make OBS (or any other screen capture software for that matter) working:

uninstall Radeon Software if you have it installed. i think you can do it after installing CCC, too
1. download CCC from this link (i'll put it here too): https://www.amd.com/en/support/kb/release-notes/rn-rad-win-15-7-1
2. complete the installation
3. go to energy -> switchable graphics cards settings (i think that's what it's called, my software is in italian) View attachment 75092
4. you'll see two tabs: recent apps and all the apps. you have to add OBS if you don't see it there and put power-save.
that's it! that should work! also, my software is in italian, i'm too lazy to change system language or to crop the screenshot, it's late and i have work tomorrow good night guys i hope this helped.
ok guys *don't* install AMD Radeon Software or whatever you have installed after CCC. that's because it will remove the graphics drivers (apparently, instead of only being programs that let you choose how your graphics card behaves, they install drivers too), so if you install CCC and then uninstall AMD RS, it won't work anymore. or at least it didn't for me.
 
Top