Audio Output Capture on Windows Partition Needs Resetting Every Time?


New Member
I run OBS on a Windows partition on my Mac. Any time I turn on OBS or switch scenes, the only way I can pick up desktop audio is by making a new audio output capture. And I have to do it every time. It shows that audio is being picked up on the meters, but my stream wont have it. Anyone else who had this issue ever figure it out? It's not bad, and it does eventually pick it up, but as one can imagine it can get irritating to add a new audio output capture every time I start streaming or change scenes. I didn't have this issue when I used to stream before, but that wasn't on a partition.


New Member
Windows Partition?
1. Window Installation on Mac Hardware?
2. Windows Emulation on a Running Mac OS ?
totaly unclear what situation is mean with Partition
why not use OBS for Mac on a Mac?
It's a partition. You partition your hard disk so that you can run both Mac and Windows OS on the same computer, depending on how you start it up.

If I liked using OBS on my Mac partition, which I don't, I would.

Here's the log file, but again, OBS is just LIKE this. It's not registered as an issue in the logs.


Dude i asked by the fact that what you write not clarified what you are running.
"I run Dedicated Windows on mac hardware(Dual boot)"
The partition stuff not say whats going on related to Real or Virtual Windows

Related to the log files

(2- Scarlett 2i2 USB)
22:42:00.747: Max audio buffering reached!
22:42:00.747: adding 960 milliseconds of audio buffering, total audio buffering is now 960 milliseconds (source: Mic/Aux)

22:42:04.082: WASAPI: Device 'Speakers (2- Scarlett 2i2 USB)' [44100 Hz] initialized
22:42:04.090: WASAPI: Device 'Speakers (2- Scarlett 2i2 USB)' [44100 Hz] initialized
22:42:04.099: WASAPI: Device 'Speakers (2- Scarlett 2i2 USB)' [44100 Hz] initialized
22:42:04.106: WASAPI: Device 'Speakers (2- Scarlett 2i2 USB)' [44100 Hz] initialized

that is nothing default happen
no onboard/dedicated soundcard?
You added the source to every scene is not the default handle
thats not the way to write it but leave it out.

check if you select the correct source on settings->Audio
and if you have select the right settings on Audio-Advanced (Right click on the audio mixer) there must be "Monitoring Off or Monitoring and Output" is there Only Monitoring selected then only you hear it.

if this setup like i wrote above , then look for the Issue on USB/driver side of the USB sound device