Question / Help Fading Audio between scenes ??

Gerry

New Member
Im having bit of an issue that i need to solve

I have 'starting soon' scene which i use before i start streaming, It has a music source playing in the background

When i decide to begin the stream i select the new scen, then its displayed after a stinger transition
The only problem im having it that once im already on the new scene, the music is still playing from the ''previous scene for an additional second, then just cuts out

Is there a more seamless way of some how fading the audio when the stinger transition is triggered?
 

FerretBomb

Active Member
By default, OBS crossfades audio on scene changes. If a source is not present in the destination, it's faded out; if not in the origin it's faded in. Stingers have an option in their properties to choose between a crossfade, or fade out and then fade in.
Which type of music source are you using, that's having the problem? Are you using the stinger crossfade or out-in option?
 

Gerry

New Member
The audio is playing as a media source in the 1st scene and the stinger is set to 'fade out to transition point then fade in', i tried crossfade as well but doesn't seem to work.

the audio from the mp3 continues to play into the 2nd scene for an additional second or two then just cuts out
 
I found that the amount of audio fade is the same as the video fade duration.
Try setting a video fade to 2000-3000ms, then the audio will follow that.
 
What I am saying is that the MP3 audio that is on your scene, when switched to another scene where the MP3 does not exist, should fade based on the video fade duration.
 

Gerry

New Member
What I am saying is that the MP3 audio that is on your scene, when switched to another scene where the MP3 does not exist, should fade based on the video fade duration.

Where do i set the fade of the audio? Currently the MP3 is still playing when i am on the new scene for about 1 sec
 
You don 't set the fade on the audio.... you set the duration of the fade transition in the VIDEO.

If you do a RMB on the scene object, you can to a Transistion override.... make sure it is set to Fade, and set the duration to 2000ms or 3000ms.

The audio will fade accordingly (as long as the audio does not exist on the net scene.
 

rweeden

New Member
There is no way of monitoring the ACTUAL audio that is sent to the recording/stream from OBS which is bonkers. Can we please have the ability to hear the accurate audio so we don't have to guess?!

The audio fade is only evident when playing back a recording or for the streaming viewers, not to the user when broadcasting live, but yes, audio DOES fade alongside any video fades.
 

Tormy

Member
There is no way of monitoring the ACTUAL audio that is sent to the recording/stream from OBS which is bonkers. Can we please have the ability to hear the accurate audio so we don't have to guess?!

The audio fade is only evident when playing back a recording or for the streaming viewers, not to the user when broadcasting live, but yes, audio DOES fade alongside any video fades.
Because I just stumble upon this issue now, I'm wondering where to ask to solve this issue.
As user, I would like to have the same representation the viewer has. Or I always think to a malfunction, though.
 
This is a longstanding known issue and as I just posted on another thread, I for one would send $5 to anyone who fixes it :) Who's with me? :) Can we get a fund going?

Seriously tho, a lot of us are using OBS via a virtual audio redirect for things like Zoom right now, and this is painfully lacking.
 

phedders

New Member
This is a longstanding known issue and as I just posted on another thread, I for one would send $5 to anyone who fixes it :) Who's with me? :) Can we get a fund going?

Seriously tho, a lot of us are using OBS via a virtual audio redirect for things like Zoom right now, and this is painfully lacking.

It might be lacking in core - but have a look at:

There are other options too. Search :)
 

daleb

New Member
The best solution I've found so far is to install NDI tools and the OBS NDI plugin, then use "Line (NewTek Audio)" as the audio input for Zoom (rather than a virtual audio cable). The NDI audio fades as in and out as expected. The downside is that I've had some A/V sync issues if OBS runs overnight, but a reboot seems to resolve it.

-and-

Although I understand why some might prefer that monitored audio is treated differently, I would like to see an option in OBS to treat the monitored audio like streamed and recorded audio.
 

daleb

New Member
The best solution I've found so far is to install NDI tools and the OBS NDI plugin, then use "Line (NewTek Audio)" as the audio input for Zoom (rather than a virtual audio cable). The NDI audio fades as in and out as expected. The downside is that I've had some A/V sync issues if OBS runs overnight, but a reboot seems to resolve it.

-and-

Although I understand why some might prefer that monitored audio is treated differently, I would like to see an option in OBS to treat the monitored audio like streamed and recorded audio.


... and enable NDI in OBS using Tools/NDI Output setting, and then select the appropriate source using NDI's Virtual Input app.
 
Top