Blurry image when setting Logitech C922 Pro to 1280x720?


New Member
Just upgraded to a Logitech C922 camera because my previous one was stuck at 30fps. I got the new one hooked up and added it as a video capture device. Everything was good so far, running at 60fps but was defaulted to 4:3 for some reason. I went into the properties and set the device's resolution to "Custom" then selected 1280x720. My camera filled the frame but became super blurry, especially noticeable in the face area. I tried bumping it up to 1920x1080, which no longer looked blurry, but is capped at 30fps.
I then tried lowering the resolution DOWN to 1024x576, and somehow that WASN'T blurry but is lower than the 720p I need. I'm not sure if this is the device having an issue or OBS, since the camera advertises 720p60 / 1080p30 output. All I know is that it's an issue specifically with this one exact resolution, since lower 16:9 resolutions work just fine.

Here's the log file of my session where I was cycling through the resolutions. Not sure if it's going to be of much help with this particular issue.


Active Member
The cameras sensor is physical 4:3, and it's still an usb 2.0 cam, thus resulting in such res/fps ratios.
Going 1280x720 means that the cameras electronics (or even worse its driver) resembles the picture from the one physical taken by the sensor.

Try another 4:3 res like 960x720, look if that comes sharp its way, then resize it to your needs regarding width and crop the image in height (to reach for your 16:9 ratio). Maybe the camera should step back physically a little bit then due to the focal length.