Resource icon

Free Animated Lower Thirds with Dockable Control Panel v.1.6

rogue-ronin

New Member
Hi! Apparently, the OBS Browser of the Linux version is not entirely compatible. In that case, I will have to find an alternative.
I will appreciate any help. Thank you for your collaboration! ;)
Glad to help -- can you tell me how? I'm a longtime linux user, not afraid to mess about -- but I am not a programmer, just a bit of bash.
 

rogue-ronin

New Member
Great!!
However, when I added Animated Lower Thirds as a dock the following error message appeared:
"Couldn't load that page!
Make sure the address is correct, and that the site isn't having issues.
Server's IP address not found
URL: http://home/xxx/OBSTest/_ScriptsAndPlugins/Plugins/Animated-Lower-Thirds/lower thirds/control-panel.html
Click here to retry"
Am I doing something wrong or is a bug in the OBS that prevent user to select a local path instead of web server address?

Thank you!
my first thought is that you have a space between "lower" and "thirds" in your URL line, and that might break it.
 

snss

Member
my first thought is that you have a space between "lower" and "thirds" in your URL line, and that might break it.
True! That's the name of the folder created by the author of this plugin. So, modifying that name would require to modify the path in all files that need access that folder.
 

NoeAL

Member
Awesome plugin. This dev has done excellent work. Thank you so much !!! I am wondering if there is a way for the memory slots to have some sort of smooth transition if going from one memory slot to another?, rather than just an instant change.
Hi! Yes, in the next update there will be an in-out transition when you load a memory slot.

new_change_slot_l.gif
 

NoeAL

Member
Great!!
However, when I added Animated Lower Thirds as a dock the following error message appeared:
"Couldn't load that page!
Make sure the address is correct, and that the site isn't having issues.
Server's IP address not found
URL: http://home/xxx/OBSTest/_ScriptsAndPlugins/Plugins/Animated-Lower-Thirds/lower thirds/control-panel.html
Click here to retry"
Am I doing something wrong or is a bug in the OBS that prevent user to select a local path instead of web server address?

Thank you!
Hi! It's a local file, so the http:// prefix doesn't make much sense.
On the other hand, I don't know if the space between "lower" and "thirs" can cause you a problem, better to add a %20.
Sorry if I'm wrong, I'm not a Linux user, but I guess it would be something like this:
/home/xxx/OBSTest/_ScriptsAndPlugins/Plugins/Animated-Lower-Thirds/lower%20thirds/control-panel.html
or:
file:///home/xxx/OBSTest/_ScriptsAndPlugins/Plugins/Animated-Lower-Thirds/lower%20thirds/control-panel.html
 

snss

Member
Hi! It's a local file, so the http:// prefix doesn't make much sense.
On the other hand, I don't know if the space between "lower" and "thirs" can cause you a problem, better to add a %20.
Sorry if I'm wrong, I'm not a Linux user, but I guess it would be something like this:
/home/xxx/OBSTest/_ScriptsAndPlugins/Plugins/Animated-Lower-Thirds/lower%20thirds/control-panel.html
or:
file:///home/xxx/OBSTest/_ScriptsAndPlugins/Plugins/Animated-Lower-Thirds/lower%20thirds/control-panel.html
Hi!
There is a space(%20) in the URL. I used the file:/// and it's working.
Thank you @NoeAL.
 

snss

Member
I suggest the OBS dev team to add the browse button in View>Docks>Custom Browser Docks like in Windows in order to avoid this kind of problems.
After closing and restarting OBS the error appeared again. I removed from the Custom Browser Docks the plugin line, restarted and re-entered the path and now it's working.
 

Roberto Crispim

New Member
Goodnight!
I installed version 27 on linux ubuntu, but I can't insert the "logos". When clicking to insert an image nothing happens!
Does anyone know how to solve?
 

rogue-ronin

New Member
Goodnight!
I installed version 27 on linux ubuntu, but I can't insert the "logos". When clicking to insert an image nothing happens!
Does anyone know how to solve?
Browser docks are new in v27, and I believe there is a conflict between native dialogs and QT dialogs in OBS. There are github reports on this.

NoeAl responded to me above that he would be looking into it, so hopefully you and I can help him to test.
 

Dreamcast88

New Member
Hey buddy! In the new version 27.0.0 for Mac OS and Linux, "custom docks" are again available. Will there be an update to your work for us Linux users?
 

Dean Holder

New Member
Thanks, apparently it's a bug. The fonts are sent to the Browser Source when opening the Control Panel. If the Browser Source is turned off, the fonts are lost. You can resend them by opening the Control Panel again (which can be quite annoying).
So that this does not happen to you, remember to check "Shutdown source when not visible" and "Refresh browser when scene becomes active" in the properties of the Browser Source.
Anyway, It shouldn't happen and I'll try to fix it in future updates. ;)
Hi there, I have follower the instructions to the letter to install the plugin Animated-Lower-Thirds and it does not work on my laptop. I got it working on my desktop pretty easy and with no problems. My laptop is an intel i7 Lenovo Thinkpad W520, Windows 10 with all updates to the present. Can someone help? All I see is a blank preview window, the dock panel is loaded and turned on and the lower third is still not running.
 

snss

Member
Hi there, I have follower the instructions to the letter to install the plugin Animated-Lower-Thirds and it does not work on my laptop. I got it working on my desktop pretty easy and with no problems. My laptop is an intel i7 Lenovo Thinkpad W520, Windows 10 with all updates to the present. Can someone help? All I see is a blank preview window, the dock panel is loaded and turned on and the lower third is still not running.
@Dean Holder: Go to View>Docks>Custom Browser Docks and (1) delete the dock related to Animated Lower Thirds, (2) Close OBS, (3) Restart OBS and (4) Add again Animated Lower Thirds. Don't forget to hit the Apply button :D. Check and make sure that you have enabled Browser Source Hardware Acceleration(File>Settings>Advanced>Source Section)
 

Etstoo

New Member
Lovin the awesome plugin and it works great under mac os

Is there a way to show two lower thirds, e.g. when two people are on screen at the same time?
 

snss

Member
Workaround for displaying logo in Animated Lower Thirds on Linux:
(1) Go into logo folder and rename the files.
(2) Copy your png files with the same name in the logo folder(e.g.: xxx.png will be renamed into logo_1.png)
(3) Restart OBS.
(3) Check the Local File and then select the path to the browser-source.html
(e.g.:/home/<your_user>/Animated Lower Thirds/lower thirds/browser-source.html).
(3a) Specify the desired Width and Height.
(3b) Delete the CSS code from Custom CSS.
(3c) Check if you want Refresh browser when scene becomes active.
(3d) Click OK (only if you want :) :P )
(4) Restart OBS.
Enjoy logos in Animated Lower Thirds on Linux!
 

Attachments

Last edited:

snss

Member
P.S. IMPORTANT!!! Save your settings in case something is going wrong or doesn't work as expected.
 

snss

Member
I noticed the following:
(1) Reset will clear the text and the specified time. It will NOT clear the logos you have since the default logos are your images.
(2) Import is NOT working(at least for me) so you will have to add manually everything, so a backup will reduce the time you need to redo everything.
These are my findings for now.
 
Top