Waveform

Waveform 1.8.0

Kzoarhin

New Member
How do I stop the visualizer to be heavily focus on the left side? Trying to make a radial, but it just cuts off weirdly and I hate it. Any fix to this other than mirroring?

On top of this I feel like my radial isn't strong enough, I don't see anything happening for vocals getting higher, or the drums. It just feels really static to me. Is this just how it is, or is there a way to fix it?
 

Attachments

  • image_2023-11-27_032842343.png
    image_2023-11-27_032842343.png
    17.7 KB · Views: 21

Dave Verney

New Member
Hi everyone, I've only just found this thread and really want to add it to my OBS stream, but I cannot seem to get it to work. Could someone brighter than me - that's probably all of you. Give me some basic instructions to get the waveform to work please.

Really sorry to be so dumb, I'm an old DJ trying to work in a digital world
 

Phandasm

Member
Hi everyone, I've only just found this thread and really want to add it to my OBS stream, but I cannot seem to get it to work. Could someone brighter than me - that's probably all of you. Give me some basic instructions to get the waveform to work please.

Really sorry to be so dumb, I'm an old DJ trying to work in a digital world
What's the issue?
If it's been installed correctly, then you should see "Waveform Visualizer" in the menu when adding a source to a scene.
Once it's been added to a scene, you can right-click it, select properties, and then you can pick the audio source you want to capture from the topmost dropdown menu (labeled "Audio Source").

Installation instructions for each OS are listed on the release page (If you're on Mac make sure you're not mixing x64 and ARM).
 

J-PD

New Member
Does this only do flat and circular? I'm looking for an audio visualizer that will outline an avatar. See attached.
 

Attachments

  • PoorHammer Aratar visualizer.jpg
    PoorHammer Aratar visualizer.jpg
    223.6 KB · Views: 31

Phandasm

Member
Does this only do flat and circular? I'm looking for an audio visualizer that will outline an avatar. See attached.
Yep, just flat or circular.
If you just want some indicator for audio activity, you could maybe take a look at the Scale To Sound plugin.
 

Gargleblast

New Member
Hello! Does anybody know if there's a way to put a delay on the waveform animation? I have to delay my music audio source by 300ms or it's out of sync with my cam+mic and i sound 0.3 sec behind if i'm singing or humming along, but when i do that, the waveform goes out of sync with the music. I'd think the waveform would match any delay that was put on the audio source, but it doesn't seem to.
 

Phandasm

Member
Hello! Does anybody know if there's a way to put a delay on the waveform animation? I have to delay my music audio source by 300ms or it's out of sync with my cam+mic and i sound 0.3 sec behind if i'm singing or humming along, but when i do that, the waveform goes out of sync with the music. I'd think the waveform would match any delay that was put on the audio source, but it doesn't seem to.
If you're ok with capturing the "output bus" instead, that should fix it (I think).
Otherwise I can add an option to adjust audio sync in the next update, which should hopefully be Soon™
 

Gargleblast

New Member
If you're ok with capturing the "output bus" instead, that should fix it (I think).
Otherwise I can add an option to adjust audio sync in the next update, which should hopefully be Soon™
aha! this works for me, at least as a temporary solution. i'd, of course, rather not have it react to all the audio in the stream, but for the time being, it's better! xD
thanks!
 

Phandasm

Member
Phandasm updated Waveform with a new update entry:

Waveform v1.8.0

  • Add 'Range' (tricolor dB range) render mode (thanks to @filiphanes)
  • Add power-of-sine windows
  • Add 'Time Variant EMA' temporal smoothing method (decouples smoothing from framerate)
  • Add Cubic interpolation method (now default)
  • Add option to adjust audio sync
  • Increase 'FFT Size' limit to 65536 (requires 'Enable Large FFT Sizes' to be checked)
  • Update Chinese translation (thanks to @GodGun968)
  • Rename 'Gravity' setting to 'Inertia'

Read the rest of this update entry...
 

sherryw

New Member
Hello the awesome community! I am a Mac user. Just downloaded the 64 bit version file (OBS is also 64 bit). The installation was done successfully and then I reopened OBS but still don't see 'waveform' in source. Am I missing steps? Hope to learn from you! Thanks
 

Phandasm

Member
Hello the awesome community! I am a Mac user. Just downloaded the 64 bit version file (OBS is also 64 bit). The installation was done successfully and then I reopened OBS but still don't see 'waveform' in source. Am I missing steps? Hope to learn from you! Thanks
Make sure you're not mixing x64 and ARM.
If you have an Intel Mac then you need the "x86_64" version.
The newer ARM (aka apple silicon) Macs can run either version, but it has to match your OBS.

If your OBS is x64 then grab the x86_64 version, otherwise grab arm64.
 

sherryw

New Member
Make sure you're not mixing x64 and ARM.
If you have an Intel Mac then you need the "x86_64" version.
The newer ARM (aka apple silicon) Macs can run either version, but it has to match your OBS.

If your OBS is x64 then grab the x86_64 version, otherwise grab arm64.
Oh I think I installed the wrong version. My mac is M1 and I installed x86_64 waveform. Could you please let me know if I need to and how to uninstall x86_64 waveform?
 

Phandasm

Member
Oh I think I installed the wrong version. My mac is M1 and I installed x86_64 waveform. Could you please let me know if I need to and how to uninstall x86_64 waveform?
Pretty sure you can just install the other one over it.
Worst case scenario you can manually delete it from from your plugins folder which i believe is "/Library/Application Support/obs-studio/plugins"
I'm not a Mac user though so I'm just going off memory here.
 

Jerrid80

New Member
I'm a little confused. I'm a Mac user. I just downloaded the arm64 installer, but when I installed, Sonoma said I needed Rosetta to run it. I thought this was native...
 

Phandasm

Member
I'm a little confused. I'm a Mac user. I just downloaded the arm64 installer, but when I installed, Sonoma said I needed Rosetta to run it. I thought this was native...
It said that when running the installer? Or when trying to run OBS afterward?
The waveform binary is definitely native ARM, but I'm not actually sure about the installer itself.
 

Jerrid80

New Member
It said that when running the installer? Or when trying to run OBS afterward?
The waveform binary is definitely native ARM, but I'm not actually sure about the installer itself.
I guess it was just the installer. Checking the Activity Monitor, no instance of Rosetta is running while OBS is open.
 
Top