Unfortunately, I think G-SYNC might be my issue.

jeanmonday

New Member
PROBLEM
Unable to record buttery-smooth 60fps gameplays without having to run current monitor through HDMI and being forced to play games at 60Hz with VSync enabled.

SYSTEM SPECS
Lenovo Legion Y720 (Laptop)
  • Intel® Core™ i7-7700HQ (2.80GHz)
  • NVIDIA® GeForce® GTX 1060 (6GB)
  • 16GB (2 × 8GB) DDR4-2400MHz
  • Windows 10 Home (version 20H2)

I also have a Dell S2417DG, which is a 1440p 144Hz monitor. Though, I only run it at 1080p 120Hz with G-SYNC enabled through Mini DisplayPort. Just wanna make clear that, when I say Mini DisplayPort, I mean a cable that has a regular DisplayPort on one end connected to the monitor and a Mini DisplayPort on the other end connected to the laptop. I know this monitor is overkill for my system, but past me didn’t know enough about patience and technology to notice that.

Since I have to post at least one log file, I took the time to run three tests on Halo: The Master Chief Collection—which is one of my favorite games that my system can run well over 120fps—and give you the detailed settings I used for them as well as the .mp4 video files, in case you wanna take a closer look to my problem. Without further ado, here's the material:

WINDOWS SETTINGS
Settings > Gaming
  • Game Bar: Off
  • Captures: Off
  • Game Mode: On

OBS SETTINGS
OBS > Settings > Output > Recording
  • Recording Path: C: drive*
  • Recording format: flv
  • Encoder: NVIDIA NVENC H.264 (new)
  • Rate Control: CQP
  • CQ Level: 27
  • Keyframe Interval: 2
  • Preset: Quality
  • Profile: High
  • Look-ahead: Unchecked
  • Psycho Visual Tuning: Checked
  • Max B-frames: 2
OBS > Settings > Video
  • Base (Canvas) Resolution: 1920x1080
  • Output (Scaled) Resolution: 1920x1080
  • Downscale Filter: Bicubic (Sharpened scaling, 16 samples)
  • Common FPS Values: 60
OBS > Settings > Advanced > General
  • Process Priority: High
OBS > Settings > Advanced > Video
  • Renderer: Direct3D 11
  • Color Format: NV12
  • Color Space: 709
  • Color Range: Partial
*OBS is installed on the C: drive (Samsung PM961 Polaris 128GB M.2 SSD) but I run my games from my D: drive (Seagate ST1000LM035 1TB SATA HDD).

SETTINGS - TEST #1
NVIDIA Control Panel > Manage 3D settings > Global settings
  • Max Frame Rate: 117FPS
  • Monitor Technology: G-SYNC
  • Vertical sync: On
NVIDIA Control Panel > Change resolution
  • Connector: DisplayPort - PC display
  • Resolution: 1920 × 1080
  • Refresh rate: 120Hz
NVIDIA Control Panel > Set up G-SYNC
  • Enable G-SYNC, G-SYNC Compatible: Checked
  • Enable for fullscreen mode: Selected
Halo: The Master Chief Collection
  • WINDOW MODE: FULLSCREEN
  • RESOLUTION SETTINGS: 1920x1080
  • V-SYNC: OFF
  • FRAMERATE LIMIT: 120 FPS
  • GRAPHICS QUALITY: ENHANCED

SETTINGS - TEST #2
NVIDIA Control Panel > Manage 3D settings > Global settings
  • Max Frame Rate: Off
  • Monitor Technology: Fixed Refresh
  • Vertical sync: On
NVIDIA Control Panel > Change resolution
  • Connector: DisplayPort - PC display
  • Resolution: 1920 × 1080
  • Refresh rate: 120Hz
NVIDIA Control Panel > Set up G-SYNC
  • Enable G-SYNC, G-SYNC Compatible: Unchecked
Halo: The Master Chief Collection
  • WINDOW MODE: FULLSCREEN
  • RESOLUTION SETTINGS: 1920x1080
  • V-SYNC: OFF
  • FRAMERATE LIMIT: 120 FPS
  • GRAPHICS QUALITY: ENHANCED

SETTINGS - TEST #3
NVIDIA Control Panel > Manage 3D settings > Global settings
  • Max Frame Rate: Off
  • Vertical sync: On
NVIDIA Control Panel > Change resolution
  • Connector: HDMI - HDTV
  • Resolution: 1920 × 1080
  • Refresh rate: 60Hz
Halo: The Master Chief Collection
  • WINDOW MODE: FULLSCREEN
  • RESOLUTION SETTINGS: 1920x1080
  • V-SYNC: OFF
  • FRAMERATE LIMIT: 60 FPS
  • GRAPHICS QUALITY: ENHANCED
.MP4 FILES

So, as you noticed, TEST #3 has way better frame pacing than the previous ones. This is what gives it the buttery-smooth look (except for occasional hitches here and there which are pretty much normal), at the expense of higher input lag and less FPS while gaming, obviously.

Since G-SYNC is constantly updating the monitor’s refresh rate to prevent some tearing, it’s basically impossible to get stable frame pacing (AKA ‘frametimes’) but only when the framerate can’t go past the refresh rate… which doesn’t happen in this case scenario! My system can go past 120fps in this game, so why isn’t it recording as expected like Shadowplay would?!

Could it be that I’m ignorant to how some of this stuff works? Or maybe smooth recordings are only achieved on desktop PC environments where you just use a capture card and call it a day? Could it be the Mini DisplayPort cable? I’m so confused!

Please, if you have any questions/suggestions, let me know. This has been a learning journey of almost a year and I hope I’m not doomed to record 30fps videos until I get a desktop PC. Also, feel free to correct me if I’m wrong in some of the stuff I said in this thread, it’s always good to learn.

Anyways, thank you for reading.
 

Attachments

jeanmonday

New Member
SET CBR in encoder Settings
set your refreshrate to 120hz the framerate is dubble of the framerate of the video
I don't use CBR merely because, having a constant bitrate is not as good as having a quality target value like with CQP.

Oh, and the first two tests I posted here were made running the monitor at 120Hz, if you read the NVIDIA Control Panel settings section on the post.

But, just so you're left satisfied... I've tested with CBR countless times before and I get the same results on the output file. And is not like I'm getting skipped frames or rendering lag using CBR or anything, really.
 
Top