Question / Help Tons of "freezing" on Twitch, but not reported in OBS or with in-game issues


New Member
Hey guys! I've run into some issues with my stream with a new setup. First of all (since I know this is what you're all gonna ask for), I am work right now but I will update this thread as soon as I have logs and data to report this evening. I will attempt to detail my issues below for now, with video references.

I recently purchased a Vega 56 (PowerColor Red Dragon on Performance BIOS, not currently OCd or UVd past factory default) to go with my Ryzen 7 1700, upgrading from a GTX 980. I've absolutely LOVED the performance increase it's gotten me in games, but I'm having a lot of issues when streaming Apex Legends. I play a lot of Apex on stream the past couple of weeks, but I've been having frame issues since the upgrade. Here's an example of the stream with the 980 (for reference). Notice the lower framerate because of my VRAM buffer being loaded (I didn't know that at the time of recording). Otherwise, the experience is watchable even if a bit lower than 60 fps.

When using AMD VCE on the Vega 56 (which I figured would be fine because my 980 used NVENC fine), OBS reported a ton of dropped, skipped, or lagged frames, with some impact on the end viewer. Here's what it looked like using AMD VCE in OBS.

So I heard that VCE is not as good as NVENC, so I switched to x264 (which I should have been using anyways, in retrospect, being that I have a Ryzen 1700). However, this produced worse results. Oddly, the performance impact is still negligible; none of these issues occur in-game or are reported in OBS. There's a minor average framerate decrease, but that's to be expected at times.

CPU is around 60% load, pretty evenly split among threads, depending on x264 settings

Here's what I have tried in OBS, Windows, and in-game so far:
Ensured Windows Game Mode and Bar was completely disabled (it was from the beginning)
Enabled/disabled V-Sync/Freesync in-game
Adjusted stream resolution, bit rate, encoding speed
Lowered in-game details settings (I thought for a while it was from particle effects, but it had no impact)
Disabling/enabling limit capture FPS (it is normally always on)
Display vs. application capture (doesn't matter)

Things I've still yet to do (will update with more info later):
Update to Radeon 19.2.2 (currently on 19.2.1, Apex ready driver)
BIOS update to most recent (AGESA has better RAM support again so I can take it up to 3200mhz as designed)
Try fullscreen as opposed to borderless windowed
Fixing a lower framerate (I am starting to play competitively and want to avoid this as much as possible)
Lowering speed past "fast'

Currently my settings are x264, 720p60, veryfast speed, 5000 bitrate (I used to stream OW at 6000 1080p60 so it should be fine).

I will test and log it in Overwatch tonight, to see if it's just Apex or not, as well as run logs in Apex and post them this evening.

Please let me know if you have any ideas, or things you also need from me. I really, really appreciate every bit of help (I'll totally put your channel on my auto-host and credits if we can get it working).


New Member
UPDATE: I actually solved it through disabling Freesync in the Radeon drivers. I don't know how the hell I missed it but here we are!