Source Record

Source Record 0.2.6

MichaelvanLaar

New Member
Great plugin, makes my life easier because it solves my problem that I need a recording of the raw webcam input (with green screen) while sending an altered version (using the chroma key and a background image) to a webinar tool using the virtual cam.

However, recording any audio using the Source Record plugin only works in my setup when two conditions are met:
  1. The audio source must be specified in the filter settings. Without this setting, the recording contains no audio.
  2. The audio source which was selected in the filter settings must be included and active in the scene which is active while recording – even if this is not the scene with the Source Record filter.
Typically, I want to record a specific mic input along with the raw webcam input. So in my case it is not a big problem because this mic input is activated in all scenes anyway. I have one scene for the raw webcam input and a second “presentation” scene with a source mirror version of the webcam input with the chroma key applied. The “presentation” scene is the active scene (which is used for the virtual cam output) while the first scene with the raw webcam input is the one which is recorded. As soon as I deactivate or delete the mic input source in the “presentation” scene, the recording has no sound, although the same mic source is an active source in the “raw‘ scene – in addition to being specifically selected in the filter settings. But obviously the plugin can’t access the mic source as soon as it is not an active source in the active scene.
 

doctordarling

New Member
I'm really really excited to get this to work! Alas, I'm having trouble. My videos are sped up. Anyone else have this issue? I'm new to recording, but not streaming (want to record stuff for youtube content without stream nonsense). I'm testing it with a full record, and source recordings of webcam & gameplay separately. The separate gameplay/webcam ones are way sped up. The base recording is not, so I'm not sure where the discrepancy is.


is my log file i think I did that right
 

tiagoventura

New Member
I'm really really excited to get this to work! Alas, I'm having trouble. My videos are sped up. Anyone else have this issue? I'm new to recording, but not streaming (want to record stuff for youtube content without stream nonsense). I'm testing it with a full record, and source recordings of webcam & gameplay separately. The separate gameplay/webcam ones are way sped up. The base recording is not, so I'm not sure where the discrepancy is.


is my log file i think I did that right
you are performing on the limit of your hardware capability, take a look on task manager during your recordings and change settings...
 

Pudding

New Member
Would it be possible to make this plugin compatible with Audio sources? My Editing Program doesnt recognize multiple audio tracks.
 

ZoBro23

New Member
Hi, great work on the plugin! I have a question, however. What does the replay buffer do? Or rather, how can I use it? It doesn't seem to be working, and the video explanation isn't useful in that part.
 

Rodorenn

New Member
I've been trying to get this to work for a while now. My use case for Source Record is to record my camera and monitor device in OBS while streaming. My camera is in a nested scene within my game play scene, and my goal is to use the replay buffer to capture interesting moments that I can convert into TikToks, YouTube shorts, and longer form YouTube / Facebook videos. The camera device records just fine in Source Record, but the display capture device for my monitor does not.

OBS Studio Version - 27.1.3 (64 bit)
Source Record version - 0.2.6

I just uninstalled and reinstalled OBS so that Source Record is the only plugin running. Below is how I have my devices configured in OBS:

Primary Monitor is a display capture device. Source record is set to Streaming or recording with a 90s replay buffer. Recording is configured to record to mkv with x264 encoder.

Camera is a video capture device in a nested scene with Source Record set to streaming or recording. Recording is configured with NVENC encoder and mkv format with a 90s replay buffer.

OBS Recording is set to NVENC encoder.

My goal is to be able to use the Replay buffer to record separate clips after exciting or interesting moments, as well as record the entire stream with clean gameplay (no stream alerts or overlays) and clean full resolution camera. The attached log file contains a fresh session where I attempt to use the replay buffer to create a clip, and then start recording a longer form video.

Test #1 (Replay) results - Camera source recorded successfully, stream scene recorded successfully, monitor source did not record
06:12:22.563: ==== Replay Buffer Start ===========================================
06:12:29.891: [ffmpeg muxer: 'Source Record - Camera'] Wrote replay buffer to 'C:/Recordings/Camera/Camera_Only_2021-10-11 06-12-29.mkv'
06:12:37.291: [ffmpeg muxer: 'Replay Buffer'] Wrote replay buffer to 'C:/Recordings/Recording/Replay 2021-10-11 06-12-37.mkv'
06:12:47.549: Output 'Replay Buffer': stopping
06:12:47.549: Output 'Replay Buffer': Total frames output: 1486
06:12:47.549: Output 'Replay Buffer': Total drawn frames: 1500
06:12:47.549: ==== Replay Buffer Stop ============================================

Test #2 (Recording) results - Camera source recorded successfully, stream scene recorded successfully, monitor source did not record
06:12:52.119: ==== Recording Start ===============================================
06:12:52.119: [ffmpeg muxer: 'adv_file_output'] Writing file 'C:/Recordings/Recording/2021-10-11 06-12-52.mkv'...
06:12:52.141: [ffmpeg muxer: 'Source Record - Gameplay'] Writing file 'C:/Recordings/Primary Monitor/Gameplay_Only_2021-10-11 06-12-52.mkv'...
06:12:52.141: [ffmpeg muxer: 'Source Record - Camera'] Writing file 'C:/Recordings/Camera/Camera_Only_2021-10-11 06-12-52.mkv'...
06:13:06.859: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Recordings/Recording/2021-10-11 06-12-52.mkv' stopped
06:13:06.859: Output 'adv_file_output': stopping
06:13:06.859: Output 'adv_file_output': Total frames output: 870
06:13:06.859: Output 'adv_file_output': Total drawn frames: 884
06:13:06.859: ==== Recording Stop ================================================
06:13:06.878: [ffmpeg muxer: 'Source Record - Camera'] Output of file 'C:/Recordings/Camera/Camera_Only_2021-10-11 06-12-52.mkv' stopped

Full log file attached

Behavior is the same regardless of encoder used on the monitor source (x264 vs NVENC). OBS also still freezes on exit.
 

Attachments

ojaneri

New Member
Hi!

Thank you for your plugin.

But I can´t get it to work.

Copied all files from the zip file, tried Windows installer, but no success.

It won´t appear on Filter list on OBS. Tried on Scene and Video source, Video/Audio and Effects filters, without success.

My OBS Studio is 24.0.3 (64bit).

Anyone can point me to the right direction? Thank you!
 

ojaneri

New Member
Hi!

Thank you for your plugin.

But I can´t get it to work.

Copied all files from the zip file, tried Windows installer, but no success.

It won´t appear on Filter list on OBS. Tried on Scene and Video source, Video/Audio and Effects filters, without success.

My OBS Studio is 24.0.3 (64bit).

Anyone can point me to the right direction? Thank you!
Just realized that updating the OBS Studio to 27.1.3 solved the issue.

Keeping this topic so it can help anyone on the future. UPDATE FIRST. :)
 

fritzzes

New Member
hello! sorry for the inconvenience, but is it possible to get access to the older downloads for this please? i'm on obs 24.0.3 and would love to be able to use this plugin. thank you so much for your work + time!
 

Alpha Divine

New Member
Have been using this plugin for a while now to record my webcam and then my desktop separate but recently it seems to not want to record multiple sources into their own file. It will only record one source and seem to just ignore the other. Any suggesting on what the cause could be?
 

MrFrenglish

Member
Hopefully Im going to find an answer here. I started using Source Record today.

My main objective is to have pure gameplay (no webcam, no mic, no alerts) in my recordings when Im streaming.

So game + cam + mic + alerts in my stream
Game only in my recordings

I managed to remove the cam and mic from my recording. But not the alerts. I cannot figure for the love of baby jesus how to remove the alerts. I currently have:

Game + alerts in my recordings (streamlabs).

Anyone know how I can do that?
 

MrFrenglish

Member
I fugired it out.

But I discovered something.

I'm not sur why, but If I use the x264 encoder with record source, it shoots my cpu usage to 60-70-80% when normally I would have 15-25% cpu usage with a preset of medium in the normal settings of OBS.
 

MrFrenglish

Member
And I figured it out too.

SR records only with your base resolution. So if your base resolution is 1440p (like me), it will record 1440p and theres no way to change the resolution. That is why my cpu usage was skyrocketing to 60-70-80%. Hopefully we get this option eventually. Unless I missed something of course.
 
Top