DwarvenHulk

New Member
I am having issues with skipped frames on x264 even though my CPU usage is 4% on the OBS stats panel, and with the task manager the CPU output is less than 8%. I did a bunch of live stream tests on a private twitch account and I was able to get everything to run smoothly on the Slow preset with about 22% CPU usage on task manager at 1080p@60fps with 0% skipped frames, but changed to Medium just to be careful of any spikes or whatnot (plus to my understanding Medium is more than adequate). However, when I am on my actual streaming account I will 90%+ skipped frames with absolutely no setting changes what so ever. The only way I can get things to run smoothly on my normal streaming account is to change over to NVENC (new) for the encoder. But my GPU is only a 1070, so this ends up maxing my GPU out unless I make a bunch of graphics setting changes on the game. I also monitor my CPU temps when on x264 and rarely get above 75C. Somebody with a bigger brain than me please give me a hand because this just isn't making any sense to me or my streaming partner. Attached are the logs of both my last successful test on the private account where I was satisfied with the results, and the failed stream that didn't have any changes that I am aware of. I may have increased the fps from 48 to 60, I can't remember when I made that change, however I went back to 48 after the bad stream attempt and it changed nothing.

I'm running:
Ryzen 9 5950x
AMD Dark Hero 8 X570
4x8GB DDR4 3200 G.Skill Trident
EVGA GeForce GTX 1070
Cooler Master Hyper 212 CPU Air Cooler
Samson 980 Pro M.2 2280 1TB
About 11 TB of HDD storage
 

Attachments

  • Successful Test.txt
    14.5 KB · Views: 26
  • Failed Stream.txt
    18.9 KB · Views: 23

cyclemat

Active Member
use 30 or 60 FPS

not 48 and on you successfull i didnt see any stream session why you didnt use nvenc on a single PC setup ?

did you have set the windows energy settings to high performance ?
 

koala

Active Member
18:25:28.056: Video stopped, number of skipped frames due to encoding lag: 14264/14356 (99.4%)
Almost all frames were not encoded in time, so they were dropped. Usually a sign of severe system (CPU) overload, but your CPU is quite powerful, and if you say your CPU had only 4% usage, it's definitely not overloaded. However, it is said Windows 11 has performance issues with AMD CPUs. I don't know the exact issues, and if they apply to OBS. If the Windows CPU scheduler is activating not enough CPU cores for OBS, this may lead to the issue you observe, but that's only a guess from me.
It's not possible to compare with your successful test, because that other logfile doesn't contain any recording or streaming session. It's just OBS start and stop.
 

DwarvenHulk

New Member
use 30 or 60 FPS

not 48 and on you successfull i didnt see any stream session why you didnt use nvenc on a single PC setup ?

did you have set the windows energy settings to high performance ?
I read that 48 was a descent framerate to drop to without going all the way to 30 so that's why I attempted it.

I didn't use NVENC because my CPU should he able to handle it and my GPU can't handle both the game and encoder without changing all my game settings to low, I was attempting to be able to get full usage from both components for a better stream. Which I was able to do on my successful stream just fine. I may have ended my successful stream too quick to get any info, when I get home from work I will try to upload the session before that, which if I remember correctly was also successful but I was using the Slow preset at 48fps.

I haven't touched anything on windows 11 set up, I just built this rig and left everything at default.

I'm pretty sure I updated the bios? I would have to check.
 

DwarvenHulk

New Member
This should be a successful stream...I honestly don't know how to read these so if its wrong I apologize.
 

Attachments

  • Successful Test 2.txt
    19.5 KB · Views: 24

koala

Active Member
A strange difference I see in your two logfiles is this:
18:25:28.448: run_program_init: 13052.9 ms ("failed" stream)
and
20:08:08.587: run_program_init: 3478.17 ms ("sucessful" stream)

This is the time OBS needs to start. It needs 13 seconds for startup with the failed stream later, and only 3.4 seconds for the successful stream. I really don't know what might cause this, since none of the sub-entries indicate an issue. I can only guess, and given reports about Windows 11 still not properly supporting AMD CPUs leading to performance issues, I guess you issue might have something to do with this.

I found this AMD kb article:
Make sure you have properly updated chipset drivers according to the described "issue 2".
 

DwarvenHulk

New Member
A strange difference I see in your two logfiles is this:
18:25:28.448: run_program_init: 13052.9 ms ("failed" stream)
and
20:08:08.587: run_program_init: 3478.17 ms ("sucessful" stream)

This is the time OBS needs to start. It needs 13 seconds for startup with the failed stream later, and only 3.4 seconds for the successful stream. I really don't know what might cause this, since none of the sub-entries indicate an issue. I can only guess, and given reports about Windows 11 still not properly supporting AMD CPUs leading to performance issues, I guess you issue might have something to do with this.

I found this AMD kb article:
Make sure you have properly updated chipset drivers according to the described "issue 2".

I gave this a shot, will see how it goes. From my limited knowledge, I feel like this makes sense because I had thought that I figured it out during my testing streams when I started OBS as administrator. I tested multiple times and when I ran OBS as admin everything worked as intended. But when I did this during my normal stream it did not appear to do jack squat.
 

DwarvenHulk

New Member
Just tried another stream and it still happened even after updating the bios and the Issue 2 fix stated above for AMD chip compatibility with Windows 11. I'm at a total loss. Here are the logs for the newest attempt on the x264 encoder,
 

Attachments

  • 3-1-2022 Failed Stream.txt
    82.2 KB · Views: 9

DwarvenHulk

New Member
please try set you OBS FPS to 30
I certainly can but I'm not convinced that's the issue when I'm on my countdown screen. Or when ive been battling this for months and that's of course the first thing I change and I see absolutely zero difference.
 

DwarvenHulk

New Member
I FOUND THE ISSUE!!! I can't believe I missed this. In the advanced settings on OBS there is a "Process Priority" option. It was set to "Normal" by default. As soon as I set it "Above Normal" all my issues stopped. Zero Skipped Frames due to Encoding.

One of my tech support guys at work was telling me about it. I guess Windows 11 tries to be "smart" and stops programs from accessing cores it doesn't feel the program needs. Sometimes Windows 11 changes a programs affinity (task manager>details>right click program>set affinity). Go there and select all processing cores. This wasn't the case for me, however I'm sure someone would benefit from that info.

Thanks for all the help everyone.
 
Top