New Member
Major Camera Latency/Buffering Issue Help!

I’ve been trying to solve this issue the past few days. It’s been driving me nuts!
So, I’m running a Sony A6000 as a video capture device and it has buffer/latency/lag. But not any normal lag like the one you change your audio a few ms forward or back. It’s like a hard stutter and it’s usually when I move my head or arms. So here’s what I have done so far and am running out of options fast!! PLEASE HELP.

I have a HD60s, Elgato cam link, Sony A6000, Sony ZV-1 tried it all..

I dl Elgato 4K Capture app changed the settings like supposed to and it ran so smooth no problems w/ A6000, HD60s and Cam Link. But when I open Obs the problems start.

I changed all setting to custom. And enabled/disabled buffering.
I lowered iso, 1080 60, 1080 30, shutter speed & file size on camera.
I changed USB ports.
I updated all firmware.
Uninstalled then reinstalled Obs.
Rollback OBS.
Change priority.
Running as Admin.
Changed Color range and settings.
Lowered monitor Htz.
Changed from dual to single monitor.
Running all performance on Maximum.
Basically everything you can think of.

Everything does work and is smooth like butter on Elgato 4K Capture. I even tried to do a window capture on Obs but right when I open that app, boom it starts again. I know it’s an OBS problem because everything works fine until it’s open.

Running a Ryzen 5900x, 3060ti, b550 tomahawk, ripsaw ddr4 3200 (4x8gb)

If you find a fix for this your a dang legend.
LOG File


New Member
Hi there, I have a similiar issue... 2x Sony Alpha 5100 and a Cam Link Pro... After some hours the video from the camera get's laggy and looks like it doubles some frames... so no clear 59.94 or 50 FPS... After restarting it works again for some time...
In 4K Utility everything is smooth and fine.....

Tried almost everything... also upgraded my PC with new CPU, Mainboard, GPU etc....

Can't help you with this, but you are not alone :(


New Member
so i have just purchased the a6000 and the cam link 4k
i was having the same issues pretty much
live view would show up on all platfroms {windows camera, elgato capture hub and even streamlabs}
but not on obs it would show up at first but then freeze instantly and then after a while would just go blank
i tried all different camera settings, tried a BETA obs, different USB 3 ports etc.. nothing seemed to be working
until i thought i wonder if it work if i plugged the camlink 4k into a usb2 port
now although when i opened elgato camera hub it instantly recognised that i had plugged the cam link into a usb 2 port
but upon openening OBS and setting up a new video capture, camlink4k was still showing up and to my avail it is now displaying my live view from the camera and continues to do so whilst i am typing this thread
all i need to do now is try and up the camera settings back to a good quality picture and i should be set
i hope this helps someone else as i due to send it all back

RTX 3060TI
32GB 3600MHZ RAM