Question / Help OBS lagging while I'm playing-streaming (updated)

#1
Hi!
I have a problem with streaming. The game scene is still lagging in OBS too and when I start then the stream is lagging too. I tried a lot of settings to get a normal quality / FPS. I would like to stream GTA V / PUBG / Dota 2 etc. I can stream Dota 2 without lag, 30FPS, Bilinear (Base res: 1920x1080 | Output res: 1280x720), 6k bitrate, and x264, but the scene is still lagging in OBS. Last year I could stream without lagging with better options, now I can't, why? What options should I use?

Computer:
Motherboard: ASUS ROG STRIX X370-F Gaming Motherboard
CPU: AMD Ryzen 7 1700X
Videocard: Gigabyte Radeon R9 270X
Ram: G.SKILL Aegis 16GB (2x8GB) DDR4 3000MHz F4-3000C16D-16GISB
Windows 10 Pro 64bit
Log File: https://obsproject.com/logs/f4bNFP_j2_cnTdnK

Thank you very much!
 

Attachments

Last edited:
#3
You have a good CPU, but the GPU card is not so good. It is the bottleneck in your system. You need to get a better GPU card.

For a Ryzen 1700X system, pair it with a GTX 1070//RTX 2070 and you'll be much happier. You will get way higher FPS for in game play (100+ FPS) and be able to do x264 at 1920x1080@6000@60FPS.
 
#4
You have a good CPU, but the GPU card is not so good. It is the bottleneck in your system. You need to get a better GPU card.

For a Ryzen 1700X system, pair it with a GTX 1070//RTX 2070 and you'll be much happier. You will get way higher FPS for in game play (100+ FPS) and be able to do x264 at 1920x1080@6000@60FPS.
Okey, thank you very much!
 
#5
Did you have the newest Chipset Driver? I changes my Cpu a few days ago from the Ryzen 5 1600X to the 2700X.
With the 1600X i was able to use the x264 only in Veryfast smooth.
Then i changed and it was the same. CPU with more power and cores...
I checked the site of my motherboard (Gigabyte) and downloaded the newest driver for the Chipset.
After updating, everything runs smooth in faster without frame drops.
 
#6
Did you have the newest Chipset Driver? I changes my Cpu a few days ago from the Ryzen 5 1600X to the 2700X.
With the 1600X i was able to use the x264 only in Veryfast smooth.
Then i changed and it was the same. CPU with more power and cores...
I checked the site of my motherboard (Gigabyte) and downloaded the newest driver for the Chipset.
After updating, everything runs smooth in faster without frame drops.
I'll check it, thank you very much!
 
Top