OBS branch with AMD VCE support.

chummy

Member
bframes will allow for better compression and hence, more quality per same bitrate so they are worth it.
I dont make streaming, so for local recording which i do they are not that big matter but yet is good to have. Too much Bframes in some cases give worse quality. Current case is the Quicksync in OBS-Studio using 7 consecutive Bframes which cause ugly random frames in high motion scenes with lower bitrate.

I using Studio(MFVCE) because their compatibility with 3rd party OSD hooks while OBS Classic has major problem with it,
Now with AMF SDK being Open source will Jackun can we expect implement their Branch there in Studio?
 

dping

Active Member
I dont make streaming, so for local recording which i do they are not that big matter but yet is good to have. Too much Bframes in some cases give worse quality. Current case is the Quicksync in OBS-Studio using 7 consecutive Bframes which cause ugly random frames in high motion scenes with lower bitrate.

I using Studio(MFVCE) because their compatibility with 3rd party OSD hooks while OBS Classic has major problem with it,
Now with AMF SDK being Open source will Jackun can we expect implement their Branch there in Studio?
From my understanding @jackun has helped @Xaymar get started with his fork to which I believe Xaymar is heading up his own project with (I'm excited about his builds).

the second part was @Jim wanted to ensure that there was an open sourced licence to VCE (particularly AMF) before a merger can happen with the main OBS Studios branch. This has happened over the past two weeks thanks to Robert Hallock and releasing VCE with the GPUOpen.

I do not make any decisions related to what happens from here, but what I can tell you is we are closer to getting in the main branch than ever before and I'm confident that once we get stable with Xaymar's fork, you can expect to see things happening.
 

Jason Absher

New Member
i tried installing this plugin into my studio install, and now the studio crashes everytime.

also i am trying to use OBS to record using the VCE, and i have a 290X. i use a 1440p monitor and when i try to record with no downscaling it says encoder initialization failed, but if i downscale to 1080p then it works. is it just not possible to record in 1440p with this setup...i feel like there should be no issue.
 

dping

Active Member
@Jason Absher this plugin is for OBS-Classic. OBS-Studio comes with a VCE encoder already or you can try this one with Studio: https://obsproject.com/forum/resources/vce-based-encoder-amd-media-framework.427/

Not sure about the limitations of the 290X VCE, but its possible that 1440p is too much. Someone else might be able to shed more light on this.
@Jason Absher
VCE 1 and 2 have a max output of 1920x1200 from my understanding. VCE 3 and 4 have raised this to up to 4K. that being said, the API that supports higher than 1920x1200 is required for the encoder to take advantage of this (and remove software limitation) for VCE 3 and 4 GPUs.

You have a VCE 2 GPU. as well as @jackun 's build is based on Media SDK 1.1 which had issues for anything above 1080p for output.

Feel free to test with the build that Jack0r linked but note, I would uninstall the previous build before updating to the newer one. I ended up with 6 (5 VCE) encoder options in my list when I installed straight over. Note that because what I said above, you will still end up with the same limitation on a VCE 2 based card.
 

D4rKiTo

New Member
Hello. I've issues streaming with VCE (Tested obs classic and obs studio). If I play a game with puts my gpu at 100% usage then my streams are very choppy and laggy (no fps drop ingame). How can I fix this? Im using bitrates between 4000 and 10000 at 1080@60fps. GPU: RX 470 4GB.
 

D4rKiTo

New Member
TVg6GXz.png

Audio default settings.

tOfz52Q.png


For streaming I just lower bitrate to 4000-5000. Same effect. For example, in Overwatch, if I leave all epic+frames unlimited stream/recording is like 20fps 2 second, then 60fps 1 second, then 2-5 sec freeze.. My gameplay never drops fps below 80-90. If I change obs settings to 1280x720 and in game settings to 60fps limit stream/recording goes better.

I feel like if I hit 100% usage by a game OBS doesn't priorize so I don't lose any fps in gameplay but hurts recording/streaming.

Another example:

https://www.youtube.com/watch?v=bBF6Xwx5phA (starts at min 2:00).

Today seems to work better, but still lagging 2-3 secs every a few seconds. Now I don't now if it's related to VCE or to OBS, because I had a lot problems to make OBS record the screen in game (as you can see before min 2) (tried with Game capture, Window capture, Display capture). I have dual screen and I see obs lagged (I can see it looking at volume bar). I need to change scene/delete source a few times and go to in game till it works.

Game is windowed with no borders. Same results with full screen.


PD: I didn't have any problems like this with my old 280x.


OBS log: http://pastebin.com/hmeewj8Q
 
Last edited:

chummy

Member
A bit offtopic but someone with GCN 1.2 or higher there with Win 10 installed? If yes i wanted someone with GCN 1.2 or higher to test Win10 GameDVR recording.

Win10 GameDVr is the only recording software out there for now capable to hook UWP DX12 games and yet to hook any other Dx12 game.

Now the problem(always AMD) Win10 Game DVR is bugged for GCN 1.0 & 1.1 since november 2015 when AMD driver changed from OVE to MFT. It cause image artifacting in low complexity scenes randomly, like in menu or some lower Graphics games like CS.

I just not see any reporting from people with VCE 3.0+ about this issue and was concerned if even VCE 3.0+ has this same problem.

I have a GTX770 and NVENC 1.0 and there the Game DVR app works just fine.
 
I want to try VCE, but am afraid of breaking the bandwidth rules with Twitch..how do I properly set it up not to? I looked through like 7 pages of this giant thread and didn't see any.

I'm on OBS studio 0.15.4. I have a 390x.
FPS: 30
Bitrate: 2700
Max Bitrate: 3000
 

banOBS

New Member
Hello, I have a Fury X and can record just fine if I rescale output from my native 1440p to 1080p, but I can't record without rescaling at all. The "Start recording" button simply does nothing. Attached are my setting. What could be causing this?
 

Attachments

  • obs_settings.png
    obs_settings.png
    79.1 KB · Views: 154

dping

Active Member

Benman2785

Member
I want to try VCE, but am afraid of breaking the bandwidth rules with Twitch..how do I properly set it up not to? I looked through like 7 pages of this giant thread and didn't see any.

I'm on OBS studio 0.15.4. I have a 390x.
FPS: 30
Bitrate: 2700
Max Bitrate: 3000

ArucarD_VCE_Encoder.jpg

ArucarD_VCE_Codec.jpg


sry - found out u r on studio, not Jackuns OBS VCE fork
 

Green428

New Member
Hey Guys, I need help with settings for my Stream. I stream at 720p 30fps, at 3500 Bitrate. I don't know how to configure the encoder properly, I saw that the IDR should be 60 for 30fps, and GOP is quality of some sort. I would like some help in getting some good settings for streaming. I have a MSI R9 390, and an 8350. If anyone could help that'd be great!
 

Benman2785

Member
Hey Guys, I need help with settings for my Stream. I stream at 720p 30fps, at 3500 Bitrate. I don't know how to configure the encoder properly, I saw that the IDR should be 60 for 30fps, and GOP is quality of some sort. I would like some help in getting some good settings for streaming. I have a MSI R9 390, and an 8350. If anyone could help that'd be great!

OBS_VCE_encoder_settings_15%2660.jpg

maybe check "Force 16x16 Skip" + maybe use "5" I Pic Period + better use minQP "20" maxQP "42"
also better use 3400kbps with 1132kbps custom buffer (in codec-tab)

these would be the recommended settings for youtube video upload ->so if u upload there it would be processed faster
 

Green428

New Member
OBS_VCE_encoder_settings_15%2660.jpg

maybe check "Force 16x16 Skip" + maybe use "5" I Pic Period + better use minQP "20" maxQP "42"
also better use 3400kbps with 1132kbps custom buffer (in codec-tab)

these would be the recommended settings for youtube video upload ->so if u upload there it would be processed faster
Thanks man! I'll test them out. Appreciate the help <3
 
Top