Question / Help NVENC H264 Error

#1
Hey, it seams that every time i try to record h264 via my GPU, it doesn't work, i get an error messageevery time but when i record via my CPU, Work Perfectly...

I want to start recording with my GPU because I play mostly cpu intensive games so if i record with my GPU, I could crank some render distance and others setting higher while recording and get a better looking video out of it. ALSO Right now, if i record with my cpu setting while gaming, i can't get to 1080p 60FPS, my cpu just ping to 100% use and the recording just come out horrible since i skip frames like crazy

-I record Gameswith OBS(Obviously) and edit them later on adobe premiere and after effect
-I have posted a picture of the error message, my cpu recording settting and gpu recording setting and here is my Log file of when I got the error: https://obsproject.com/logs/aGAfq1VFGu6uWTUD
***the time i tried it for the error picture and GPU Setting picture, my recording encoder was on ''nvenc (libx264)'' and when i did it for the log file, i was on ''nvenc_h264 (libx264)'' both of these give me the same error

PC Specs:
-i7 7700k @5,00GHz
-AIO 240mm Liquid cooler
-16Go DDR4 Ram @2133MHz
-980 ti Hybrid Overclocked
-850Watt power supply
-2Tb 7'200RPM Hard Drive(this is where my recording is stored)
-250Go SSD(for windows)
 

Attachments

Narcogen

Active Member
#2
I am guessing that somewhere in your custom FFMpeg settings an invalid argument is being passed:

19:30:47.091: Failed to open video codec: Invalid argument

This message repeats for each recording attempt using NVENC.

I'm not familiar enough with it to see where the problem is. I would suggest switching to Advanced Output mode, but Standard Type under recording, and choose your encoder there without the other arguments and see if you still get the error.
 
Top