No audio track in output recording (Slackware Current)

MurdoMaclachlan

New Member
Kind of as the title says. Recording/streaming with OBS 26.1.1 on Slackware Current, the audio in the mixer shows like it's working and I can monitor it and everything, but in the output file there is no audio, and when I imported it into a video editor, it shows I don't just have silent audio, I have no audio track. I used to use an older version of OBS (21.0.2, I think) with Slackware 14.2, and that worked fine, but this is a fairly new system install, so I'm still getting used to changes.

I've attached my log file, as well as screenshots of my Audio, Stream, & Recording output settings, as well as my Advanced Audio Properties. I'm assuming the lines of interest to be:

02:08:07 PM.520: pulse-input: Server name: 'pulseaudio 14.2'
02:08:07 PM.520: pulse-input: An error occurred while getting the source info!


But I don't know how I would go about fixing that, since it doesn't say what the error is.
 

Attachments

  • Screenshot_2021-03-14_14-05-10.png
    Screenshot_2021-03-14_14-05-10.png
    48.5 KB · Views: 79
  • Screenshot_2021-03-14_14-05-38.png
    Screenshot_2021-03-14_14-05-38.png
    47.5 KB · Views: 73
  • Screenshot_2021-03-14_14-05-53.png
    Screenshot_2021-03-14_14-05-53.png
    78 KB · Views: 64
  • Screenshot_2021-03-14_14-06-07.png
    Screenshot_2021-03-14_14-06-07.png
    38.3 KB · Views: 53
  • Screenshot_2021-03-14_14-07-06.png
    Screenshot_2021-03-14_14-07-06.png
    30.8 KB · Views: 44
  • 2021-03-14 14-08-07.txt
    16.2 KB · Views: 13

mayr.petr

New Member
Kind of as the title says. Recording/streaming with OBS 26.1.1 on Slackware Current, the audio in the mixer shows like it's working and I can monitor it and everything, but in the output file there is no audio, and when I imported it into a video editor, it shows I don't just have silent audio, I have no audio track. I used to use an older version of OBS (21.0.2, I think) with Slackware 14.2, and that worked fine, but this is a fairly new system install, so I'm still getting used to changes.

I've attached my log file, as well as screenshots of my Audio, Stream, & Recording output settings, as well as my Advanced Audio Properties. I'm assuming the lines of interest to be:

02:08:07 PM.520: pulse-input: Server name: 'pulseaudio 14.2'
02:08:07 PM.520: pulse-input: An error occurred while getting the source info!


But I don't know how I would go about fixing that, since it doesn't say what the error is.

I had exactly the same problem in Slackware. Last week I managed to upgrade from 14.2 to current. That day I realized that there is this issue with sound when recording in OBS. This was really strange, because I realized that after I did some testing streams, that were just fine. In short - streaming had no sound issues, only when recording there was no audio track. No errors in log files, moreless the same configuration as yours.

The first thing I tried was some experiments with jackd. I'm not sure, but I think all that it just misconfigured now and has no real effect. Then I noticed that the prebuilt ffmpeg in slackware-current is quite limited and that it's configuration includes --disable-encoder=aac. So I had to rebuild it from source. After rebuilding and installing ffmpeg 4.4 my recordings from OBS again include audio track. Good luck!
 

Attachments

  • ffmpeg_configure.log
    41.5 KB · Views: 70

MurdoMaclachlan

New Member
I had exactly the same problem in Slackware. Last week I managed to upgrade from 14.2 to current. That day I realized that there is this issue with sound when recording in OBS. This was really strange, because I realized that after I did some testing streams, that were just fine. In short - streaming had no sound issues, only when recording there was no audio track. No errors in log files, moreless the same configuration as yours.

The first thing I tried was some experiments with jackd. I'm not sure, but I think all that it just misconfigured now and has no real effect. Then I noticed that the prebuilt ffmpeg in slackware-current is quite limited and that it's configuration includes --disable-encoder=aac. So I had to rebuild it from source. After rebuilding and installing ffmpeg 4.4 my recordings from OBS again include audio track. Good luck!

Looks like this has fixed it! Thank you so much!
 
Top