Question / Help No audio on stream or recording, only on monitor

gavi

New Member
Hey!

So, this issue is really weird, and every solution I've found so far hasn't fixed the issue. I can hear the audio locally when I am monitoring ("monitor and output") the sound - regardless of source. I have an audio file, two NDI sources (Skype), desktop audio, and a microphone. All of these sound fine when I monitor them, but when I stream or record... nada. Silence.

I have checked audio tracks, trying all on 1, all on all, splitting them up, resetting all user preferences, changing the sample rate... and nothing seems to help.
On the other hand, I have the same scenes set up on SLOBS, and am having no issues at all.

Why then, you might be asking, are you even trying to fix it in OBS if it works in SLOBS?
Well, SLOBS doesn't let me set the bounding box type (as far as I can find) so my NDI sources jump around if there is any fluctuation in the incoming Skype feed's bandwidth (example).

So at the moment, I'm either stuck with jumpy video, or no sound.

Help?
(Attached are screenshots of my settings, and the log. Note: I am only trying to record four of the audio tracks, but even when "desktop audio" is also marked in tracks 1-6 I get no audio output in the recording or stream)
 

Attachments

  • Advanced Audio Properties.png
    Advanced Audio Properties.png
    54.1 KB · Views: 3,921
  • Audio Settings.png
    Audio Settings.png
    48.4 KB · Views: 3,912
  • Output Settings.png
    Output Settings.png
    36.4 KB · Views: 3,143
  • 2020-03-30 11-08-18.txt
    15.8 KB · Views: 239

Theray070696

New Member
Currently running into this same exact issue, only getting audio on devices that are set in the audio devices area in settings, despite there being audio input and output captures in the scene on my main PC, or on my NDI PC it's only getting audio from one specific NDI source despite there being two more audio-only NDI sources. Getting green bars in the mixer on both PCs.
 

Narcogen

Active Member
Playback on recordings will only be a track at a time. You've only got 3 devices on all 6 tracks; one of them is inactive, and the others are Guest and Host. This picture shows your Desktop audio on *no* tracks.

It's possible some of your recordings have audio on some of the tracks, but not the early tracks.

OBS can only stream *one* track at a time.
 

gavi

New Member
Playback on recordings will only be a track at a time. You've only got 3 devices on all 6 tracks; one of them is inactive, and the others are Guest and Host. This picture shows your Desktop audio on *no* tracks.

It's possible some of your recordings have audio on some of the tracks, but not the early tracks.

OBS can only stream *one* track at a time.


I checked all of the tracks of the recording. The desktop track isn't relevant (no audio is coming through there, guest and host are the two NDI sources with audio), and even when I set to stream track one (and have everything play through track 1, as the screenshot shows) nothing plays through in the recording or stream. I have the exact same setup on SLOBS and the audio works perfectly. I don't get why it doesn't work here.

Edit: I only really care about the audio from Guest, Host, CD Music, and GC Intro. Turning on the desktop source doesn't make a difference - neither when monitoring or when recording/streaming
 

Narcogen

Active Member
Your Output settings screenshot also shows you are in Simple output mode, which does not support multitrack recording. You are only recording track 1 probably.
 

gavi

New Member
Your Output settings screenshot also shows you are in Simple output mode, which does not support multitrack recording. You are only recording track 1 probably.


Yes, well, I would LOVE if that were the case, but OBS is not even recording to track 1 at the moment. Hence - "No audio on stream or recording, only on monitor"
 

Narcogen

Active Member
Ok, then let me be clear:

If you want to record multitrack audio with OBS you need to enable advanced output mode. I've honestly no idea what OBS does with devices assigned to multiple tracks when simple output mode is on as I've never tried.
 

gavi

New Member
I've tried track one only too, and it still gave me nothing. :(

StreamLabs OBS seems to not have any of these audio issues. I would assume they would handle audio the same since they are both built on the same software.
 

Narcogen

Active Member
Are you getting activity in your VU meters?

I would suggest making a blank, fresh scene collection, add just a couple of sources, and assign them to tracks 1 and 2 as a test. Make sure in advanced output settings you check off the track(s) you want to record; just turning on the mode doesn't automatically record all tracks.

What are you playing recordings back in?
 

gavi

New Member
Are you getting activity in your VU meters?

I would suggest making a blank, fresh scene collection, add just a couple of sources, and assign them to tracks 1 and 2 as a test. Make sure in advanced output settings you check off the track(s) you want to record; just turning on the mode doesn't automatically record all tracks.

What are you playing recordings back in?


Yeah, meters show activity. Monitoring plays audio back.

I tired the advanced and simple recording mode (but audio isn't coming through on the stream either) with different tracks. I'll see if I get anything with a fresh new scene.

Playing back in VLC and streaming to YouTube, neither play any audio when using OBS but playback fine when doing the same thing in SLOBS.
 

Narcogen

Active Member
I'd start by just using a couple audio sources, putting them on all six tracks, record all six tracks, and see that you get from that in VLC six audio tracks of identical audio.

Then start disabling a few and make sure the recordings give you the behavior you expect.
 

jdantastic10

New Member
I'm having the exact same issue... was fine in Streamlabs OBS, but will not work as intended with OBS. I just switched because at this moment OBS is running a lot smoother for me. I have the elgato 4k60 Pro capturing my PS4. I also have headphones attached to my PS4, so I only want the audio to output to the stream, not the monitor in OBS so I hear it twice. So I have the capture card set to "monitor off" as I did in Streamlabs OBS and it's set to output to track 1 with the rest of the audio sources. But the stream can't hear my game audio unless I use "monitor only (mute output)" or "monitor and output" options which doubles the audio in my headphones. Audio is clearly coming in, it just won't send it where it's supposed to.
 

Attachments

  • 4f17a4ccdc8e6823eaf9532fd6ca3290.png
    4f17a4ccdc8e6823eaf9532fd6ca3290.png
    36.6 KB · Views: 800
  • 319bf02ce9e4532bb5561fda0df022c7.png
    319bf02ce9e4532bb5561fda0df022c7.png
    7.8 KB · Views: 769

Narcogen

Active Member
Please make your own thread and post logs. Just because people have similar symptoms does not mean they have the same problem.
 

jdantastic10

New Member
Please make your own thread and post logs. Just because people have similar symptoms does not mean they have the same problem.

My apologies. Someone else above mentioned that they were also having the issue, so I was adding to the conversation. And it's pretty clear we are having the same problem, even down to it working in Streamlabs OBS but not OBS Studio. I can open a new thread, but I thought it made more since to contain the issue here rather than having multiple threads discussing the same thing. I've been scouring the internet looking for someone else having this exact issue, and this is the only place I could find.
 

AdrianoPassos

New Member
I am having the exact same issue. Only work around I could find is to add audio sources under 'settings -> audio'. Those would mix just fine. But anything I add as a source wont mix.

 

gavi

New Member
And it's pretty clear we are having the same problem, even down to it working in Streamlabs OBS but not OBS Studio

I wouldn't say we're having the same issue at all (definitely not "the exact" one).
You said that

I also have headphones attached to my PS4, so I only want the audio to output to the stream, not the monitor in OBS so I hear it twice. So I have the capture card set to "monitor off" as I did in Streamlabs OBS and it's set to output to track 1 with the rest of the audio sources. But the stream can't hear my game audio unless I use "monitor only (mute output)" or "monitor and output" options which doubles the audio in my headphones.

You're able to send audio to the stream, just not the way you want it to. I'm not able to get any audio on the stream regardless.
Now, I'm not opposed to having other people post on the thread (like, why not help others out too?) but I agree with Narcogen that your issues might sound similar (no audio on stream), but really isn't at all the same (you can output audio but you hear it twice, I have no audio output regardless of how it is set up).
 

jdantastic10

New Member
Well, for what it's worth. I was able to solve my issue and it may help you if you're willing to try. The discord was able to help me. If you used the import tool to bring your scenes in from Streamlabs OBS, there is a bug with the importer that mutes audio output. I created a brand new scene collection in OBS, added my sources, and all audio worked as intended as it did in Streamlabs OBS. It did NOT work by simply removing and re-adding the sources to the imported scene collection. It had to be a brand new collection within OBS. Either way, I hope that might help you as well.

And also I wasn't trying to be rude or anything. You mentioned no audio on stream or recording, only on monitor. Which was my issue as well. The audio couldn't be heard (aka doubling up in my headphones) unless it was set to monitor.
 

gavi

New Member
Well, for what it's worth. I was able to solve my issue and it may help you if you're willing to try. The discord was able to help me. If you used the import tool to bring your scenes in from Streamlabs OBS, there is a bug with the importer that mutes audio output. I created a brand new scene collection in OBS, added my sources, and all audio worked as intended as it did in Streamlabs OBS. It did NOT work by simply removing and re-adding the sources to the imported scene collection. It had to be a brand new collection within OBS. Either way, I hope that might help you as well.

Seems like it solved the issue for me, I guess Narcogen was quick to jump.

And also I wasn't trying to be rude or anything.

I know :) I didn't mind. I just wanted to make it clear (before knowing what would solve the issue) that our problems might not be alike.

But now it seems that it's an import issue from SLOBS into OBS.
 
Top