Micro-stuttering on recordings

Lithia

New Member
Greetings,

I want to get as much info across with as little text as possible, for your convenience, so forgive this formatting.

The problem TL;DR: I suddenly have micro-stutters appearing in my recorded footage, where this was previously not the case when I ran on "worse" hardware.

- I record footage, I don't stream.
- I upgraded my hardware, the most notable upgrade being GTX 1080 --> RTX 2080 ti. If this is directly related is unknown. (My CPU is an 8700k OC'd to 4.8, fwiw)
- My base canvas is 1440p, which I Lanczos-downscale to 1080p (this is allegedly intensive, but this has worked without problems before my upgrade)
- FPS limit is 60 (I somehow think that a combination of factors regarding the 60fps is/are the culprit...?)

- Game in question which I'm testing/wish to play: Hellblade: Senua's Sacrifice (never got around to playing it...and now I still don't). Stuttering occurs in the opening cinematic.
- I have a 144hz monitor and I have done a combination of the following:
  • - in-game Vsync off, Nvidia control panel (NCP) vsync on
  • - In-game vsync on, NCP vsync on
  • - In-game vsync on, NCP vsync off
  • - Rivatuner (RT) 60fps limit (on both medium and high profile), NCP vsync on, in-game vsync off
  • - RT 60fps, NCP vsync off, in-game vsync on
  • - RT 60fps, NCP vsync on, in-game vsync on
  • - Enforce 60fps via game .ini file and repeat all the above
  • - Lowered refresh rate of my monitor down to 60 (never had to do this before, plus it did not help)
  • - Used RT overlay to make sure 60fps cap was solid and GPU was not overloaded --> GPU sat at about 50-60% load.
  • - I tried enforcing 60fps via the NCP
- I have lowered in-game settings, thinking it might have been that, but seeing as my GPU was hovering at 50% load on 'very high' settings, I doubt it was the problem.
- I disconnected my Capture card (which is not part of the scene I'm using for PC-game recordings) thinking it might have been interfering somehow.
- I disconnected my DSLR, thinking it might have been interfering somehow.
- I disconnected my Valve Index cable DP-cable, though the headset itself is not even connected to it
- I'm using Wallpaper engine, which I've setup to 'stop' (to save memory) when a maximized window is in focus / when a fullscreen application is running
- I have tried "turning it off and on again".

Through all this, I still get these...micro-jitters. I record a portion of the intro every time, to see if the stuttering is still there, and it's the same almost every time, in more or less the exact same way, too, to the point where I'm thinking it might be baked into the game (though, naturally, when playing "live" there is no stuttering whatsoever)
Is there anyone out there that could point me toward a potential fix.
Again, I've recorded other games in the past -- in their entirety -- without problem. I have changed nothing settings-wise since then, except for adding a capture card to my setup, which I disconnected for good measure.
Either lowering the in-game FPS to 60, or turning on in-game vsync (I typically have it off, due to G-sync) solved solved my issues in the past, but in this case I'm reaching the end of my rope.

OBS log can be found below, as well as a link to a short recording for reference (the opening moments are hard to distinguish, but once we get closer to the character the jittering should become more obvious)


Thanks in advance,

- Lith.

 

Attachments

  • Lithia__Log_2020-06-05 20-36-46.txt
    21.9 KB · Views: 53

qhobbes

Active Member

Lithia

New Member
1. Update your Windows to 2004 per https://obsproject.com/blog/five-simple-tips-for-new-streamers
2. In Windows 10 versions 1809 and newer, we recommend that "Game Mode" be enabled for maximum gaming performance. Game Mode can be enabled via the Windows 10 "Settings" app, under Gaming > Game Mode
3. The encoder is skipping frames because of CPU overload. Read about it at https://obsproject.com/wiki/General-Performance-and-Encoding-Issues
4. Run OBS as Admin

First off, thanks for the quick reply.

Second: Judging from the many sources of the internet I was under the strong impression that game mode should always be turned OFF, for high-end PCs at least...?

Third: I don't know how and why I wasn't running OBS in admin yet, I'm doing that as of writing.

Fourth -- Breakthrough: I wanted to see if OBS was, indeed, skipping frames, as I find it hard to fathom that a beefy card and juicy CPU like mine would have troube with the encoder. Wasn't sure how to achieve that, as recording fullscreen --> alt-tabbing means seeing a black screen, meaning the encoder has the easiest job in the world.
So I though 'if I switch to windowed....maybe?" --> I switch to windowed and record, both alt-tabbed and in-game, and would you believe that the stuttering is just.....gone? (I don't know why, by all accounts windowed mode should induce more stress on the system, right...?)
I will do a thorough test in just a bit, but this is....promising.

Thanks for the tips, regardless!


- Lith.
 

carlmmii

Active Member
Second: Judging from the many sources of the internet I was under the strong impression that game mode should always be turned OFF, for high-end PCs at least...?
Guides are out of date as soon as new versions of windows and OBS are released.

Currently, with windows 1903 and later, and running OBS 24.0.3 or later as admin, game mode does not matter (in this mode, OBS is placed onto the GPU priority list).

Fourth -- Breakthrough: I wanted to see if OBS was, indeed, skipping frames, as I find it hard to fathom that a beefy card and juicy CPU like mine would have troube with the encoder.
It doesn't matter how high-end your hardware is -- if windows doesn't let it get the priority it needs, then it is given the left-overs after what your game utilizes.

Avoid these settings:
- Max Quality (forces 2-pass encoding)
- Look Ahead
- Psychovisual Tuning

All of these use CUDA for processing, which can cause issues when running any other resource-intense process (i.e. any game).
 

Lithia

New Member
Guides are out of date as soon as new versions of windows and OBS are released.

Currently, with windows 1903 and later, and running OBS 24.0.3 or later as admin, game mode does not matter (in this mode, OBS is placed onto the GPU priority list).

Ah, I see. Who would've thought. But, if game mode 'doesn't matter' as you say (or as the guide says), then having it on or off makes little or no difference, yes?

It doesn't matter how high-end your hardware is -- if windows doesn't let it get the priority it needs, then it is given the left-overs after what your game utilizes.

Avoid these settings:
- Max Quality (forces 2-pass encoding)
- Look Ahead
- Psychovisual Tuning

All of these use CUDA for processing, which can cause issues when running any other resource-intense process (i.e. any game).

Hmm that how it works, huh?
Here's the thing, however: setting aside that I had max quality, look ahead and psycho-tuning turned on with my previous hardware, and having zero problems with it, I did some more testing with this title and found that:

1) Launching OBS
2) Starting the game
3) changing (windowed)fullscreen to Windowed (need to do this every time, as windowed mode from the get-go doesn't show up in OBS)
4) then hit record on OBS
--pretty much solves my issues. I don't know why. It annoys me, but perhaps it is a problem with this title, rather than my setup...

I'll take your suggestions into account for any potential future issues however. Thanks!


- Lith.
 

carlmmii

Active Member
For your window capture, have you tried both capture methods? (Windows 1909 and BitBlt behave very differently... BitBlt is the older method)
 

Lithia

New Member
For your window capture, have you tried both capture methods? (Windows 1909 and BitBlt behave very differently... BitBlt is the older method)

Have to admit that I'm not quite sure what BitBit even is. Always used the latest Windows version (if that's what you're refering to)
Though I can't update to v2004 yet, as windows tells me "My device is not quite ready".

I'll look into this BitBit thing, and will also test OBS with other fullscreen games to see if the problem persists there.


Thanks again.

- Lith.
 
Top