MIC Audio Crackling ONLY in OBS

CoffeeKitten

New Member
Hello, I've been trying to fix this issue for weeks now, whenever I use my mic in OBS there is this crackling noise all the time.
Only when using OBS to record or stream does this occur.
  • I've done separate recordings on Audacity and talking through Discord everything is clean.
  • I've messed with the sample rates, making everything 44.1kHz and 48kHz even with everything on the same sample rate it doesn't help.
  • I moved my mic from inputting directly to OBS to go through a virtual audio channel first and then into OBS but still no luck.
I'm at a total loss here, I can't get this to go away.
I'm 100% sure it is an OBS software problem because the hardware works perfectly everywhere else.

OBS Version: 25.0.8 (Studio)
Mic: AT2020 XLR
Audio Software: Voice Meeter Banana
Log file:
 

theartfulroger

New Member
Hello, I've been trying to fix this issue for weeks now, whenever I use my mic in OBS there is this crackling noise all the time.
Only when using OBS to record or stream does this occur.
  • I've done separate recordings on Audacity and talking through Discord everything is clean.
  • I've messed with the sample rates, making everything 44.1kHz and 48kHz even with everything on the same sample rate it doesn't help.
  • I moved my mic from inputting directly to OBS to go through a virtual audio channel first and then into OBS but still no luck.
I'm at a total loss here, I can't get this to go away.
I'm 100% sure it is an OBS software problem because the hardware works perfectly everywhere else.

OBS Version: 25.0.8 (Studio)
Mic: AT2020 XLR
Audio Software: Voice Meeter Banana
Log file:
I'm having the same issue on an M1 mac mini, it only occurs in OBS, no other applications have an issue. I've read all the posts and watched all the troubleshooting videos but nothing has worked to alleviate the problem. It sounds like clipping, but adjusting the input gain does nothing.
 
I'm having the same issue on an M1 mac mini, it only occurs in OBS, no other applications have an issue. I've read all the posts and watched all the troubleshooting videos but nothing has worked to alleviate the problem. It sounds like clipping, but adjusting the input gain does nothing.
Which version did you test?
 

xplsoivza

New Member
Exact same issue. Any other audio recorder or video call software works flawlessly. OBS has crackling noise on audio recordings... M1 Mac. Anyone found a fix yet?
 

ghagata

New Member
I spend a long while trying to solve this, too, M1 mac.
I was trying to record with Recording Format set to mkv, and when I switched to mov the audio was clear, as expected. It was also still clear when auto-remuxed to mp4.
Hope that helps.
 
Top