I will pay you if you fix my microstutters when recording, not in game.

Faz8

New Member
I upgraded my PC about two months ago with the latest hardware for 4K60 game recording. I started using Shadowplay instead of OBS because it uses less GPU resources. It wasn't until after a few recording sessions that I found out my shadowplay videos had minor microstuttering. Bummer, but I'll switch to OBS. Then I found out my OBS recordings have microstutters as well.

I have tried EVERYTHING. EVE-RY-THING. to try and fix this for the past 60 days. I disabled game bar completely, disabled windows dvr, I tried so many things that I'm going crazy. I'm 100% serious with the title when I say that I will pay you if you can fix my microstutters. I'm 99% sure it's something I need to do outside of OBS, so if I manage to fix that, I'm sure shadowplay is fixed as well.

Attached is a log of the recording, here is a google drive link to the recording. ( 900 MB file ) I recommend using potplayer to watch the video as its 4K60.
You can see the microstutter starting at 00:30 when I run around the pillars and 01:35 when I enter the Kichijoji area. These stutters are NOT in game and gameplay has been completely stutter free while recording this.

This is my PC, I'm running Windows 11 Pro version 10.0.22621 build 22621. Game is installed on my main samsung 980 pro m.2 nvme ssd, recording goes to my samsung 970 evo ssd. ( I also tried recording it to my second nvme ssd, no dice )

If you prefer to talk in discord, feel free to send your # and I'll add you there. Again, I'm 100% serious when I say that I need this fixed, I do not mind paying you, sending you a steam gift or what you prefer.
 

Attachments

  • log of recording in G Drive.txt
    17.7 KB · Views: 85

rockbottom

Active Member
I won't try any of your links but this isn't an OBS issue. OS, hardware (GPU), bad build take a pick. Check GPU-Z is the GPU @ x16 4.0? When you're doing whatever you do is the GPU getting overloaded or is the Performance Capped? Plenty of tools out there to help you figure it out.
 

Faz8

New Member
I won't try any of your links but this isn't an OBS issue. OS, hardware (GPU), bad build take a pick. Check GPU-Z is the GPU @ x16 4.0? When you're doing whatever you do is the GPU getting overloaded or is the Performance Capped? Plenty of tools out there to help you figure it out.
My first sentence literally says that I upgraded to the latest hardware...? a 4090 with a ryzen 9 7900x
My GPU sometimes goes back x16.1.1 or x16.2.0 when idle. But its always x16.4.0 when playing and recording. GPU is not overloaded ( 60% ) nor is the performance capped ( unless you mean the game? its capped to 60fps )
 

khaver

Member
I believe what's happening is at certain places in the game where more resources are being used, the game is throttling down the framerate, and if you have a free-sync monitor you don't notice the slight decrease in framerate while playing, but OBS and Shadowplay are pulling frames from the buffer at a constant rate. If the game framerate slows down, the recording may be pulling out a frame twice. I noticed in a few spots in your recording where there were duplicate frames.

You might try setting the refresh rates of your monitors to be exact multiples. You have one monitor at 60fps and the other at 144fps. This may have an effect on recordings. If possible, set your 144fps monitor down to 120fps. Try lowering the quality settings in the game slightly so less resources are used.

This is all I can think of.
 

rockbottom

Active Member
Crystal ball is broken....

Updating to the latest & greatest has it's risks. Since Shadowplay is doing the same thing, it could just be the Nvidia driver causing your pain & you have to wait for a new release.
 

Faz8

New Member
Crystal ball is broken....

Updating to the latest & greatest has it's risks. Since Shadowplay is doing the same thing, it could just be the Nvidia driver causing your pain & you have to wait for a new release.
yeah thought that might be the case :/ thank you for your input, I appreciate it.
 

Faz8

New Member
I believe what's happening is at certain places in the game where more resources are being used, the game is throttling down the framerate, and if you have a free-sync monitor you don't notice the slight decrease in framerate while playing, but OBS and Shadowplay are pulling frames from the buffer at a constant rate. If the game framerate slows down, the recording may be pulling out a frame twice. I noticed in a few spots in your recording where there were duplicate frames.

You might try setting the refresh rates of your monitors to be exact multiples. You have one monitor at 60fps and the other at 144fps. This may have an effect on recordings. If possible, set your 144fps monitor down to 120fps. Try lowering the quality settings in the game slightly so less resources are used.

This is all I can think of.
I have a freesync monitor, but freesync is not on. I also tried recording with just one monitor one ( the 60hz one ) and the issue persists :/
 

Faz8

New Member
What specific model drive are you saving to?
...I got it wrong in my initial post, my apologies.
The recording is saved to my Samsung SSD 870 QVO. It's a sata SSD. Full performance mode is turned on in Samsung Magician
 

Harold

Active Member
Some drive types lack the sustained write performance to keep up with recording, and depending on how bad the sustained write performance is, that can feedback all the way back to the encoder as stutters or encoding lag.
 

rockbottom

Active Member
1671302966850.png
 

Faz8

New Member
Just opened your log, before you start that test disable HAGS.
progress, sorta? not 100% sure. Only small stutters when running around the first two pillars, rest is fine.
video link. Let me try to record with shadowplay as well
 

Attachments

  • 2022-12-17 20-15-56.txt
    18.7 KB · Views: 51

rockbottom

Active Member
Try setting your main monitor to either 60 or 120 instead of 144.

Colors may look off too using the sRGB color space, Rec. 709 should produce better results.

I also noticed you're using CBR. The P5 Preset is mapped, no 4090 to test the dual encoders but I know that Preset is too slow for 60FPS on the 3000 series. P4 or lower must be used.
 
Top