Connecting OBS with Zoom without AV syncing issues

I'm running a live vocal from obs into Zoom with a video with audio at the same time - not streamng anywhere else just using OBS as a dressing for Zoom. Sent the OBS monitor feed to voicemeeter

Put the video audio through one channel in voicemeeter and the vocal through another then routed both out on BUS A on a virtual cable to Zoom
I sing bang on time but when the zoom client hears it I am still ever so slightly out of time with the audio from the video. Less delay than when I virtual cable to Zoom from OBS - so an improvement but it needs to be exactly right\ and synced. No idea what to do. Any help greatly appreciated. I've tried running just and audio file with the audio from the video but the same thing happens.


Thanks

Patrick
 
I'm having similar frustrations to folks here. I run my audio directly to Zoom but I'm using OBS to make my image better. What's particularly frustrating is I swear in older versions, or older settings I used to have last year, there was no, or almost no, delay. I have a top of the line gaming laptop, and largely that purchase was to try to get this delay to go away, but it had no effect. What on Earth is making OBS so delayed if I have the fastest Windows 10 machine most folks could ever get?

My friends on their MacBook Pro are able to use OBS for a nice visual over Zoom, but they don't have any noticeable delay. So frustrating!
 

ad1562

New Member
Hey, Folks, I suffered with this problem also, and found a solution that works fairly well for me.

OBS -> NDI -> Zoom

Requirements...
*OBS latest version
*OBS-NDI plugin
*NDI Tools (specifically NDI Webcam Input)

There are several tutorials on this available on youtube. Here's the one I used as reference:

This solution took care of the major sync issues that I was facing as it enabled me to sync everything in OBS and then send it out to NDI as one output that includes audio and video. In Zoom I select Newtek NDI Audio and Newtek NDI Video as my microphone and camera, respectively.

Hope this helps... Happy conferencing!
 

jleagle94

New Member
Hey Function, little late to the party and new to OBS studio but I think I have a solution for you. Instead of adding a source for window capture using Zoom, try instead using the regular display capture. You can then open the properties to the display capture and choose "crop". You can crop to the Zoom meeting window. This removes the time lag but I, too, cannot seem to fix the time lag when I simply using the window capture source directly. The method above should work though. Hope this helps.
 
Top