davidmcmusic

New Member
Hello to everyone!

The problem is: I connect my keyboard and guitar through inputs 1-2 which let me select between line-instrument connection. And then, I connect my microphone into the input n3. OBS gets the signal well from the inputs 1 and 2 but doesn't from the 3 input (mic). I hear the mic through my headphones but OBS does not get signal.

If I connect the mic into 1-2 inputs OBS gets the mic's signal, but instruments must be plugged into inputs 1-2.

Focusrite inputs.JPG
Focusrite inputs.JPG
Focusrite inputs.JPG
 

Sukiyucky

Member
Does the mic need phantom +48V?, If so, your 48V light isn't on. Press the button to engage it. It should be red continuously.

Also, do you have an audio input or audio output capture to that line #3 as a source for your scene(s) that need a mic?
 

davidmcmusic

New Member
First thank you for your time to response @Sukiyucky !!

No, it doesn't need phantom. It is a dynamic shure SM7B.

The thing is that OBS does not allow me to select the exact input where the sound comes from the focusrite. It just let you select focusrite, but no the input chanel. So I play piano or guitar and the same chanel on the OBS mixer gets the signal. Would like to separate instruments so any filter applied does not affect both. And also because I could tell OBS, that the mics sound comes from input 3.

In the next picture, I have 3 channels.

1-Desktop audio.
2-Guitarra (Guitar)
3-Shure.

Channel 1 gets the signal of everything. I play piano or guitar and channel 2 gets it. Channel 3 does not get anything.

OBS forum.jpg
 

Sukiyucky

Member
For audio interfaces that have multi i/o, the higher end products provide 1:1 correspondence between i/o and audio device driver. The cheaper one's with limited development budget don't want to hire an audio device driver engineer to add to the cost of production. Those are the one's that offer really crappy high latency audio interfaces. In the long run, it bites them in the butt and they get more returns from consumers who desire low latency gear and flexible routing. The hardware maybe super, but the software crap. This is the difference between the low end and high end audio interfaces (besides mic pres and ADC/DAC). The driver and software routing/mixing is the tell.

Ideally there should be corresponding audio device drivers listed in Windows sound control panel for playback and recording for each i/o jack of the audio interface. That is where things can get very frustrating because the flexibility in routing can be limited The only way to figure this out is by actually buying and testing to see if you can get it to work or not.

In Windows sound control panel, go to the recording tab and look at all the listed device drivers. Then speak into the mic to see which of the audio device drivers shows the meter bouncing up and down. Note that audio device driver and specify that in OBS Mic/Auxillary Audio drop down in settings (or create an input/outputt source for the Scenes you are using it in). The one that bounces, set as the default.

If all else fails, consider using VoiceMeeter Banana and virtual audio cables along with Windows App and Device Preferences to do the routing.
 

davidmcmusic

New Member
For audio interfaces that have multi i/o, the higher end products provide 1:1 correspondence between i/o and audio device driver. The cheaper one's with limited development budget don't want to hire an audio device driver engineer to add to the cost of production. Those are the one's that offer really crappy high latency audio interfaces. In the long run, it bites them in the butt and they get more returns from consumers who desire low latency gear and flexible routing. The hardware maybe super, but the software crap. This is the difference between the low end and high end audio interfaces (besides mic pres and ADC/DAC). The driver and software routing/mixing is the tell.

Ideally there should be corresponding audio device drivers listed in Windows sound control panel for playback and recording for each i/o jack of the audio interface. That is where things can get very frustrating because the flexibility in routing can be limited The only way to figure this out is by actually buying and testing to see if you can get it to work or not.

In Windows sound control panel, go to the recording tab and look at all the listed device drivers. Then speak into the mic to see which of the audio device drivers shows the meter bouncing up and down. Note that audio device driver and specify that in OBS Mic/Auxillary Audio drop down in settings (or create an input/outputt source for the Scenes you are using it in). The one that bounces, set as the default.

If all else fails, consider using VoiceMeeter Banana and virtual audio cables along with Windows App and Device Preferences to do the routing.


Thanks again.

The thing is that on windows I can only select between analogue 1-2 inputs. Same on OBS.

Could I fixed this with VoiceMeeter Banana? Then thing is that I don't know how many analogue inputs OBS let you capture from
Focusrite OBS.jpg
Focusrite windows.jpg
 

Sukiyucky

Member
To see more audio device drivers, go to the Windows tray and right click on the Focusrite "F" icon. A menu should come up. Click the Show/Hide Windows channels to put up a dialog box where you can check the checkboxes to allow for more channels.

See if that solves your problem and helps in setting specific audio routing. It should show you Analogue 3 + 4, etc. so you can now have anmore audio device driver endpoints to work with.
 

yonago27

New Member
I have this exact problem with Scarlett 6i6. I am also using the voicemeeter Potato, but haven't tried to route the analogue input 3+4 from there. Usually I use voicemeeter to route my desktop audio to the stream. I'll try it tonight and hopefully it can work.
 

yonago27

New Member
OK, solved it.

You have to click this on your lower right panel, choose the Focusrite Icon, and Expose Windows Channel. Activate input and output as you want.

Finally
Untitled.png
 

Sukiyucky

Member
Which is exactly what I said three posts above your "aha! moment".

"To see more audio device drivers, go to the Windows tray and right click on the Focusrite "F" icon. A menu should come up. Click the Show/Hide Windows channels to put up a dialog box where you can check the checkboxes to allow for more channels."
 

davidmcmusic

New Member
That was absolutely helpfull! Now I can stream with both instruments at the same time. Thank you so much so much for that.

I do have another question related to that! I have plugged into 1 and 2 piano and guitar. When I select on properties the input like this image (Analogue 1+2) How do I separate them so I can ads filters individually (piano and guitar) even if I select analogue 1+2?
analogue 1-2.jpg
 

Sukiyucky

Member
Go to Focusrite and ask them about how to do that. Get it to work at their end first using their product then figure out how to get it to work with OBS. You already have the basics down, create an audio input capture source to tie it to an audio device driver.

Ideally, like I said above, there should be separate audio device drivers for each i/o port. That is going to give you the most flexibility in tracking, mixing and routing.... that way, you can specifically create a OBS source for each i/o port that relates to an existing ready/enabled state audio device driver for use.

This maybe a weakness in Focusrite design. It maybe the reason why Ableton Lite DAW is required in place of them writing their own mixing and routing application to control all of this. Most audio interfaces provide this as software. Focusrite is very weak in this regard. No wonder why Focusrite audio interfaces are cheaper eh?

Given the solution I mentioned above about showing/hiding additional drivers, you should now be able to see and use ports 3, 4, 5, ...10 driver to plug the guitar into. To get it to work with port 2 is probably a simple, silly solution - go ask Focusrite. And then question them why they designed it this way.

The reason maybe to get stereo mic. Mics are mono typically and to get stereo, one would have to create duplicate of the mic 1 signal into another channel (like channel 2). Then do a trick like panning far left on channel 1 and duplicate the signal on channel 2 and pan far right and mix together.

Putting the guitar into channel 2 might override this behavior. So go ask Focusrite. Maybe its another setting in their software you have to set?
 

bvZed

New Member
I don't have a 2 preamp Focusrite, only a Scarlett Solo. The Solo has 1 preamp, so its two inputs are mixed and come out as 1 channel (analog 1+2). The mix can't be separated, it's only 1 channel. The 6i6 has two preamps, so I'll guess inputs 1 and 2 mix to (analog 1+2), while inputs 3 and 4 mix to (analog 3+4). Just a guess, I'm actually curious because I'm considering getting an interface with more preamps that I would want to receive as separate channels into a daw.
 

MIDIvsTHEWORLD

New Member
I came across this forum trying to figure out how to separate my audio inputs on my RME Babyface and came up with a solution shortly after. The issue I was having specifically relates to yours in that my channel 1 and 2 on my interface are 2 separate inputs on my device but OBS doesn't give me an option to select only channel 1 or 2 individually, so 2 signals would go into the same channel at once.

The solution is basic but for some reason wasn't the first thing I tried until after reading this forum and not getting the answer I need lol

****SOLUTION****
So if you are trying to pick up 2 mono signals in channels 1 and 2 of your interface you need to add to audio input captures in your OBS project capturing 2 instances of the same channel. So in my case it is channel 1&2. Then go into advanced audio properties and pan hard left on channel 1 and hard right on channel 2. After panning you can set those tracks to mono and you will have your signals separated into 2 mixer channels within OBS.
 

blackalberts

New Member
Im having the same issues just on mac with 2 mics in analog 1 and 2 .
i cant get any sound from analog 2 whatever I do...
There is no F icon to click anywhere.
I have sound within the FControl software on analog 2 but OBS doesnt get any signal from it.
 

Attachments

  • Screenshot 2021-06-13 at 22.25.00.png
    Screenshot 2021-06-13 at 22.25.00.png
    286.8 KB · Views: 176
  • Screenshot 2021-06-13 at 22.25.03.png
    Screenshot 2021-06-13 at 22.25.03.png
    584.9 KB · Views: 180
  • Screenshot 2021-06-13 at 22.25.17.png
    Screenshot 2021-06-13 at 22.25.17.png
    122.7 KB · Views: 174
  • Screenshot 2021-06-14 at 10.40.30.png
    Screenshot 2021-06-14 at 10.40.30.png
    108.7 KB · Views: 158
  • Screenshot 2021-06-14 at 10.40.43.png
    Screenshot 2021-06-14 at 10.40.43.png
    76 KB · Views: 165

jaimes

New Member
Im having the same issues just on mac with 2 mics in analog 1 and 2 .
i cant get any sound from analog 2 whatever I do...
There is no F icon to click anywhere.
I have sound within the FControl software on analog 2 but OBS doesnt get any signal from it.
were you able to figure out the issue?
im having the same issue
 

Mark Weiss

Member
Is there a setting like this for MOTU896 mk III? I used to be able to hear audio from MOTU Analog 1-2 inputs, but this last time I tried to use OBS, it's silent. Either a windows up date or an update to OBS broke my setup. I suspect a windows update because my Sound properties shows only meter activity on MOTU OUT but not on Analog 1-2 when I have 0dBFS signal going into and see those levels on the MOTU hardware meters on the front of the 896.

MOTU896 Output works, but not input
 

shock

New Member
were you able to figure out the issue?
im having the same issue
I Dont know if you have solved this problem, I have found a solution. Search focusrite in search bar in windows, or find where your focusrite files are in mac and that f symbol is focusrite device settings and right click and select expose hide windows channels and go to obs setting and put them in auxilery mic and it will have both anolog 12 and 34
 
Top