Bug Report WARNING - OBS does not work on MacOS 10.15 Catalina

#1
I upgraded to MacOS 10.15 (Catalina Dev Beta 1) and found out that OBS refuses to open. If any of you on Mac use OBS, do not upgrade to Catalina 10.15 until this is fixed.
When you attempt to open OBS, you will be immediately be greeted by an "OBS quit unexpectedly" message.
 
#7
I just upgraded to the public release of Catalina yesterday (10.15) and ran into this very same problem. When I click on the OBS icon, OBS immediately crashes. When I run OBS from the command line via terminal, OBS runs. The terminal window must stay open. I'm seeing two issues running this way and both are related to audio. There's no audio from video clip sources or from alerts from streamlabs. Game and chat audio works ok as does audio coming from my stream deck.

Edit: I resolved the audio issues by adding the Terminal application as an audio source in my Loopback setup.
 
Last edited:
#8
This morning I decided to troubleshoot my audio issues running OBS via terminal. With nothing plugged into my MacBook Pro, I clicked the OBS icon out of habit and it launched without crashing. With OBS running, I plugged in my cameras and video capture device and turned on my xbox and OBS crashed. I attached the problem report generated by Catalina.

Next, I unplugged everything and clicked the OBS icon. OBS started up without crashing. With OBS running I plugged in a single Logitech camera and OBS immediately crashed. I unplugged the camera, clicked on the OBS icon, and OBS started again. Log file attached.

I tried viewing the OBS crash report but when I click on view crash report or upload crash report log file, nothing happens.
 

Attachments

#9
This morning I decided to troubleshoot my audio issues running OBS via terminal. With nothing plugged into my MacBook Pro, I clicked the OBS icon out of habit and it launched without crashing. With OBS running, I plugged in my cameras and video capture device and turned on my xbox and OBS crashed. I attached the problem report generated by Catalina.

Next, I unplugged everything and clicked the OBS icon. OBS started up without crashing. With OBS running I plugged in a single Logitech camera and OBS immediately crashed. I unplugged the camera, clicked on the OBS icon, and OBS started again. Log file attached.

I tried viewing the OBS crash report but when I click on view crash report or upload crash report log file, nothing happens.
I tried it too, opening the obs without the camera connected, after that started the tests on camera and OBS only opens/remain working when i delete the camera view on it, tried using Logitech c922, the facetime and tried the snapcamera(thinking about changing the interface of capture since the snapcamera uses the camera then OBS gets the "virtual camera"), on all tests OBS crashes when open the camera, cause of this i think the problem on Catalina + OBS are on the Camera calls of OBS since its what are causing the crashs. Tests on Imac Late 2015, logs attached
 

Attachments

#10
I tried it too, opening the obs without the camera connected, after that started the tests on camera and OBS only opens/remain working when i delete the camera view on it, tried using Logitech c922, the facetime and tried the snapcamera(thinking about changing the interface of capture since the snapcamera uses the camera then OBS gets the "virtual camera"), on all tests OBS crashes when open the camera, cause of this i think the problem on Catalina + OBS are on the Camera calls of OBS since its what are causing the crashs. Tests on Imac Late 2015, logs attached
https://obsproject.com/forum/threads/macos-10-15-catalina-support-status.111343/
 
#13
I’m using the Catalina OBS test release and have had pretty good luck with it so far. Not tried to do anything fancy though - three scenes: title screen pumping an image, face cam, and window capture of my browser. No PIP but will try that tonight / tomorrow.

so far it’s working. I have noticed that I get a flicker (black flashes occasionally) if I try to view the webpage via OBS rather than having the safari as my active window while surfing. Not sure if that’s normal. This means I have to swap windows if I ever want to view OBS bc I do not have a duel monitor set up sadly. Something I should likely remedy this Christmas.

the only issue I have noticed now is that my Canon G7X-iii is “squished” along the vertical axis but my Sony RX100-iii works fine. Still not been able to figure out why the Canon is squished. If you have thoughts on that please tell me!
 
#15
FYI, to get screencapture in catalina working, on mac Catalina as of November 2019 1) update xcode 2) open obs via terminal $
$ open /Applications/OBS.app/Contents/MacOS/OBS --args -picture 3) open system prefrences > security > privacy > Screen Recording > check sh and terminal. 4) quit obs via terminal 5) reopen obs via terminal $
open /Applications/OBS.app/Contents/MacOS/OBS --args -picture ... and your it should.
 
Top