Unable to save recordings (or even create them) using H265/HEVC encoder (AMD)

Cindro

New Member
Hi guys, so about 2 days ago, OBS decided to stop working for me.
Specifically with use of any of the AMD-provided (?) encoders (H265/HEVC and H254/AVC), regardless of my recording settings it would seem, unless I just haven't found the magic combo :P


TL;DR I have an AMD GPU & CPU, ONLY the x264 encoder works for me (but I don't want to use that), otherwise no output file is written to or even created, regardless of my audio tracks, output storage, framerate, Windows game-mode, etc yadda yadda.


If I start recording, I am unable to save it. In fact, no file is ever even created. I've tried outputting to different storage devices, including SSDs and HDDs, nothing changes.
Upon clicking the "stop recording" button, it stays highlighted on "stopping recording..." eternally.
Also, if I view the stats dock, after the stat "Disk full in (approx.)" it reads "-5962523 Hours, -14 Minutes", rather oddly.

I've heard that using multiple audio tracks and a "high framerate" can cause OBS to break, but the thing is, I'm always using 60fps, and it was working with multiple audio tracks prior to this.
I have tried using a single audio track to no avail. Also, the x264 encoder works fine with multiple audio tracks.
I should also mention that I have a G-Sync/FreeSync monitor, and this feature is enabled in AMD's settings.
I've tried disabling and enabling Windows' "Game Mode" feature, and I've also heard about turning this "GPU acceleration" thing off or something, however it is nowhere to be seen in Windows' settings, following a guide on it, so maybe that's Nvidia-only or something?

For the record, I don't want to use the x264 encoder because it takes a significant chunk out of my game's performance (like, often halving my framerate, but that's another story), although from what I can tell the somewhat decreased filesize-to-quality ratio seems nice.

This issue has seemingly arose out of nowhere.
AMD didn't update, OBS didn't update, not even Windows updated when this problem came.
I have since updated AMD drivers as well as Windows and the problem persists.
All that I've done in the past week in fact was install that recent VLC Media Player update, the security one. I'm only mentioning this because it appears VLC is mentioned in the log file.
I also thought that maybe it's a problem on AMD's end, however if I use the same encoders for recording with AMD ReLive (or whatever), it records and saves just fine. I have reported the issue to AMD just in case.

Kind of tearing my hair out over this since practically nobody online has this issue, and when they do, the thread is years old and has no replies :(
Any help would be greatly appreciated, as I use OBS quite frequently online, thank you.

Log file:
 

Attachments

  • obs glitch.png
    obs glitch.png
    17 KB · Views: 37

Cindro

New Member
Whoops, forgot to mention that as a result of the eternal "stopping recording..." I have to kill OBS with task manager, so the end of the log may look a bit weird.

I'm also using ADMINISTRATOR MODE. This also isn't a one-off thing, I literally cannot use OBS because of it.
 
The last thing "stopping recording..." at least may be caused by recent AMD software. There are already threads in this forum regarding this.

Your primary issue i don't have any clue, sorry.
 

Cindro

New Member
Recording to H264/AVC by using AMF fails also?
Are you recording 3500kbps only?

Hey, sorry for the late reply, yes H264 fails too.
And normally I record at like 14000kbps I believe, however it was set to the default values for that specific log, and changing the bitrate doesn't appear to affect whether it saves recordings or not.

Would you be able to link me to the other threads? I must have terrible searching skills since I was unable to find anything that wasn't years old or had any replies.

Thanks
 
A summarized post regarding the recent AMD stuff is here:

It targets to two other threads, but there are more. Its often symptom based, so that eventuelly it turned out that newer AMD software is the common point to observations made by different people. That means that there is no final conclusio on this. But sometimes people come back and report that downgrading to this or that version helped (at least for this issue).

I remember that on another thread somebody told, that he reverted all "gpu 3D settings" to its defaults (whatever this means, i don't have AMD stuff), and it worked, he could record or stream again flawless.

Lets hope that someone other answers here possibly too, because i've no knowledge about the AMD stuff in detail.
 
Last edited:
Top