Source Record

Source Record 0.3.4

errornosignal

New Member
Hi.

I'm trying to use the plugin to record a CQP source with a MK2 capture card, BUT, there is a error in the button or encoding settings.

Once CQP is selected, the menus change to the same CQP preset of OBS under CONFIG, but when the filter window is closed, by some reason, the text "CQP" in the drop down menu is called CQP but quality preset instead of 20 is set to 2500 bitrate, after some tests, it seems that CQP is somehow switching to CBR.

Already try to delete the filter and redo all settings, but problem persists.

Tested with NVIDIA HVEC under a GTX 1060 6 GB and AMD hw h.265 HVEC and booth scenarios the problem is the same.
I have this same issue. Source Record filter enabled on a scene containing a game capture source and have configured the filter as follows:
Screenshot 2024-06-02 111615.png


However, after leaving the filter configuration window and coming back, the CQ Level field will change to Bitrate, with a value of 2500 Kbps, while all other settings remain unchanged. I have also tried removing and re-adding the filter, but the issue remains.
Screenshot 2024-06-02 111518.png
 

Razzee

New Member
Great plugin, but... it does not respect the "Pause" button. ;(

If you could fix that, it would be perfect.

By the way, what is the difference between both "Hardware NVENC" and "NVIDIA NVENC"?
 

xKaioh

New Member
I couldn't get it to work on the MAC MINI M2...

I added the filter to two sources via the HDMI capture card, and selected the file path to be the desktop, but it doesn't work at all... even changing the encoder, the activation trigger, nothing...
 

Gitago

Member
If you turn on Replay Buffer in teh Source Record Filter, you will see an entry for it under "Hotkeys". It will say have the name of the scene or source it's loaded into, followed by "- Source Record" with an entry that says "Save replay". There you can assign the hotkey you want to save the replay buffer for that filter.
I dont want to use an actual hotkey.. I am trying to trigger the hotkey action so to speak, using the obs websocket
 

Exeldro

Active Member
@Gitago calling save replay buffer for source record via obs-websocket you can use TriggerHotkeyByName with hotkeyName set to ReplayBuffer.Save and contextName to "Source name - Source Record filter name" as shown in the hotkey settings
 

Data Swami

New Member
Is there a way to downscale the recording on the source? My resolution is 3840x2160 and downscale output to 1080p but I cant do that with Source Record from what i can see so its causing an encoding overload
 

McKeyPL

New Member
I get suggestions under my thread to post crashes and logs there. OBS crash when plugin record 2 streams via nvenc.

According to all crash logs, the source record plugin is involved with the crashes.
According to one of the regular logs, the source record plugin gets an invalid frame size:
[...]
Check your source or plugin settings to set a valid frame width. 4294967295 is -1, so it seems there is some uninitialized value propagating from the plugin.
 

Attachments

  • 2024-06-20 15-38-51.zip
    494.6 KB · Views: 4
  • Crash 2024-06-20 16-01-58.txt
    150 KB · Views: 6

TheDJTC

New Member
It works very well, don't have scenes to transition to yet so can't report if that still crashes, but the only problem I have is having to use shutter encoder to trim the video into chunks so it's easier to edit/transcode. (Having a five hour video isn't great XD)
 

dwils046

New Member
OBS suddenly crashing when attempting to record with two sources. Worked previously with 3 sources. If anyone can help me figure out what's wrong as well as recommend optimal settings for my setup, I'd greatly appreciate it. I will list the sources and all settings below as well as attach crash reports. :

Computer specifications:
12th Gen Intel Core i9-12900H 2.5 GHz
32GB RAM
NVIDIA GeForce RTX 3070 Ti GPU

OBS Settings:
1719184139938.png
1719184201524.png


Source #1 (NVIDIA Broadcast - Samsung Z Fold 4). Source Record settings:
1719183802513.png


Source #2 (Iriun - Samsung Note 9). Source Record settings:
1719184017020.png
 

Attachments

  • Crash 2024-06-23 18-42-16.txt
    150 KB · Views: 6

Paulterghost

New Member
Hi!
I'm currently trying to get the streaming functionality to work.
I want to strea only my game source to a second twitch account but the stream simply doesn't start up.

I got the rtmp url from https://help.twitch.tv/s/twitch-ingest-recommendation?language=en_US
and copy pasted it into the Server field.
pasted the stream key into the stream key.

problem is the stream on twitch just doesnt start up.
I tried pasting

rtmp://vie02.contribute.live-video.net/app/{stream_key}
rtmp://vie02.contribute.live-video.net/app/
rtmp://vie02.contribute.live-video.net/app/my_actual_stream_key
rtmp://vie02.contribute.live-video.net
vie02.contribute.live-video.net
Into the server field but nothing works.

As trigger I have set recording so I won't start up my stream while testing, not sure if that is a problem.

Help would be greatly appreciated!
 

Paulterghost

New Member
A seperate thing I noticed.
It would be nice if it worked on a nested scene.
I have a scene where I put all my games in and in the actual stream scene I just put in the nested scene and sacle it to whatever I need.
This makes it very easy to set up a new game with game capture and have it scaled the right way.

Would be awesome if you could just have source record on the scene then and have only one filter for it instead of on every seperate game source.
 

Suslik V

Active Member
@Exeldro The "Rec Format" selection field in the plugin - is editable dropbox, thus it can be emptied by user. After the hashing of data and items in OBS was implemented ( https://github.com/obsproject/obs-s...82f6a55b14188a7a1d02053d975aeb720cddde552R891 ) it seems that the check for empty name was removed. Thus, after v29 of OBS emptied field leads to application crash.
Evidence:
 

GleasonRyan

New Member
I want to be able to record my gameplay with the game sounds on one track, and mic on another for editing purposes but dont want any stream sounds so I cant just use my normal stream mix. I am not seeing an option for this in the settings, am I missing something here?
 

Nostrildumbass

New Member
I'm trying to use this to save my 150s replay buffer but when I add the filter to my Game Capture source, no hotkey bind shows up for it in the settings. One does show up for Window Capture if I set up the filter on a Window Capture, but not Game Capture. Is this a bug/oversight?
 

ASchneider

Member
Hello @Exeldro, good morning. Sorry to bother you, but can you please consider adding WHIP support for streaming a source? Steve from VDO Ninja has now added support for meshcast, it works great for publishing a WHIP stream directly to it and been able to play that stream from multiple places at the same time, there is also no need to have a browser just for waiting the stream to start. Thanks, have a great day :)
 

TheRobinsonson

New Member
I'm having an issue with the Plug In. I have set up 2 sources to record when streaming, the second the filter is active, my OBS crashes. I've tried cutting down to 1 source record, tried different quality settings and different different encoders but still the same issue. Any suggestions?
 
Top