Scale To Sound

Scale To Sound 1.2.2

grit60

New Member
@Qufy, the filter works flawlessly - well done.

The following would be helpful: Allow 0% minimum (to hide the source). Allow a "reverse" flag so the source can be maximized when there is no audio. Allow scale to 100% (it appears to only reach a scale to about 95%).
 

BOLL

Member
This is working great, except one small detail, it is not scaling sources to the minimum size if there has been no input on them yet!

I am adding icons for my various audio sources, namely: my microphone, my TTS and VoIP, and the latter is not always in use so it can stay at 100% throughout.
 

Qufy

Member
This is working great, except one small detail, it is not scaling sources to the minimum size if there has been no input on them yet!

I am adding icons for my various audio sources, namely: my microphone, my TTS and VoIP, and the latter is not always in use so it can stay at 100% throughout.
Should be fixed in 0.2.1!
 

dungi

New Member
hey, if the Audio Source is currently not in the current scene the view will stilll animate if I speak. How can I avoid this, without muting my sources on scene switch? I have a "mic" source, that is not availble in my "AFK" scene and an global image in all sources that will animate on my mic.
 

grit60

New Member
hey, if the Audio Source is currently not in the current scene the view will still animate if I speak. How can I avoid this, without muting my sources on scene switch? I have a "mic" source, that is not available in my "AFK" scene and an global image in all sources that will animate on my mic.
If practical, duplicate the global image in the AFK scene and remove the filter. If not practical, create a virtual audio device (mic2) which receives audio from your mic. Then add a "mic2" source to the AFK scene. Without muting your original Mic source, mute mic2 when you enter and unmute when you exit. Associate mic2 to the Scale To Sound filter.

There appears to be a small bug in this plugin when you copy a source so you have to remove the copied filter.
 

BOLL

Member
I've had two crashes when closing down OBS after installing this plug-in, which is not a game breaker as then it's terminating anyway, but from what I can see it's when it tries to destroy sources but an audio monitor is still on. I believe this could possibly be an audio source that is still providing input, which is usually the case for me as I am using this with my microphone which is never muted.
 

Attachments

  • Crash 2021-08-14 20-38-36.txt
    72.8 KB · Views: 31
  • Crash 2021-08-15 00-14-51.txt
    76.1 KB · Views: 29

Qufy

Member
I've had two crashes when closing down OBS after installing this plug-in, which is not a game breaker as then it's terminating anyway, but from what I can see it's when it tries to destroy sources but an audio monitor is still on. I believe this could possibly be an audio source that is still providing input, which is usually the case for me as I am using this with my microphone which is never muted.
Will try to fix as soon as possible
 

Qufy

Member
I've had two crashes when closing down OBS after installing this plug-in, which is not a game breaker as then it's terminating anyway, but from what I can see it's when it tries to destroy sources but an audio monitor is still on. I believe this could possibly be an audio source that is still providing input, which is usually the case for me as I am using this with my microphone which is never muted.
0.2.2 should fix this. If it still occurs please let me know!
 

shibetpc

New Member
Having some trouble getting this running on Linux (kubuntu 21.04). When I make the filter visible, the source (a color bar) disappears regardless of what plugin settings are applied. Any suggestions on how to troubleshoot this? Much thanks :)
 

Qufy

Member
Having some trouble getting this running on Linux (kubuntu 21.04). When I make the filter visible, the source (a color bar) disappears regardless of what plugin settings are applied. Any suggestions on how to troubleshoot this? Much thanks :)
I ran into that problem on my Linux PC earlier. Try removing the filter and adding it again. There seems to be a bug somewhere but I'm unable to reproduce it
 

shibetpc

New Member
I ran into that problem on my Linux PC earlier. Try removing the filter and adding it again. There seems to be a bug somewhere but I'm unable to reproduce it

Thanks for the reponse :) No joy unfortunately. I removed the filter and added back in with no change. I also tried variations of adding/removing/enabling/disabling in combination with shutting obs down and restarting against different kinds of sources. Still no luck. Source just disappears when the filter is added and enabled.
 

Qufy

Member
Thanks for the reponse :) No joy unfortunately. I removed the filter and added back in with no change. I also tried variations of adding/removing/enabling/disabling in combination with shutting obs down and restarting against different kinds of sources. Still no luck. Source just disappears when the filter is added and enabled.
Sorry to hear that, have you made sure that it is installed correctly? (The download has a folder called "obs-scale-to-sound" in it, extract that in ~/.config/obs-studio/plugins).
If that does not work, could you provide me with some more info?
Specifically
Info about the source you're applying the filter to (like its type (image/color/capture etc), any other filters it has etc)
Info about the audio source you're selecting
(Is it in another scene, what kind is it (like media or global source in the mixer), does it have monitoring? Any filters?)
And a log file would be nice
Thank you!
 
Top