OBS v29 Virtual Cam not working with Zoom 5.13.4

CGGuitar

New Member
Hey guys,

Virtual Cam on OBS isn't working anymore with Zoom. Can anyone help?? I've attached a screenshot of what the OBS virtual camera looks like when turning it on to use in Zoom meeting.

Is this a bug in the new version of OBS.

Using OBS v29 and Zoom v5.13.4

Cheers,

Charlie
virtual cam broken.png
 

mhoffman2001

New Member
I'm having the same (or similar) issue with Teams and Google Meet. I've been using OBS for years on both Mac and Windows, and this issue started immediately when I upgraded to v29.0. I'm running Ventura 13.0.1 on a 13 inch Macbook Pro, 2020.

At one point. instead of a solid green, it was flickering rapidly between solid green and my actual video stream.

At another point, the image changed from the green feed to a freeze frame of my actual video stream, but even turning off and on again, I could only get the green feed or occasionally the frozen image.

2023-01-09_16-10-59.png
 

cirrusbonsai

New Member
macOS 12.6.2 / OBS v29 / Teams 1.5.00.33356
Same issue, only the screen is red.
 

Attachments

  • Screen Shot 2023-01-10 at 8.42.31 AM.png
    Screen Shot 2023-01-10 at 8.42.31 AM.png
    11.4 KB · Views: 20

Olli K

New Member
Hey guys,

Virtual Cam on OBS isn't working anymore with Zoom. Can anyone help?? I've attached a screenshot of what the OBS virtual camera looks like when turning it on to use in Zoom meeting.

Is this a bug in the new version of OBS.

Using OBS v29 and Zoom v5.13.4

Cheers,

Charlie
View attachment 90427
Using OBS 29 on Windows 11 Pro 22H2 and Zoom 5.13.4 (11835) Virtual Cam works fine so far.
 

travispetty

New Member
Hey guys,

Virtual Cam on OBS isn't working anymore with Zoom. Can anyone help?? I've attached a screenshot of what the OBS virtual camera looks like when turning it on to use in Zoom meeting.

Is this a bug in the new version of OBS.

Using OBS v29 and Zoom v5.13.4

Cheers,

Charlie
View attachment 90427
This is what i am seeing, as well . . . on OBS v29 and Zoom v5.13.4 on 2013 Mac Pro (OS 12.6.2)
 

travispetty

New Member
. . . and it's definitely not a Zoom-specific issue, as it looks the same (aka doesn't work) in Google Meet either. How can we re-download v28? (until they get this resolved). Thanks!
 

cirrusbonsai

New Member
Yeah, it makes sense to downgrade at this point.

In my testing: I can't get it to work in Teams. Won't show up as an option in PhotoBooth. Seems work in Zoom (at least, in the Preview window).

I've tried adjusting various video, camera and output settings (though, some of them are beyond my knowledge)... nothing seems to work. Strange bug.

Anyone have steps to downgrade?
 

davidthebikeguy

New Member
Yup. Same here. I tried on Zoom and WebEx - no joy. So I went to another system, same MacOS version and Zoom/Webex on the not-working system etc, and older on it and it stll worked. Looked here and thanks for the above from @lady20miles went to 28.1.2 and back to good ole working. Definitely a solid fix from my perpective.
 

Geoff_me

New Member
I managed to get this working on a MAC. Whilst staying on v29 and not rolling back to an earlier version.
I had the issue were the virtual cam in Teams and Zoom was not showing my desktop in v29.


I installed version 29, rebooted my mac, ensured security permissions on 'Settings/Security and Privacy' were ok then I went and found the OBS app in the applications folder and right clicked on it choosing 'Get Info', at the bottom of this screen I ensured Admin user had 'Read and Write' access. Then back in OBS on the menu towards the bottom of the screen were you can switch on virtual camera there is a cog to the right, I changed the output type to internal and the output selection away from program output and then back to program output. this fixed the issue, and now those settings I changed in the cog don't matter, but maybe changing them just woke up things. I think the main fix is likely the read write at an Admin level that solved the issue for me. I hope this helps someone else!

1673438370822.png
1673438311715.png
1673438293779.png
 

travispetty

New Member
I managed to get this working on a MAC. Whilst staying on v29 and not rolling back to an earlier version.
I had the issue were the virtual cam in Teams and Zoom was not showing my desktop in v29.


I installed version 29, rebooted my mac, ensured security permissions on 'Settings/Security and Privacy' were ok then I went and found the OBS app in the applications folder and right clicked on it choosing 'Get Info', at the bottom of this screen I ensured Admin user had 'Read and Write' access. Then back in OBS on the menu towards the bottom of the screen were you can switch on virtual camera there is a cog to the right, I changed the output type to internal and the output selection away from program output and then back to program output. this fixed the issue, and now those settings I changed in the cog don't matter, but maybe changing them just woke up things. I think the main fix is likely the read write at an Admin level that solved the issue for me. I hope this helps someone else!

View attachment 90514 View attachment 90513 View attachment 90512
This "almost" worked for me . . . after following your steps, it showed (in a zoom sesh) a FROZEN frame of my OBS output. And I couldn't get it to do that consistently. So . . . ya . . . going back to v28 for now. Surely they'll be a 29.0.1 in due time with this fixed :-)
 

claireannette

New Member
Can anyone report that this issue is now fixed with the latest OBS release 29.0.02? Thanks
It is certainly not fixed yet. I put off doing the update until today (march 13th, 2023) and immediately had crashing issues and obs virtual cam not relaying in zoom. I went ahead and installed 28v of OBS, did a reboot and all my problems went away. I hope the developers find a fix for this soon.
 

lengold

New Member
It is certainly not fixed yet. I put off doing the update until today (march 13th, 2023) and immediately had crashing issues and obs virtual cam not relaying in zoom. I went ahead and installed 28v of OBS, did a reboot and all my problems went away. I hope the developers find a fix for this soon.
Thank you very much for responding, appreciated. I will hold off updating.
 

jay9901

New Member
I am a little bit surprised to discover after upgrading from 28 to 29.0.2 that Virtual Camera is not working on my 2019 MacBook Pro Radeon Pro 555X 4 GB. Literally not at all. Does it work for anyone?
 

StudioNSFW

New Member
No, Virtual Camera does not work for me on your 2019 MacBook Pro Radeon either. But I don't think your computer is the issue, in that it also does not work on my 2021 16" Mac Book Pro (Apple M1 Pro Silicon, 16GB RAM). Just did the downgrade back to v28 and initial testing with Zoom seems to show it working now...
 

DJ KenJ

New Member
On the Apples computers, you need to go into the Privacy and Security settings, then Screen Record, then add both OBS and your conferencing app.
 

iamalexbrady

New Member
I managed to get this working on a MAC. Whilst staying on v29 and not rolling back to an earlier version.
I had the issue were the virtual cam in Teams and Zoom was not showing my desktop in v29.


I installed version 29, rebooted my mac, ensured security permissions on 'Settings/Security and Privacy' were ok then I went and found the OBS app in the applications folder and right clicked on it choosing 'Get Info', at the bottom of this screen I ensured Admin user had 'Read and Write' access. Then back in OBS on the menu towards the bottom of the screen were you can switch on virtual camera there is a cog to the right, I changed the output type to internal and the output selection away from program output and then back to program output. this fixed the issue, and now those settings I changed in the cog don't matter, but maybe changing them just woke up things. I think the main fix is likely the read write at an Admin level that solved the issue for me. I hope this helps someone else!

View attachment 90514

This worked for me
 
Top