Question / Help OBS encode eventually locking CPU at low clock rate

dilutedspine

New Member
In the past month or so I've run into an issue where after some time streaming my CPU will declock to 1.19GHz and stick there till the moment I close OBS. Sometimes it happens after 20 minutes, sometimes it happens after 4 hours. Stopping the stream/recording does nothing to return the clock speed to normal.

I thought thermal throttling at first but this isn't the case as I have been monitoring the CPU temps and haven't seen anything above 50C. I haven't monitored VRMs or anything of that nature but the case has sufficient cooling and has been in use for years without issue so I don't anticipate this is causing the issues. Additionally the clock speed would immediately recover when stopping the stream/recording instead of only recovering whenever I close OBS.

I've been using this PC as a streaming rig on and off for years. In the past I've been able to use it at the Medium Preset (even Slow depending on the game) without issue. It's also seen a lot of use as a Hyper-V Hypervisor in the past as well before moving back to using it as a streaming rig recently. I have the same issues using both capture cards as the video source and NDI as the video source. Never before have I ever seen it's clock speed lock like this with an application. I would expect it would happen immediately so it's super strange that it happens after some time has passed.

This is a recent install of Windows (less than 3 months old I'd guess) and a recent install / update of OBS as well.

The log attached is from a quick record I did this morning that had the issue happen within a few minutes of streaming.

Things I've Tried:
Disabling Speed Stepping in the BIOS
Setting Power Profile to Max Performance
Trying different priority settings for OBS
Tried hard setting threads=24 in x264 options
Lowered Presets to Fast from Medium.

Things I'm working on today:
Updating to 2020-03 CU 1909
Updating BIOS/Firmware (been a while)

------------------
System Information
------------------
Time of this report: 4/12/2020, 14:06:12
Operating System: Windows 10 Pro 64-bit (10.0, Build 18363) (18362.19h1_release.190318-1202)
Language: English (Regional Setting: English)
System Manufacturer: ASUS
System Model: All Series
BIOS: 3005 (type: UEFI)
Processor: Genuine Intel(R) CPU @ 2.00GHz (24 CPUs), ~2.0GHz *(Intel Xeon E5-2658 v3 ES)*
Memory: 32768MB RAM
Available OS Memory: 32678MB RAM
Page File: 8501MB used, 29041MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 144 DPI (150 percent)
DWM DPI Scaling: UnKnown
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0387 64bit Unicode

Normally I would never bother you guys with questions since I can usually find the answers to almost any question I have on the forums but this one has me super stumped. Any help is appreciated. Thank you!
 

Attachments

  • 2020-04-12 13-49-03.txt
    16.8 KB · Views: 12

R1CH

Forum Admin
Developer
Your CPU is an engineering sample, so all bets as to how a CPU should work are off. Most likely it involves clock offsets for AVX or other supplemental instructions not being implemented properly.
 

dilutedspine

New Member
Strange though that it's fine for over 3 years and suddenly it's not? Does that much really change in the x264 encoder stuff that OBS uses?
 
Top