Question / Help No video feed from video capture card in preview window


Alright, I need some help here. I have been streaming for about a year and a half and now I have finally managed to acquire my first capture card. This is the Elgato Video Capture device. Mind you, this is NOT (!) either the Elgato 60 or the Elgato HD. This is the smaller card which has a standard composite red/white/yellow cable-bundle as well as an S-Video alternative.

I have set up everything according to instructions. The red, yellow and white calbes are all connected to my TV as well as my computer through a SCART-switch.

At first I had some problems with the video feed not getting through to my computer as the software reported a "no signal" error; though the audio came through fine. It turned out to be a simple connector problem and I fixed it by replacing my SCART-cable with the SCART-adapter that came with the card. So now the video feed of my original old XBOX as well as the audio showed up in Elgato's own software on my computer, no more "No Signal"-errors.

Great? great!

However, now we come to OBS Studio and it's issues. (which is strange because I thought the hard part was getting the feed to appear on my computer at all; I figured adding the source in OBS Studio would be easy by comparisson)

I had already done some research and I deduced from both Youtube-videos as well as my own common sense that the capture card should not be entered as a new window capture-source or as a display capture-source; since it is a video capture device, and so everything pointed to the fact that it should show up under "Video Capture Device". Apparently people have been having some problems with it not showing up in the drop down menu for the new source, resulting from bad drivers or whatnot... but lo and behold, the Elgato Video Capture card DID show up for me! :D It was right there in the drop down menu. Awesome, OBS Studio had detected it!

Great? You bet! :D I was on my way!

But.... as I added the source... nothing showed up in the preview window, nothing but the standard red-bordered square which indicates the new source. And this is where I just have no clue how to solve the problem. The red border of the window is freely adjustable, no locked aspect ratio or anything. I tried fiddling with the video settings for the source but nothing seems to make any difference. I have tried restarting the software, OBS Studio, re-connecting... it's so strange, because the feed comes through in Elgato's own software nice and clear and the device IS recognized as a video capture device in the drop down menu, but the video feed itself in in the preview window is non-existant.

I do have a webcam in the same scene and at first I thought it might be conflicting with the other video capture device I was trying to add because I do know from previous experiments that you can't have multiple webcam feeds in the same scene (for some reason, one seems to always be prioritized with the other just not showing anything), but making the webcam invisible in the source-list didn't fix the problem.

I have run into similar problems before, where freely adjustable source-windows without locked aspect ratios would indicate that the video feed isn't recognized at all by OBS Studio, as the aspect ratios usually maintain their original dimensions when adjusting the red borders, but that has usually been fixed by either rebooting, adjusting some setting (like I could remember which) or simply using a different method, like using Window Capture.

Now, Window Capture on the other hand does work, I just have to crop the source, but I would prefer to have the proper video capture device-source be the one to use because upscaling the cropped window capture seriously degrades video quality and I suspect it is not the optimal choice here.

My specs:
* Windows 10 Home
* OBS Studio 21.1.0 (64 bit)

Does anybody know anything about this?


Yeah, just thought I'd update.... I now know what the deal was with the video feed, but solving that problem just had me running face-first into two new ones:

The problem with the video feed was that it wouldn't show up if I had the Elgato software app running at the same time, most likely some sort of conflict. I tried to run it in OBS on it's own and it finally worked. (though the video quality was no better unfortunately)

However, now two new problems arose.... (1) instead of no video showing up, this time there is no sound. The Elgato device added a sound bar in the list but it remains quiet. And (2) one of my widgets just mysteriously stopped working; a streamlabs browser add-on suddenly decided to refuse to show up.

I'm telling you, this is just getting weirder and weirder.


Ok, apparently Streamlabs are having global problems, it's not just me. However, I don't think the sound issue is a part of it, but whatever.... I need some sleep so I'll check on this tomorrow instead. Might have to fork up enough dough to buy an Elgato SuperUltraHighTechGiveMeYourMoneyNOW card after all.


Never mind, I will return this lightweight piece of **** and gouge out my guts in search of enough money to get my hands on a 60 S. Thanks anyway.


You could always just get a sound capture device instead of an entirely new Elgato, I'm sure they're cheaper. Also, I'm sure you tried this, but are you sure that you plugged in the sound cables securely, and in the right ports"?


Thanks for the advice, yes I checked the cables thoroughly. I think the best thing I can do is to just go for the proper deal and not do things half-assed. I thought I could get away with AV-signals through composite cables and have them be more or less clear in the streaming software, however, you wouldn't believe the amount of signal degredation. It looked like unbelievable crap. And I would get people questioning that with no end. Better to invest in the real deal so I don't have to switch further down the line. Thanks for replying though.