Lag, Hitching and Stutters in Recordings

MahGoots

New Member
Hello,

I just started recording gameplay on a new PC I built last week (RTX 3090, Ryzen 7 5800x) and my output files are extremely laggy. None of the stutters or dropped frames are apparent in-game, only when watching the OBS mkv output file. I was originally using VBR rate control, 50,000 - 100,000 Kbps, while playing at 4K with an uncapped framerate, which produced unwatchable output files. I've tried lowering the bitrate range to 40K - 50K, switching to CBR rate control, capping OBS at 30 FPS, capping in-game framerates to 60 FPS (this helped some), changing in game resolution to 2K as well as 1080p, lowering all in game graphics settings to 'low', running OBS as administrator, and setting the OBS Process Priority to both 'High' and 'Above Normal'. However, I am still getting dropped frames and hitches.

I've attached screenshots of my current OBS settings, as well as a screenshot of my GPU and CPU utilization at current settings(CPU sits around 30%, GPU sits at 50%, jumping to around 60% at times). I'm at a loss at this point, and really hoping I'm missing something basic here, as I never had any of these issues on my old PC (RTX 1080, i7-6700k).

(Log file: https://obsproject.com/logs/iKJLPXvswHsNCCMu)

Any assistance here is greatly appreciated.
 

Attachments

  • OBS_Advanced.PNG
    OBS_Advanced.PNG
    69.3 KB · Views: 16
  • OBS_Output.PNG
    OBS_Output.PNG
    69.5 KB · Views: 17
  • OBS_Task_Manager.PNG
    OBS_Task_Manager.PNG
    130.4 KB · Views: 16
  • OBS_Video.PNG
    OBS_Video.PNG
    41.6 KB · Views: 15
Top