i get lags when streaming

sometimes my csgo viewmodel is a bit laggy, but not the whole game itself, i don't seem to be lagging myself, just my viewmodel, sometimes my internet slows down and stuff every time i stream idk why, my internet speed is "very fast" it says, 400/8-12 (comcast or xfinity)

when i use like 5000 bitrate or lower, low latency performance, it doesn't seem to lag at all, why does this happen?


logs here:
 

Attachments

  • 2021-03-24 16-56-27.txt
    12.9 KB · Views: 9

qhobbes

Active Member
1. If available via Windows Update, update to Windows 10 2009 per https://obsproject.com/blog/five-simple-tips-for-new-streamers
2. The new Windows 10 Hardware-accelerated GPU scheduling ("HAGS") added with version 2004 is currently known to cause performance and capture issues with OBS, games and overlay tools. It's a new and experimental feature and we recommend disabling it via this screen or these instructions.
3. Change the refresh rate on your Sceptre monitor to 120 Hz and cap your games at 120 FPS.
4. Your log contains streaming session. Results of this log analysis are limited. Please post a link to a clean log file.
To make a clean log file, please follow these steps:

1) Restart OBS.
2) Start your stream for at least 30 seconds. Make sure you replicate any issues as best you can, which means having any games/apps open and captured, etc.
3) Stop your stream/recording.
4) Select Help > Log Files > Upload Current Log File. Send that link via here.
 

fatmatrow

Member
why would i cap my monitor and game to 120?
One reason is leaving enough overhead for everything, and also because if you're streaming/recording in 60fps then your FPS needs to be the same or a multiple of it or it will look stuttery. If you're taking every frame at 60 or every other frame at 120, it will be nice and smooth, it has to go 1 frame, skip, 1 frame, skip skip 1 frame skip etc otherwise
 
Top