Question / Help Game Audio Issues

Combat Wombat

New Member
I'm new to OBS and recording in general. Right now the only issue I'm encountering has to deal with my audio.

To clarify beforehand, all audio is being recorded, it's just that my recorded game audio comes out sounding very... Airy. It sounds light, lacks bass, and some noises arent as loud as you'd expect.

Ex: Footsteps come out loud and clear, ambient birds in the background are good, but then I fire my weapon and it is quieter than any other noise.

The audio is being fed through my headset, which is a Logitech Artemis Spectrum G633. My computer is just a 15.6' HP Pavilion Laptop l with an I7 in it. (Currently not home so I can't check the exact specs)

The answer I'm looking for is how to fix my game audio. It comes through great in my headset but once its recorded, its pretty rough. I've played with the filters a bit but I don't exactly know what I'm doing! A couple of video tutorials later have left me without answers still.

I'd just like for my little recorded shenanigans to sound good and not like a muffled, airy, oddity.

(I can post more specific specs and info later today once I get home if needed.)
 

Narcogen

Active Member
Post a logfile and screencap your settings > audio and edit > advanced audio properties screens.
 

Combat Wombat

New Member
Post a logfile and screencap your settings > audio and edit > advanced audio properties screens.
Most Recent Log File:

21:14:16.775: CPU Name: Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
21:14:16.775: CPU Speed: 2592MHz
21:14:16.775: Physical Cores: 2, Logical Cores: 4
21:14:16.775: Physical Memory: 12177MB Total, 7972MB Free
21:14:16.775: Windows Version: 10.0 Build 18362 (revision: 295; 64-bit)
21:14:16.775: Running as administrator: true
21:14:16.775: Aero is Enabled (Aero is always on for windows 8 and above)
21:14:16.775: Windows 10 Gaming Features:
21:14:16.775: Game DVR: On
21:14:16.778: Sec. Software Status:
21:14:16.780: Windows Defender Antivirus: enabled (AV)
21:14:16.780: Windows Firewall: enabled (FW)
21:14:16.781: Current Date/Time: 2019-09-05, 21:14:16
21:14:16.781: Browser Hardware Acceleration: true
21:14:16.781: Portable mode: false
21:14:17.272: OBS 23.2.1 (64-bit, windows)
21:14:17.272: ---------------------------------
21:14:17.291: ---------------------------------
21:14:17.291: audio settings reset:
21:14:17.291: samples per sec: 48000
21:14:17.291: speakers: 2
21:14:17.292: ---------------------------------
21:14:17.292: Initializing D3D11...
21:14:17.292: Available Video Adapters:
21:14:17.299: Adapter 0: NVIDIA GeForce 940MX
21:14:17.299: Dedicated VRAM: 2107703296
21:14:17.299: Shared VRAM: 2089762816
21:14:17.299: output 0: pos={0, 0}, size={1366, 768}, attached=true
21:14:17.299: Adapter 1: Intel(R) HD Graphics 520
21:14:17.299: Dedicated VRAM: 134217728
21:14:17.299: Shared VRAM: 2089762816
21:14:17.304: Loading up D3D11 on adapter NVIDIA GeForce 940MX (0)
21:14:17.443: D3D11 loaded successfully, feature level used: 45056
21:14:18.577: ---------------------------------
21:14:18.577: video settings reset:
21:14:18.577: base resolution: 1366x768
21:14:18.577: output resolution: 816x460
21:14:18.577: downscale filter: Bicubic
21:14:18.577: fps: 24000/1001
21:14:18.577: format: NV12
21:14:18.577: YUV mode: 601/Full
21:14:18.577: NV12 texture support enabled
21:14:18.579: Audio monitoring device:
21:14:18.579: name: Speakers (Logitech G633 Gaming Headset)
21:14:18.579: id: {0.0.0.00000000}.{f11c07a6-9438-4f8a-b462-a993ee195f7f}
21:14:18.579: ---------------------------------
21:14:18.586: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
21:14:18.587: Failed to load 'en-US' text for module: 'decklink-ouput-ui.dll'
21:14:18.720: [AMF] AMF Test failed due to one or more errors.
21:14:18.720: Failed to initialize module 'enc-amf.dll'
21:14:18.798: Module '../../obs-plugins/64bit/libEGL.dll' not loaded
21:14:18.804: [obs-browser]: Version 2.4.0
21:14:18.874: Couldn't find VLC installation, VLC video source disabled
21:14:18.906: No blackmagic support
21:14:18.948: ---------------------------------
21:14:18.948: Loaded Modules:
21:14:18.948: win-wasapi.dll
21:14:18.948: win-mf.dll
21:14:18.948: win-dshow.dll
21:14:18.948: win-decklink.dll
21:14:18.948: win-capture.dll
21:14:18.948: vlc-video.dll
21:14:18.948: text-freetype2.dll
21:14:18.948: rtmp-services.dll
21:14:18.948: obs-x264.dll
21:14:18.948: obs-vst.dll
21:14:18.948: obs-transitions.dll
21:14:18.948: obs-text.dll
21:14:18.948: obs-qsv11.dll
21:14:18.948: obs-outputs.dll
21:14:18.948: obs-filters.dll
21:14:18.948: obs-ffmpeg.dll
21:14:18.948: obs-browser.dll
21:14:18.948: image-source.dll
21:14:18.948: frontend-tools.dll
21:14:18.948: enc-amf.dll
21:14:18.948: decklink-ouput-ui.dll
21:14:18.948: coreaudio-encoder.dll
21:14:18.948: ---------------------------------
21:14:18.948: ==== Startup complete ===============================================
21:14:18.949: Service '' not found
21:14:18.953: All scene data cleared
21:14:18.953: ------------------------------------------------
21:14:19.042: WASAPI: Device 'Speakers (Logitech G633 Gaming Headset)' initialized
21:14:19.065: WASAPI: Device 'Microphone (Logitech G633 Gaming Headset)' initialized
21:14:19.131: adding 64 milliseconds of audio buffering, total audio buffering is now 64 milliseconds (source: Mic/Aux)
21:14:19.131:
21:14:19.230: Switched to scene 'Scene'
21:14:19.230: ------------------------------------------------
21:14:19.230: Loaded scenes:
21:14:19.230: - scene 'Scene':
21:14:19.230: - source: 'Game Capture' (game_capture)
21:14:19.230: ------------------------------------------------
 

Attachments

Narcogen

Active Member
You've set your capture device and your monitoring device to be the same. You shouldn't do that-- it doesn't matter as long as you keep all devices on all tracks set to "monitor off" but at least in theory, the monitor device should not be your default device.

You shouldn't need filters to get decent audio. Check in your Windows Sound control panel, and make sure everything is set to the same sample rate as you've set in OBS (in your case, 48khz) and also turn off windows ducking, because that will make the desktop audio quieter when you use your microphone.

For slightly better quality of recorded audio you can install the AAC encoder:

https://obsproject.com/forum/resources/obs-studio-enable-coreaudio-aac-encoder-windows.220/
 

Combat Wombat

New Member
You've set your capture device and your monitoring device to be the same. You shouldn't do that-- it doesn't matter as long as you keep all devices on all tracks set to "monitor off" but at least in theory, the monitor device should not be your default device.

You shouldn't need filters to get decent audio. Check in your Windows Sound control panel, and make sure everything is set to the same sample rate as you've set in OBS (in your case, 48khz) and also turn off windows ducking, because that will make the desktop audio quieter when you use your microphone.

For slightly better quality of recorded audio you can install the AAC encoder:

https://obsproject.com/forum/resources/obs-studio-enable-coreaudio-aac-encoder-windows.220/

I was able to get the AAC Encoder, recorded video still sounds... Muffled, to say the least. I set everything to 48khz in the Sound Settings, and disabled the ducking. I went back and forth between the Monitor being the headset and the Realtek Speakers on the computer and didn't notice much of a difference.

I appreciate your help, is there anything else you can think of as a last-ditch effort?

also, here is the most recent log if you need it

08:45:45.824: CPU Name: Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
08:45:45.824: CPU Speed: 2592MHz
08:45:45.824: Physical Cores: 2, Logical Cores: 4
08:45:45.824: Physical Memory: 12177MB Total, 6171MB Free
08:45:45.824: Windows Version: 10.0 Build 18362 (revision: 295; 64-bit)
08:45:45.824: Running as administrator: true
08:45:45.824: Aero is Enabled (Aero is always on for windows 8 and above)
08:45:45.825: Windows 10 Gaming Features:
08:45:45.825: Game DVR: On
08:45:45.826: Sec. Software Status:
08:45:45.828: Windows Defender Antivirus: enabled (AV)
08:45:45.828: Windows Firewall: enabled (FW)
08:45:45.829: Current Date/Time: 2019-09-06, 08:45:45
08:45:45.829: Browser Hardware Acceleration: true
08:45:45.829: Portable mode: false
08:45:46.286: OBS 23.2.1 (64-bit, windows)
08:45:46.286: ---------------------------------
08:45:46.304: ---------------------------------
08:45:46.304: audio settings reset:
08:45:46.304: samples per sec: 48000
08:45:46.304: speakers: 2
08:45:46.305: ---------------------------------
08:45:46.305: Initializing D3D11...
08:45:46.305: Available Video Adapters:
08:45:46.314: Adapter 0: NVIDIA GeForce 940MX
08:45:46.314: Dedicated VRAM: 2107703296
08:45:46.314: Shared VRAM: 2089762816
08:45:46.314: output 0: pos={0, 0}, size={1366, 768}, attached=true
08:45:46.314: Adapter 1: Intel(R) HD Graphics 520
08:45:46.314: Dedicated VRAM: 134217728
08:45:46.314: Shared VRAM: 2089762816
08:45:46.320: Loading up D3D11 on adapter NVIDIA GeForce 940MX (0)
08:45:46.366: D3D11 loaded successfully, feature level used: 45056
08:45:47.693: ---------------------------------
08:45:47.693: video settings reset:
08:45:47.693: base resolution: 1366x768
08:45:47.693: output resolution: 816x460
08:45:47.693: downscale filter: Bicubic
08:45:47.693: fps: 24000/1001
08:45:47.693: format: NV12
08:45:47.693: YUV mode: 601/Full
08:45:47.694: NV12 texture support enabled
08:45:47.696: Audio monitoring device:
08:45:47.696: name: Speakers (Logitech G633 Gaming Headset)
08:45:47.696: id: {0.0.0.00000000}.{f11c07a6-9438-4f8a-b462-a993ee195f7f}
08:45:47.697: ---------------------------------
08:45:47.705: [CoreAudio encoder]: Adding CoreAudio AAC encoder
08:45:47.706: Failed to load 'en-US' text for module: 'decklink-ouput-ui.dll'
08:45:47.846: [AMF] AMF Test failed due to one or more errors.
08:45:47.846: Failed to initialize module 'enc-amf.dll'
08:45:47.859: Module '../../obs-plugins/64bit/libEGL.dll' not loaded
08:45:47.861: [obs-browser]: Version 2.4.0
08:45:47.882: Couldn't find VLC installation, VLC video source disabled
08:45:47.888: No blackmagic support
08:45:47.894: ---------------------------------
08:45:47.894: Loaded Modules:
08:45:47.894: win-wasapi.dll
08:45:47.894: win-mf.dll
08:45:47.894: win-dshow.dll
08:45:47.894: win-decklink.dll
08:45:47.894: win-capture.dll
08:45:47.894: vlc-video.dll
08:45:47.894: text-freetype2.dll
08:45:47.894: rtmp-services.dll
08:45:47.894: obs-x264.dll
08:45:47.894: obs-vst.dll
08:45:47.894: obs-transitions.dll
08:45:47.894: obs-text.dll
08:45:47.894: obs-qsv11.dll
08:45:47.894: obs-outputs.dll
08:45:47.894: obs-filters.dll
08:45:47.894: obs-ffmpeg.dll
08:45:47.894: obs-browser.dll
08:45:47.894: image-source.dll
08:45:47.894: frontend-tools.dll
08:45:47.894: enc-amf.dll
08:45:47.894: decklink-ouput-ui.dll
08:45:47.894: coreaudio-encoder.dll
08:45:47.894: ---------------------------------
08:45:47.894: ==== Startup complete ===============================================
08:45:47.906: Service '' not found
08:45:47.910: All scene data cleared
08:45:47.910: ------------------------------------------------
08:45:47.976: WASAPI: Device 'Speakers (Logitech G633 Gaming Headset)' initialized
08:45:48.013: WASAPI: Device 'Microphone (Logitech G633 Gaming Headset)' initialized
08:45:48.059: adding 42 milliseconds of audio buffering, total audio buffering is now 42 milliseconds (source: Mic/Aux)
08:45:48.059:
08:45:48.338: Switched to scene 'Scene'
08:45:48.339: [game-capture: 'Game Capture'] attempting to hook process: insurgency_x64.exe
08:45:48.341: ------------------------------------------------
08:45:48.341: Loaded scenes:
08:45:48.341: - scene 'Scene':
08:45:48.341: - source: 'Game Capture' (game_capture)
08:45:48.341: ------------------------------------------------
08:45:48.368: [game-capture: 'Game Capture'] capture stopped
08:45:50.325: [game-capture: 'Game Capture'] attempting to hook process: insurgency_x64.exe
08:45:50.366: [game-capture: 'Game Capture'] capture stopped
08:45:52.326: [game-capture: 'Game Capture'] attempting to hook process: insurgency_x64.exe
08:45:52.368: [game-capture: 'Game Capture'] capture stopped
08:45:54.328: [game-capture: 'Game Capture'] attempting to hook process: insurgency_x64.exe
08:45:54.370: [game-capture: 'Game Capture'] capture stopped
08:45:56.330: [game-capture: 'Game Capture'] attempting to hook process: insurgency_x64.exe
08:45:56.372: [game-capture: 'Game Capture'] capture stopped
08:45:58.333: [game-capture: 'Game Capture'] attempting to hook process: insurgency_x64.exe
08:45:58.374: [game-capture: 'Game Capture'] capture stopped
 

Narcogen

Active Member
I was able to get the AAC Encoder, recorded video still sounds... Muffled, to say the least. I set everything to 48khz in the Sound Settings, and disabled the ducking. I went back and forth between the Monitor being the headset and the Realtek Speakers on the computer and didn't notice much of a difference.

I appreciate your help, is there anything else you can think of as a last-ditch effort?
What bitrate is set in Settings > Output > Audio ?

I suppose if it were too low there you might experience reduced audio quality.

In general if all you're doing is recording your system audio at full volume, with no filters, there should be no significant, noticeable difference between what you hear when playing audio the first time and what you hear playing back the recording.
 

Combat Wombat

New Member
What bitrate is set in Settings > Output > Audio ?

I suppose if it were too low there you might experience reduced audio quality.

In general if all you're doing is recording your system audio at full volume, with no filters, there should be no significant, noticeable difference between what you hear when playing audio the first time and what you hear playing back the recording.
Right now my audio bitrate is at 160.

Maybe I'm misunderstanding the second part, but since I'm recording via my headset I only have it set to about 20/100 because any higher than that my ears will explode haha
 

Narcogen

Active Member
What do your levels in OBS look like when you record? What's the highest peak?

If you need to have your system default audio so low it affects recording quality because the sound in your headphones is too loud, you probably need to use something like Voicemeeter to give you independent volume control of hardware monitoring devices.
 

Combat Wombat

New Member
What do your levels in OBS look like when you record? What's the highest peak?

If you need to have your system default audio so low it affects recording quality because the sound in your headphones is too loud, you probably need to use something like Voicemeeter to give you independent volume control of hardware monitoring devices.
Sorry for the delay! You've been a huge help, dude. Thanks for all your suggestions.

I was able to polish off my audio by basically undoing a few things that some big OBS "expert" on youtube recommended. Namely, I had my Desktop Audio Mixer turned down to about -10.0 dB. I turned it all the way back up and VOILA! It all works and I'm just a big dumb idiot.

Although it is much better now than it was before, so again, thanks for your help dude! I appreciate it haha
 

koala

Active Member
I was able to polish off my audio by basically undoing a few things that some big OBS "expert" on youtube recommended.
Don't mindlessly follow some guide. For every single setting you intend to change due to the guides' recommendation, try to understand what this change will do and why you need it. If you don't understand what it will do, and if you don't have a reason why you would change that setting, don't change the setting!
All defaults in OBS are sane values, usually the fastest and most secure values, and should only to be changed if you really need it. If you changed something and don't see the desired effect, revert to the default.
(this is true for every app you have on your computer, by the way)
 
Top