Question / Help Error NVENC or AMD encoders

#1
Hi,

I've been using OBS now for 5 years, and always with the NVENC +264 encoder. It has always worked beautifully, and given
great fps and quality. However 2 days ago, it started giving this error. I'm using an Nvidia GeForce GTX 1070 GPU with 8gb
ram, on a Windows 7 64 bit system with Intel i7 quad core with 32 gb of ram. I've been trying to solve this. I updated the video
driver to latest version but it didn't help. I have no other programs in memory using memory. I saw a video where memory was
causing it, but as I said I don't have a memory problem, I have 27gb free, generally 22gb.

Does anyone have any clues what's causing this? As I said, my GPU has run Nvenc now with no problems and does
support it.

This is my log:
21:45:04.875: CPU Name: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz​
21:45:04.875: CPU Speed: 3403MHz​
21:45:04.876: Physical Cores: 4, Logical Cores: 8​
21:45:04.876: Physical Memory: 31695MB Total, 27162MB Free​
21:45:04.876: Windows Version: 6.1 Build 7601 (revision: 24291; 64-bit)​
21:45:04.876: Running as administrator: true​
21:45:04.876: Aero is Enabled​
21:45:04.876: Browser Hardware Acceleration: true​
21:45:04.876: Portable mode: false​
21:45:05.057: OBS 22.0.1 (64-bit, windows)​
21:45:05.057: ---------------------------------​
21:45:05.058: ---------------------------------​
21:45:05.058: audio settings reset:​
21:45:05.058: samples per sec: 44100​
21:45:05.058: speakers: 2​
21:45:05.060: ---------------------------------​
21:45:05.060: Initializing D3D11...​
21:45:05.060: Available Video Adapters:​
21:45:05.063: Adapter 1: NVIDIA GeForce GTX 1070​
21:45:05.063: Dedicated VRAM: 4175364096​
21:45:05.063: Shared VRAM: 3464392704​
21:45:05.063: output 1: pos={0, 0}, size={1920, 1080}, attached=true​
21:45:05.063: Adapter 2: Intel(R) HD Graphics 4000​
21:45:05.063: Dedicated VRAM: 1073741824​
21:45:05.063: Shared VRAM: 771751936​
21:45:05.063: output 1: pos={1920, 0}, size={1680, 1050}, attached=true​
21:45:05.067: Loading up D3D11 on adapter NVIDIA GeForce GTX 1070 (0)​
21:45:05.098: D3D11 loaded successfully, feature level used: 45056​
21:45:05.762: ---------------------------------​
21:45:05.762: video settings reset:​
21:45:05.762: base resolution: 1920x1080​
21:45:05.762: output resolution: 1920x1080​
21:45:05.762: downscale filter: Lanczos​
21:45:05.762: fps: 30/1​
21:45:05.762: format: NV12​
21:45:05.762: YUV mode: 601/Partial​
21:45:05.764: Audio monitoring device:​
21:45:05.764: name: Default​
21:45:05.764: id: default​
21:45:05.764: ---------------------------------​
21:45:05.766: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed​
21:45:05.767: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded​
21:45:05.797: [AMF] AMF Test failed due to one or more errors.​
21:45:05.797: Failed to initialize module 'enc-amf.dll'​
21:45:05.812: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed​
21:45:05.812: LoadLibrary failed for '../../obs-plugins/64bit/libEGL.dll': The specified procedure could not be found.​
21:45:05.812: (127)​
21:45:05.812: Module '../../obs-plugins/64bit/libEGL.dll' not loaded​
21:45:05.813: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed​
21:45:05.814: [obs-browser]: Version 2.1.2​
21:45:05.818: NVENC supported​
21:45:05.841: Couldn't find VLC installation, VLC video source disabled​
21:45:05.845: No blackmagic support​
21:45:05.848: ---------------------------------​
21:45:05.848: Loaded Modules:​
21:45:05.848: win-wasapi.dll​
21:45:05.848: win-mf.dll​
21:45:05.848: win-dshow.dll​
21:45:05.848: win-decklink.dll​
21:45:05.848: win-capture.dll​
21:45:05.848: vlc-video.dll​
21:45:05.848: text-freetype2.dll​
21:45:05.848: rtmp-services.dll​
21:45:05.848: obs-x264.dll​
21:45:05.848: obs-vst.dll​
21:45:05.848: obs-transitions.dll​
21:45:05.848: obs-text.dll​
21:45:05.848: obs-qsv11.dll​
21:45:05.848: obs-outputs.dll​
21:45:05.848: obs-filters.dll​
21:45:05.848: obs-ffmpeg.dll​
21:45:05.848: obs-browser.dll​
21:45:05.848: image-source.dll​
21:45:05.848: frontend-tools.dll​
21:45:05.848: enc-amf.dll​
21:45:05.848: coreaudio-encoder.dll​
21:45:05.848: ---------------------------------​
21:45:05.848: ==== Startup complete ===============================================​
21:45:05.851: All scene data cleared​
21:45:05.852: ------------------------------------------------​
21:45:05.870: WASAPI: Device 'VoiceMeeter Input (VB-Audio VoiceMeeter VAIO)' initialized​
21:45:05.879: WASAPI: Device 'CABLE-A Input (Discord) (VB-Audio Cable A)' initialized​
21:45:05.883: WASAPI: Device 'Microphone (2- RODE NT-USB)' initialized​
21:45:05.897: WASAPI: Device 'Speakers (VIA High Definition Audio)' initialized​
21:45:05.902: WASAPI: Device 'Microphone (2- RODE NT-USB)' initialized​
21:45:05.908: WASAPI: Device 'VoiceMeeter Input (VB-Audio VoiceMeeter VAIO)' initialized​
21:45:05.909: [Media Source 'Intro']: settings:​
21:45:05.909: input: D:/Channel Clips/Intro - NeonsStyle 1080p.mp4​
21:45:05.909: input_format: (null)​
21:45:05.909: speed: 100​
21:45:05.909: is_looping: no​
21:45:05.909: is_hw_decoding: yes​
21:45:05.909: is_clear_on_media_end: no​
21:45:05.909: restart_on_activate: yes​
21:45:05.909: close_when_inactive: no​
21:45:05.918: adding 23 milliseconds of audio buffering, total audio buffering is now 23 milliseconds​
21:45:06.227: adding 23 milliseconds of audio buffering, total audio buffering is now 46 milliseconds​
21:45:06.405: Switched to scene 'Desktop'​
21:45:06.435: ------------------------------------------------​
21:45:06.435: Loaded scenes:​
21:45:06.435: - scene 'Games':​
21:45:06.435: - source: 'Intro' (ffmpeg_source)​
21:45:06.435: - source: 'Game Capture' (game_capture)​
21:45:06.435: - scene 'Desktop':​
21:45:06.435: - source: 'Monitor 2' (monitor_capture)​
21:45:06.435: - source: 'Display Capture' (monitor_capture)​
21:45:06.435: - source: 'Mic Rode NY-USB' (wasapi_input_capture)​
21:45:06.435: - source: 'default' (wasapi_output_capture)​
21:45:06.435: - source: 'Intro' (ffmpeg_source)​
21:45:06.435: - source: 'Speakers' (wasapi_output_capture)​
21:45:06.435: ------------------------------------------------​
21:45:06.904: CalculateFileHash: Failed to open file 'C:\Users\Neon\AppData\Roaming\obs-studio\updates\whatsnew.json':​
21:45:10.561: ---------------------------------​
21:45:10.561: [NVENC encoder: 'recording_h264'] settings:​
21:45:10.561: rate_control: CQP​
21:45:10.561: bitrate: 0​
21:45:10.561: cqp: 20​
21:45:10.561: keyint: 250​
21:45:10.561: preset: default​
21:45:10.561: profile: main​
21:45:10.561: level: 5.1​
21:45:10.561: width: 1920​
21:45:10.561: height: 1080​
21:45:10.561: 2-pass: true​
21:45:10.561: b-frames: 2​
21:45:10.561: GPU: 1​
21:45:10.561:​
21:45:10.721: [NVENC encoder: 'recording_h264'] Failed to open NVENC codec: Generic error in an external library​
21:45:16.713: User switched to scene 'Games'​
21:45:18.169: ---------------------------------​
21:45:18.169: [NVENC encoder: 'recording_h264'] settings:​
21:45:18.169: rate_control: CQP​
21:45:18.169: bitrate: 0​
21:45:18.169: cqp: 20​
21:45:18.169: keyint: 250​
21:45:18.169: preset: default​
21:45:18.169: profile: main​
21:45:18.169: level: 5.1​
21:45:18.169: width: 1920​
21:45:18.169: height: 1080​
21:45:18.169: 2-pass: true​
21:45:18.169: b-frames: 2​
21:45:18.169: GPU: 1​
21:45:18.169:​
21:45:18.170: [NVENC encoder: 'recording_h264'] Failed to open NVENC codec: Generic error in an external library​
21:45:20.151: User switched to scene 'Desktop'​
21:45:49.028: ---------------------------------​
21:45:49.028: [NVENC encoder: 'recording_h264'] settings:​
21:45:49.028: rate_control: CQP​
21:45:49.028: bitrate: 0​
21:45:49.028: cqp: 20​
21:45:49.028: keyint: 250​
21:45:49.028: preset: default​
21:45:49.028: profile: main​
21:45:49.028: level: 5.1​
21:45:49.028: width: 1920​
21:45:49.028: height: 1080​
21:45:49.028: 2-pass: true​
21:45:49.028: b-frames: 2​
21:45:49.028: GPU: 1​
21:45:49.028:​
21:45:49.029: [NVENC encoder: 'recording_h264'] Failed to open NVENC codec: Generic error in an external library​
21:46:28.762: ---------------------------------​
21:46:28.762: [NVENC encoder: 'recording_h264'] settings:​
21:46:28.762: rate_control: CQP​
21:46:28.762: bitrate: 0​
21:46:28.762: cqp: 20​
21:46:28.762: keyint: 250​
21:46:28.762: preset: default​
21:46:28.762: profile: main​
21:46:28.762: level: 5.1​
21:46:28.762: width: 1920​
21:46:28.762: height: 1080​
21:46:28.762: 2-pass: true​
21:46:28.762: b-frames: 2​
21:46:28.762: GPU: 1​
21:46:28.762:​
21:46:28.763: [NVENC encoder: 'recording_h264'] Failed to open NVENC codec: Generic error in an external library​
21:50:25.095: ---------------------------------​
21:50:25.095: [NVENC encoder: 'recording_h264'] settings:​
21:50:25.095: rate_control: CQP​
21:50:25.095: bitrate: 0​
21:50:25.095: cqp: 20​
21:50:25.095: keyint: 250​
21:50:25.095: preset: default​
21:50:25.095: profile: main​
21:50:25.095: level: 5.1​
21:50:25.095: width: 1920​
21:50:25.095: height: 1080​
21:50:25.095: 2-pass: true​
21:50:25.095: b-frames: 2​
21:50:25.095: GPU: 1​
21:50:25.095:​
21:50:25.096: [NVENC encoder: 'recording_h264'] Failed to open NVENC codec: Generic error in an external library​
 
Top