audio stopped with windows 10 update to 20H2

Tech at PVMC

New Member
after upgrade to windows 10 20H2 the audio mixer no longer shows anything for desktop audio (qu32 mixer) nor desktop audio 2. The system sound properties for Line Qu-32 shows movement in the vu meter and if I play a local video the playback device Qu-32 CH27/28 shows movement in the vu meter. testing session log file attached
 

Attachments

Lawrence_SoCal

Active Member
Windows 10 audio settings/config is a lot more complicated than in the 'old' days. Audio devide re-enumeration can cause headaches, as well as Audio software (I have realtek) which makes assumptions/changes which sometimes conflict with my expectations.

In OBS v26, the native 'Audio monitor' will display the device connected (often "Default"). Try changing that to the specific device desired
I've found when I have an issue, checking the Windows OS audio device defaults and 'correcting' any changes resolves my issue.
Hopefully your issue is that small
 

Tech at PVMC

New Member
Thanks for the reply!

We've tried a lot of different things, so they may be running together in my mind slightly.

We have some older (from October, 2020) documentation with screenshots of how we had it set up. All of the inputs on the Audio tab were set to disabled. But, even when we enable them, and select which input we do want (which does show up there), there's never any activity in the VU meter, and if we make a test recording, it comes out silent.

The tricky part is that we can see in the Windows control panel the input jumping as we are sending sound through it. As a further test, we installed Audacity, and it was able to record from that line in with no problems.

We're this close to just uninstalling OBS and reinstalling it again, but we're not sure we'd keep our settings (or if we would want to, maybe that's where the issue is?), or if that would even fix the issue. From the logs, there were some errors, but we're not really sure what a 'normal' state would look like. Does it matter if an encoder is not loaded or installed? Can we install one manually?

10:31:42.017: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
10:31:42.017: Failed to load 'en-US' text for module: 'decklink-captions.dll'
10:31:42.018: Failed to load 'en-US' text for module: 'decklink-ouput-ui.dll'
10:31:42.039: [AMF] Unable to load 'amfrt64.dll', error code 126.
10:31:42.041: [AMF] AMF Test failed due to one or more errors.
10:31:42.041: Failed to initialize module 'enc-amf.dll'
10:31:42.059: [obs-browser]: Version 2.9.1
 

Lawrence_SoCal

Active Member
The CoreAudio AAC is a common error (if you don't separately install Apples AAC encoder, if i recall correctly). Apple's encoder is apparently better, but not required. This should have no bearing on your experience
Just checked - my logs have all of the same notes, and my system works fine

I ran into issues initially (OBS newb user errors), so I disabled all of the global audio devices in OBS, then I added a specific Audio Capture device in my scene list (and then referenced that source in my almost 30 scenes). I still have had issues... and not sure I'd 'blame' OBS

I've found that Windows OS has changed something. Part of the 'problem' is that the devices are defined for certain hardware (at live stream location, House of Worship in my case). I take the PC home to set it up for the upcoming stream, and those Audio (and Video devices) aren't available and I do run OBS... so that could contribute to issue. Usually no issue... but sometimes...especially if I plug a headset in at home (vs separate Line In audio connection and Speakers normally.. to listen/monitor/share pre-recorded content in between live video portions (scenes) of stream).

So, if you double-click your Audio input (capture) source and see device list, often it is listed as "Default" for me, even if I added for a specific device. You may need to 're-select' your device to correct device enumeration mapping?? As for "Default" for me.. that may be because I check it when that specific device isn't available ;^) Anyway, something worth checking

Worst case - simply delete the Audio Capture Source (and all references, ie instances in other scenes), then re-add Source. This most likely isn't necessary, but I'm not knowledgeable enough to provide a more direct troubleshooting path, and I know this will most likely work
 

Tech at PVMC

New Member
We found a solution with an OBS plugin (link here)
https://github.com/Andersama/obs-asio/wiki/A&H-QU-32---QU-Series-to-OBS

Our assumption is that Windows changed the way sound is handled so that OBS no longer automatically found the sound inputted to the streaming PC from the Allen & Heath QU-32 mixer board. We had never configured audio input in OBS, which we assume automated this configuration for previous versions of Windows (we used default "desktop audio" to see the audio VU meter). The plugin gave us an OBS-ASIO option for Allen & Heath QU mixers which we then inserted as an audio source in each scene requiring sound from the mixer.

The confusing piece is that in OBS prior to the plugin solution above, the only devices in OBS audio settings used were desktop audio and desktop audio 2 (all mic/aux settings were disabled). Even attempts to enable the Line Qu-32 in one of the aux settings did not accept sound.
 

Lawrence_SoCal

Active Member
1 - yes some unexpected oddities with Win10, recent OS updates, and OBS sound device selection.
Other than #1 above, plugging our mixer into motherboard via Analog cable (will switch to USB shortly) and having Win10 sound system (Realtek) recognize the connection as a microphone, then in OBS adding Audio Input device and pointing to that microphone works great. I'm hoping that switching to USB will improve audio quality and give me DAW style access to each mixer channel... but we'll see

Audio related
 
Top