STANDyourGROUND

New Member
Hello Community,

First, I am new to OBS as a whole but I am also new to forums. This is the first forum I have posted to ever so forgive me if I break any etiquette. Now to the post.

My church has been using OBS Studio since the Coronavirus hit. It has been a great tool for us and has allowed us to continue worshiping. I have always had a problem with the audio though. Every now again, the audio would just drop out. The only solution I could some up for fixing it was to go into the audio capture device properties, change the device from "Analogue 1 + 2(Fosucrite Usb Audio)" to something else (either "Default" or "Line In (Realteck(r) Audio)" it didnt matter which one) and then back to "Analogue 1 + 2(Fosucrite Usb Audio)". This past week, I tried that fix and it did not fix it. I had to go so far as going to the "Windows Sound Panel" to disable and then enable the device to get the computer/OBS to get the audio again. I could really use some help since this had gotten much more complicated. Below is a list of the audio hardware that we use here and attached is the log file. I appreciate any help or direction that you all could give me.

Peace.

Sound board:
Behringer x32

Audio Capture Device:
Focusrite Scarlett 2i2 3rd Gen

Computer:
Windows 10 pro,
Vostro 5090
Intel Core i7-9700 CPU @ 3.00GHz 3.00GHz
16gb Ram
 

Attachments

VCLE

New Member
Hello,

We have the same device (Scarlett 2i2 3rd gen, and ATEM Mini) and are having the exact same problem. Have you found a solution to this issue?
 

STANDyourGROUND

New Member
I am sorry you are having the same problem. The problem is not OBS but with the 2i2 itself. I talked with the Focusrite people and they are very helpful. Here is basically what they told me:

  1. Optimize your computer using their recommendations. (Link)
    • Make sure to create a separate power plan so you aren't running your computer at 100% all the time.
  2. Make sure to set the buffer size is larger than the buffer size of OBS. Those two do not have to match. I moved mine from 256 to 512 (or something like that. I cannot remember what it is off the top of my head since I am not in front of the computer).
  3. There are further optimization steps on their website that I cannot find right now but they have some good help.
At the end of the day, the tech support through Focusrite is very helpful and will lead you in the right direction. I hope this helps!
 

VCLE

New Member
Thank you so much, I'll give this a try. We have an ATEM Mini, and these audio dropouts have happened while transitioning/selecting different cameras from the mini. It'll stutter, then drop audio. We were losing audio prior to buying the 2i2, so I thought this might be outside of the 2i2. I will optimize the audio for windows however. Thank you very much for your reply:)
 

STANDyourGROUND

New Member
You are welcome. I hope that it helps. Another helpful thing to do is to run the diagnostic tool in OBS. I believe it is in the help menu, but it will scan the log file that you have and show you any warning signs. I was also running into USB overload problems so the less stuff I had in USB ports the better. I would start there in case you are wondering about OBS being the problem.
 
Top