Question / Help XComposite and Source Engine Games

#1
(This post is a direct copy/paste of a post I made in the Linux Mint forums about a month ago that came to no avail, aside from changes to my screenfetch)

This has been one of the only major problems I've encountered on my switch to Linux. Overall, everything else has gone swimmingly, and I'm certain I'm pretty used to the workflow now.

However, although I don't publish videos of any type onto platforms such as YouTube, I do tend to record VODs of the games I play.
One of my most played games is Team Fortress 2, and I've discovered a bit of a problem when recording it using OBS 23.0.2 - As of writing this post, OBS Studio 23.1.0 has been released and the same issues occur. I'm using XComposite for recording, the "Mesa Workaround" just makes the recording go blank.

There seems to be a lot of issues with lighting in these games. In gameplay (playing them as normal) it looks fine, but OBS is receiving really messed up lighting and issues drawing other elements like the HUD.

I recorded a demo video showing off the situation a while ago, and it can be seen here.
https://www.youtube.com/watch?v=gLsWQGGaRiw

As for system information, here is my screenchfetch:
Code:
                                       matt@matt-desktop
 MMMMMMMMMMMMMMMMMMMMMMMMMmds+.        OS: Mint 19.1 tessa
 MMm----::-://////////////oymNMd+`     Kernel: x86_64 Linux 4.18.0-18-generic
 MMd      /++                -sNMd:    Uptime: 3h 18m
 MMNso/`  dMM    `.::-. .-::.` .hMN:   Packages: 3633
 ddddMMh  dMM   :hNMNMNhNMNMNh: `NMm   Shell: zsh 5.4.2
     NMm  dMM  .NMN/-+MMM+-/NMN` dMM   Resolution: 2960x1050
     NMm  dMM  -MMm  `MMM   dMM. dMM   DE: Cinnamon 4.0.10
     NMm  dMM  -MMm  `MMM   dMM. dMM   WM: Muffin
     NMm  dMM  .mmd  `mmm   yMM. dMM   WM Theme: Adapta-Eta (Adapta-Eta)
     NMm  dMM`  ..`   ...   ydm. dMM   GTK Theme: Arc-Dark [GTK2/3]
     hMM- +MMd/-------...-:sdds  dMM   Icon Theme: Flat-Remix-Blue
     -NMm- :hNMNNNmdddddddddy/`  dMM   Font: Ubuntu Light 9
      -dMNs-``-::::-------.``    dMM   CPU: AMD Athlon X4 860K Quad Core @ 4x 4GHz [40.0°C]
       `/dMNmy+/:-------------:/yMMM   GPU: Radeon RX 560 Series (POLARIS11, DRM 3.26.0, 4.18.0-18-generic, LLVM 8.0.0)
          ./ydNMMMMMMMMMMMMMMMMMMMMM   RAM: 4931MiB / 7931MiB
             \.MMMMMMMMMMMMMMMMMMM
I'm using the latest version of mesa from the padoka PPA, maintained by Paulo Dias. (19.0.1-3~b~padoka0)

This happens in all Source games, If anyone could supply an alternate recording workaround for OBS or a general fix (that won't impact performance as much as just screencapture) I would greatly appreciate it.
 
#5
The workaround should have been the "Alphaless texture format (Mesa workaround). If that it is not working it is either a bug or something with the setup is failing. Either way that would require some debbuging.

The workaround works on my Intel GPU.
 
#6
I had several different problems streaming with OBS Studio in Linux Mint for liek two years. I realized earlier this week that something to do with Cinnamon was causing all my problems. I installed and switched to Mate, disabled all compositing, and disabled flipping in the nvidia settings. Window capture now works perfectly with every game I've tried so far.

I just did a test recording and I don't seem to be having the same issues you are. https://www.youtube.com/watch?v=xC-W5IURXVY
 
#7
So in my case, disabling compositing and disabling some features in the GPU settings seems to be what fixed all my window capture problems. Cinnamon has an option to disable compositing for full screen applications, but I don't think it actually works. I had to switch to Mate to actually disable compositing.
 
Last edited:
#8
The workaround should have been the "Alphaless texture format (Mesa workaround). If that it is not working it is either a bug or something with the setup is failing. Either way that would require some debbuging.

The workaround works on my Intel GPU.
Yeah it just leads to a completely black viewport for me in OBS.

I had several different problems streaming with OBS Studio in Linux Mint for liek two years. I realized earlier this week that something to do with Cinnamon was causing all my problems. I installed and switched to Mate, disabled all compositing, and disabled flipping in the nvidia settings. Window capture now works perfectly with every game I've tried so far.

I just did a test recording and I don't seem to be having the same issues you are. https://www.youtube.com/watch?v=xC-W5IURXVY
I've had this issue on every desktop environment that I have tried, including MATE. I'd like to stick with Cinnamon if I can, are there any workarounds that are specific to cinnamon?
 
#9
Yeah it just leads to a completely black viewport for me in OBS.



I've had this issue on every desktop environment that I have tried, including MATE. I'd like to stick with Cinnamon if I can, are there any workarounds that are specific to cinnamon?
Not sure then. If I were you I would try switching to a newer Linux kernel and/or GPU driver and see if that helps. I have no idea whether that'll do anything or not. It's just something I'd try if nothing else seemed to work.

Also, try different combinations of those window capture options. Not just the Mesa workaround
 
Last edited:
#10
I have this exact same problem on Ubuntu 18.04. (Portal 1 and Portal 2 games)
OBS logs are repeating errors:
glCopyImageSubData failed glGetError returned 0x502
device_copy_texture (GL) failed

Any help is appreciated. Reinstalling drivers did nothing.

EDIT: "Mesa workaround" and "flipping red and blue" checkboxes seems good. I'm going with that.
 
Last edited:
Top