Question / Help While recording I keep experiencing frame drops. Is a setting I have involved?

Koala_KingxX

New Member
I was recording a game and my frames started dropping about 10 minutes in and the fluctuated between 30-49 FPS for a while. My CPU was running no higher then 15% at peak. The game ran flawless on my end so any help with the settings that may be a problem would be greatly appreciated.
 

Attachments

Narcogen

Active Member
21:25:24.799: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 12614 (11.0%)

You're overloading your GPU.

https://obsproject.com/wiki/GPU-overload-issues

20:53:27.649: [x264 encoder: 'recording_h264'] preset: ultrafast
20:53:27.649: [x264 encoder: 'recording_h264'] profile: main
20:53:27.649: [x264 encoder: 'recording_h264'] settings:
20:53:27.649: rate_control: CBR
20:53:27.649: bitrate: 14000


You're also using CPU encoding for local recording on a machine that is capable of using the new NVENC encoder, and using CBR rate control, which is better suited for streaming.

I'd suggest using NVENC-new, CQP rate control and a quality setting of 15 and see how that goes. Make sure lookahead and psycho-visual tuning are off, at least to start with.
 

Koala_KingxX

New Member
21:25:24.799: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 12614 (11.0%)

You're overloading your GPU.

https://obsproject.com/wiki/GPU-overload-issues

20:53:27.649: [x264 encoder: 'recording_h264'] preset: ultrafast
20:53:27.649: [x264 encoder: 'recording_h264'] profile: main
20:53:27.649: [x264 encoder: 'recording_h264'] settings:
20:53:27.649: rate_control: CBR
20:53:27.649: bitrate: 14000


You're also using CPU encoding for local recording on a machine that is capable of using the new NVENC encoder, and using CBR rate control, which is better suited for streaming.

I'd suggest using NVENC-new, CQP rate control and a quality setting of 15 and see how that goes. Make sure lookahead and psycho-visual tuning are off, at least to start with.
Thank you so much! It appears to have cleared out my issue immediately!
 
Top