Webcam feed fails under Windows 11

CheeTah64

New Member
Hi,

I have the following issue after upgrading my PC from Windows 10 to 11:
  • OBS Studio sometimes does not recognize the webcam feed (black screen); when this happens:
    * no other program is using the webcam
    * the webcam is functioning (closing OBS and starting a different program, e.g. Camera, works)
    * OBS typically crashes when trying to close it
  • OBS only functions properly when launched right after booting the PC and logging into my Windows profile quickly
  • even when working properly, the webcam freezes after a while (anything between 10min and 3h), which forces me to restart OBS (and reboot the entire PC because of this issue)
I have experienced the following three scenario, all of which I have attached a logfile:
  1. reboot PC, login immediately, start obs; everything works; closing the program works normally
  2. reboot PC, wait ~1min, login, start obs; webcam not recognized (black screen); closing the program works normally
  3. reboot PC, wait ~3min, login, start obs; webcam not recognized (black screen); closing the program results in a crash
Note that the timings are estimated. Scenario 2 is quite hard to reproduce.

Additional information:
  • OBS version: 29.0.2 (64 bit)
    * version 28.1.2 doesn't work either
  • Specs:
    * GPU: Gigabyte GeForce RTX 3070
    * Motherboard: Asus Rog Strix B550-F Gaming
    * CPU: AMD Ryzen 9 5950X
    * RAM: G.Skill Ripjaws V F4-3200C16D-64GVK
  • Windows 11 Education (Version 22H2, OS Build 22621.1265)
    * seemed to work properly on Windows 10 (with the exact same specs)
  • Webcam: Aukey PC-LM1E 1080p
(Unsuccessful) fix attempts:
  • updating Windows
  • updating OBS
  • checking file integrity (via OBS Help)
  • assigned OBS to use the dedicated GPU:
    * Windows Settings -> Display -> Related Settings -> Graphics -> Add an app (OBS executable) -> Options -> High performance
    * restart PC
Current workaround:
  • add a scheduler task to start OBS after log on
    * Trigger: At log on (of any user)
    * Action: Start a program (C:\Program Files\obs-studio\bin\64bit\obs64.exe)
    * arguments: --minimize-to-tray
    * Start in: C:\Program Files\obs-studio\bin\64bit\
  • log onto Windows quickly (waiting 2min already screws it up)
    * changing the trigger to "At startup" doesn't work
I'm thankful for any help and please let me know if any more details are needed!
 

Attachments

  • logfile_black_screen_crashed_2023-02-16 11-50-45.txt
    8.1 KB · Views: 17
  • logfile_black_screen_terminated_normally_2023-02-16 11-41-53.txt
    8.1 KB · Views: 16
  • logfile_successful_2023-02-16 11-38-20.txt
    13 KB · Views: 14
Top