Resource icon

Video source plugin (OBS Classic only)

Pjuske2613

New Member
Mine doesn't work :( saddly

I have checked, that im downloading the right bit and putting it in the right bit folder.. but it still doesn't work...

When i open the OBS it goes fine, when i then click add, i dont see a thing that is called "video"

Please help :)
 

Jack0r

The Helping Squad
Forum Moderator
@thasmog, the only options available are the ones you can see in the properties dialog when you add a Video to OBS.
Without adding a new option to change the buffer size I dont know how you would want to change it.
Maybe it can be changed within the plugin code manually. Assuming the current 3000ms are hardcoded it could be changed. You would then just have to compile the plugin yourself after changing it.

BTW the Media Source in OBS-Studio has advanced settings to change the Audio and Video Buffer, maybe you want to check that out.
 

thasmog

New Member
@Jack0r Yes they are 1 default. But it still uses 3000ms buffer. Maybe the issue is with Monaserver.

Also maybe there is better wat than RTMP im playing with ffmpeg right now. It very complicated to me but lets see.
 

Acrotar

New Member
Hello, I tried this out and was very disappointed. First of all it's clearly not capturing the video at 1080p, I gave it a 1080p video from a file on my computer and it looks terrible like it's just capturing it lower and then stretching even tho I entered in 1920by1080. And then the looping is really bad too, there's like a 5 second delay between when the sound starts looping and when the video loops.

Also another problem is that I try to lower the video's volume b/c the video at max volume is WAY too loud, but when the playlist starts looping it returns to the original max volume and does not start at the lowered volume I set.
 
Last edited:

Annah

New Member
I've been streaming using this plugin for a few months now with no problems until just now. I streamed earlier in the evening, went for a break and now that I'm trying to start up my stream again OBS keeps crashing and complaining that the libvlc.dll file is to blame;

Code:
This crash appears to have occured in the 'd:\programs\obs\64bit\plugins\videosourceplugin\libvlc.dll' module.

**** UNHANDLED EXCEPTION: c0000005
Fault address: 00000000640E8790 (d:\programs\obs\64bit\plugins\videosourceplugin\libvlc.dll)
OBS version: Open Broadcaster Software v0.657b
Windows version: 10.0 (Build 10586)
CPU: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz

Crashing thread stack trace:
Stack            EIP              Arg0             Arg1             Arg2             Arg3             Address
000000C3974FEAB8 00000000640E8790 0000000063F6CB25 000001E1CFF6A140 000001E1D5A9ABD0 00000000640E1CA2 libvlc.dll!0x640e8790
000000C3974FEAC0 00000000640EB96B 000000C3974FE950 AE396364FF2BFF64 0000000000000000 0000000000000000 libvlc.dll!0x640eb96b
000000C3974FEB30 00000000640EBA85 0000000000000000 000001E1B33B6F00 000001E1D5A9ABD0 0000000000000000 libvlc.dll!0x640eba85
000000C3974FEB60 00007FF80D43380B 000001E1D5A9AD70 0000000000000000 000001E1D5A9AD70 0000000000000018 videosourceplugin.dll!0x7ff80d43380b
000000C3974FEC00 00007FF80D432D79 000001E1D5A9ABD0 000001E1B33B6FD0 000001E1D5A9AD70 000001E1B33E7C60 videosourceplugin.dll!0x7ff80d432d79
000000C3974FEC40 00007FF80D437734 0000000000000000 000001E1D5A9ABD0 000001E1B33B8230 000001E1B335F180 videosourceplugin.dll!0x7ff80d437734
000000C3974FEC80 00007FF6345B1B60 00007FF6346BD548 000001E1D5A8AD80 000001E1B33B8230 000001E1B33B8230 obs.exe!OBS::CreateImageSource+0xc0
000000C3974FECB0 00007FF6345D4983 000001E1D6437490 000001E1B3396670 000001E1B333EA00 000001E1B3396670 obs.exe!OBS::AddGlobalSourceToScene+0x93
000000C3974FECE0 00007FF6345D44A5 000001E100000031 0000000000000005 0000000000000077 000001E1B335F180 obs.exe!GlobalSource::UpdateSettings+0x35
000000C3974FED20 00007FF6345D46D7 0000000000000005 0000000000000004 000001E1D60A6D70 000001E1D60A6D70 obs.exe!CreateGlobalSource+0x57
000000C3974FED50 00007FF6345B1B60 000001E1B333EA00 000001E1D5A8A470 000001E1D60A6D70 000001E1D60A6D70 obs.exe!OBS::CreateImageSource+0xc0
000000C3974FED80 00007FFFF4566CCB 000001E1B3396790 000001E1B3396790 000001E1D60A6D70 000001E1D5A8A470 obsapi.dll!SceneItem::SetRender+0xab
000000C3974FEDB0 00007FFFF4567949 000001E1B335F180 000001E1D5A8A470 000001E1D60A6D70 0000000000000004 obsapi.dll!Scene::InsertImageSource+0x279
000000C3974FEE40 00007FF6345EDECF 000000C3974FF170 00000000002F05FC 00000000002E075A 0000000000001397 obs.exe!OBS::Start+0x138f
000000C3974FF070 00007FF63461D117 00000000B0E5607D 0000000000000000 0000000000000048 0000000000000001 obs.exe!OBS::OBSProc+0xeb7
000000C3974FF2C0 00007FF819E91169 000001E1B38D29F0 00007FF63461C260 00000000002E075A 0000000000000111 user32.dll!0x7ff819e91169
000000C3974FF3B0 00007FF819E908F5 0000000000000000 00007FF819E91300 0000000000001397 000001E1B38D29F0 user32.dll!0x7ff819e908f5
000000C3974FF440 00007FF819E9065B 000001E1B32FD830 0000000054010001 0000000000000001 00007FF81A115193 user32.dll!0x7ff819e9065b
000000C3974FF4A0 00007FF812F280DE 0000000000000202 000000C3974FF558 000001E1B32FD830 0000000000000000 comctl32.dll!0x7ff812f280de
000000C3974FF4E0 00007FF812EEF9F7 0000000000000000 0000000000000000 0000000000000000 0000000000000000 comctl32.dll!0x7ff812eef9f7
000000C3974FF5A0 00007FF819E91169 000001E1B38C2680 00007FF812EEF250 00000000002F05FC 000000C3972C7800 user32.dll!0x7ff819e91169
000000C3974FF690 00007FF819E90C97 000001E1B337C540 0000000000000000 0000000000000001 0000000000000000 user32.dll!0x7ff819e90c97
000000C3974FF710 00007FF819E93B8F 00000000047D06E5 000000C3974FF870 000001E1B337C540 000001E1B337C540 user32.dll!0x7ff819e93b8f
000000C3974FF770 00007FF6345DD91A 0000000000000000 00007FF6345B0000 0000000000000000 0000000000000000 obs.exe!WinMain+0xb6a
000000C3974FFD30 00007FF63465EFB0 0000000000000000 00007FF63465EE54 000000C3972C6000 0000000000000000 obs.exe!__tmainCRTStartup+0x148
000000C3974FFD70 00007FF817AA8102 00007FF817AA80E0 0000000000000000 0000000000000000 0000000000000000 kernel32.dll!0x7ff817aa8102
000000C3974FFDA0 00007FF81A15C574 0000000000000000 0000000000000000 0000000000000000 0000000000000000 ntdll.dll!0x7ff81a15c574
As far as I'm aware, nothing has changed on my computer in the hours that I took a break, nor had anything changed with my OBS install/plugins. I've tried removing the Video Source Plugin and then my OBS seems to work fine, only it doesn't show the videos I've used (naturally). I've tried downloading the latest version of the plugin and reinstalled using that, but still no luck.
Any help with this would be greatly appreciated.
 

CrisuKomie

New Member
How do I get this plugin to show up in the latest version of OBS Studio? Version 0.13.2. I've tried both 64 bit and 32 bit and neither works. Anyone else having this issue?

Thanks!
 

Jack0r

The Helping Squad
Forum Moderator
In OBS-Studio you can use the Media Source, it comes right with OBS-Studio. It allows you to add video files to your scene.

This Thread and the Video Source Plugin are for the classic OBS (v0.657b) though. Plugins have to be re-written to work between OBS and OBS-Studio. So you cannot use this Video Source Plugin in OBS-Studio.
 

thomasvt

New Member
Is it possible to control the speed of video playback. eg: playback at half speed (slow motion)?

I need to capture the last 2-3 seconds and play that back in slow motion. Running into 2 issues...
1. Cannot capture buffer less than 5 secs.Though I set the buffer length to 2-3 secs, it captures the last 5 secs.
2. Unable to use the Video Source plugin to play video at slower speeds

It would also be nice to have an option on clip completion,
1. To switch to another scene OR show last frame (which is pause function - as some users have requested that)
 
Last edited:

Craft

New Member
can you PLEASE add chroma key or has someone figured out a cool way to yet or made a new one?

also please add a functional way to load a video you created without a URL from desktop D: mp3 & or mov. files <3
 

Pete E

New Member
I installed your software and plug in from YOUR website and it is not working properly.I have tried both 32 bit and 64 bit versions. I am not the only one seeing this issue. Please address.
 

Attachments

Top