Question / Help Video not looking great (mac)

SkunkyBass

New Member
Hello. I dont need to stream just record. I used to record minecraft on a 2012 macbook pro and it looked fine. I'm now trying the same game on a 2019 macbook pro and my videos do not look as crisp as I'd like and quicktime has trouble playing them afterwards. I just unchecked enforce streaming rules or whatever and that helped a lot but still not where I want to be clarity wise. Also, can someone explain what my base resolution should be. My computer screen has a weird resolution but should I just put my base at 1080? In minecraft my resolution is full screen but I can change it. My computer screen resolution is 2880 x 1800. When I made minecraft that resolution it was really stretced out so I went back. Ive attached a log file and here is the link to it. https://obsproject.com/logs/GDjFtUegxP9i78CE
 

Attachments

  • 2019-12-28 01-11-46.txt
    5.5 KB · Views: 74

Narcogen

Active Member
You're recording 1080p60 at 4000kbps. That'd be almost guaranteed to look bad.

00:58:33.445: [VideoToolbox recording_h264: 'h264']: session created with hardware encoding
00:58:33.445: [VideoToolbox recording_h264: 'h264']: settings:
00:58:33.445: vt_encoder_id com.apple.videotoolbox.videoencoder.h264.gva
00:58:33.445: bitrate: 4000 (kbps)
00:58:33.445: fps_num: 60
00:58:33.445: fps_den: 1
00:58:33.445: width: 1920
00:58:33.445: height: 1080


Try starting with simple output mode, indistinguishable quality, large file size.
 

SkunkyBass

New Member
Thanks, I swear I put the kbps at 40000kbps not 4000kbps. Maybe I changed the streaming one and thought it was video.
 

SkunkyBass

New Member
You're recording 1080p60 at 4000kbps. That'd be almost guaranteed to look bad.

00:58:33.445: [VideoToolbox recording_h264: 'h264']: session created with hardware encoding
00:58:33.445: [VideoToolbox recording_h264: 'h264']: settings:
00:58:33.445: vt_encoder_id com.apple.videotoolbox.videoencoder.h264.gva
00:58:33.445: bitrate: 4000 (kbps)
00:58:33.445: fps_num: 60
00:58:33.445: fps_den: 1
00:58:33.445: width: 1920
00:58:33.445: height: 1080


Try starting with simple output mode, indistinguishable quality, large file size.
Thanks Simple output worked great!!! Now I just need to learn how to have my videos come out at 1920x1080 without black bars on the side and without losing some of the picture from resizing the window to fit the preview.
 

Narcogen

Active Member
Since your display's native aspect ratio is not 16:9 and all streaming platforms use this ratio, a translation has to occur somewhere in order to make this happen. It will either happen on the audience's end, or on yours. Either you have black bars and the audience doesn't, or the audience has black bars and you don't, or you view a stretched/squeezed image and you undo that in OBS so the audience doesn't see it, or you view a normal image and the audience sees it stretched or squeezed.
 

SkunkyBass

New Member
Since your display's native aspect ratio is not 16:9 and all streaming platforms use this ratio, a translation has to occur somewhere in order to make this happen. It will either happen on the audience's end, or on yours. Either you have black bars and the audience doesn't, or the audience has black bars and you don't, or you view a stretched/squeezed image and you undo that in OBS so the audience doesn't see it, or you view a normal image and the audience sees it stretched or squeezed.
Does this apply to recording too? Im not streaming
 

Narcogen

Active Member
I believe on YouTube now it is possible, at least when watching the Original file quality, to get their player to show a video's native aspect ratio even if it is not 16:9. I have not had cause to test this myself.

Of course that's only when watching in an embedded player. If a viewer who has a 16:9 display (which is the vast majority of them) plays such a video at full screen, they're either going to get letterboxed or pillarboxed, depending.
 

SkunkyBass

New Member
I believe on YouTube now it is possible, at least when watching the Original file quality, to get their player to show a video's native aspect ratio even if it is not 16:9. I have not had cause to test this myself.

Of course that's only when watching in an embedded player. If a viewer who has a 16:9 display (which is the vast majority of them) plays such a video at full screen, they're either going to get letterboxed or pillarboxed, depending.

Do you know how I get rid of the black bars on the side? Its showing up in the video
 

Narcogen

Active Member
To get rid of the black bars in a YouTube video (bars on the side) you need to configure your computer and capture app, as well as canvas ratio, to use a 16:9 aspect ratio. This will put black bars on screen while you play (on the top and bottom, if your screen is 16:10). Or else it will stretch the image on your screen, and you'll have to use the "stretch to fill" option in OBS (right click the source in the preview window) to correct for the stretch.
 

SkunkyBass

New Member
To get rid of the black bars in a YouTube video (bars on the side) you need to configure your computer and capture app, as well as canvas ratio, to use a 16:9 aspect ratio. This will put black bars on screen while you play (on the top and bottom, if your screen is 16:10). Or else it will stretch the image on your screen, and you'll have to use the "stretch to fill" option in OBS (right click the source in the preview window) to correct for the stretch.

thanks, I found an app for mac that changes the aspect ratio of my computer to 16:9 Makes my screen way smaller length wise but I guess this will have to do. It works
 
Top