The dreaded "If you are using NVENC or AMD encoders, make sure your video drivers are up to date", but only for streaming?

ssolveig

New Member
Hi there, I've been using OBS just fine to live stream on the side some games for friends for a long while now, however for some reason since Thursday I've been unable to livestream at all. I've ***no*** clue why, I've tried to change the video encoder to every single other encoder available to me (just to get the same damn message), and I've reinstalled the most recent drivers update for my graphics card *twice* now to no avail. I am capable of recording just fine, but streaming is not working at all.

I've got no clue what to do at this point and I'm getting a little sad, as I was getting really excited to stream the Endless Dungeon closed beta to some friends of mine but it seems like that'll be out of the cards.

Specs:

GPU - NVIDIA GTX 1060 3gb
CPU - AMD Ryzen 7 5700X 8 core

Let me know if there's anything else you need!
 

Attachments

  • 2023-09-08 16-51-12.txt
    16.5 KB · Views: 36
  • Screenshot 2023-09-08 170711.png
    Screenshot 2023-09-08 170711.png
    55.9 KB · Views: 112
  • Screenshot 2023-09-08 170756.png
    Screenshot 2023-09-08 170756.png
    8.4 KB · Views: 103
  • Screenshot 2023-09-08 170803.png
    Screenshot 2023-09-08 170803.png
    50.1 KB · Views: 91
  • Screenshot 2023-09-08 170829.png
    Screenshot 2023-09-08 170829.png
    268.8 KB · Views: 93
  • Screenshot 2023-09-08 170851.png
    Screenshot 2023-09-08 170851.png
    257.8 KB · Views: 112

qhobbes

Active Member
1. To ensure that OBS Studio has the hardware resources it needs for realtime streaming and recording, we recommend disabling the "Game DVR Background Recording" feature via these instructions.
2. Re-install iTunes.
3. At least one of your audio devices has a sample rate that doesn't match the rest. This can result in audio drift over time or sound distortion. Check your audio devices in Windows settings (both Playback and Recording) and ensure the Default Format (under Advanced) is consistent. 48000 Hz is recommended.
OBS Sample Rate: 44100 Hz
CABLE-B Output (VB-Audio Cable B): 44100 Hz
VoiceMeeter Input (VB-Audio VoiceMeeter VAIO): 48000 Hz
Headset Microphone (CORSAIR VOID ELITE USB Gaming Headset): 48000 Hz
4. Run OBS as Admin. Right click on the OBS shortcut, properties, advanced, check box, ok, apply, ok.
5. Display and Game Capture Sources interfere with each other. Never put them in the same scene (streaming and barebones).
 

ssolveig

New Member
1. To ensure that OBS Studio has the hardware resources it needs for realtime streaming and recording, we recommend disabling the "Game DVR Background Recording" feature via these instructions.
2. Re-install iTunes.
3. At least one of your audio devices has a sample rate that doesn't match the rest. This can result in audio drift over time or sound distortion. Check your audio devices in Windows settings (both Playback and Recording) and ensure the Default Format (under Advanced) is consistent. 48000 Hz is recommended.
OBS Sample Rate: 44100 Hz
CABLE-B Output (VB-Audio Cable B): 44100 Hz
VoiceMeeter Input (VB-Audio VoiceMeeter VAIO): 48000 Hz
Headset Microphone (CORSAIR VOID ELITE USB Gaming Headset): 48000 Hz
4. Run OBS as Admin. Right click on the OBS shortcut, properties, advanced, check box, ok, apply, ok.
5. Display and Game Capture Sources interfere with each other. Never put them in the same scene (streaming and barebones).

1. I actually turned off Game DVR Background Recording a little bit ago, but for some reason it's still showing up as a process for OBS. I'll turn it on and off again just to be sure.
2. Is iTunes a dependency? I actually had no idea that might cause a problem when I uninstalled it; I wasn't getting much use out of it since I got an iMac and figured that it'd better to work music onto my phone with. It's reinstalling now!
3. Audio sample rate should now be consistent.

Let me restart my system real quick and I'll do a quick test and give an update! Thank you!
 

ssolveig

New Member
1. To ensure that OBS Studio has the hardware resources it needs for realtime streaming and recording, we recommend disabling the "Game DVR Background Recording" feature via these instructions.
2. Re-install iTunes.
3. At least one of your audio devices has a sample rate that doesn't match the rest. This can result in audio drift over time or sound distortion. Check your audio devices in Windows settings (both Playback and Recording) and ensure the Default Format (under Advanced) is consistent. 48000 Hz is recommended.
OBS Sample Rate: 44100 Hz
CABLE-B Output (VB-Audio Cable B): 44100 Hz
VoiceMeeter Input (VB-Audio VoiceMeeter VAIO): 48000 Hz
Headset Microphone (CORSAIR VOID ELITE USB Gaming Headset): 48000 Hz
4. Run OBS as Admin. Right click on the OBS shortcut, properties, advanced, check box, ok, apply, ok.
5. Display and Game Capture Sources interfere with each other. Never put them in the same scene (streaming and barebones).
Unfortunately, I got the same exact error yet again-- I followed all of the steps you mentioned, is there something I'm potentially missing?
 

Attachments

  • 2023-09-08 23-05-43.txt
    10.2 KB · Views: 20

koala

Active Member
OBS is trying to use the coreaudio audio encoder installed by Itunes. You seem to have removed Itunes, so OBS isn't able to find this encoder any more. I don't know if you can switch the audio encoder in Settings→Output→Streaming and Settings→Output→Streaming away from coreaudio, (default should be "AAC (Default)" resp. "FFmpeg AAC" in advanced mode), but if there is something different, switch to the defaults I mentioned. In case this doesn't change anything, create and use a new profile in OBS. This will forget the coreaudio encoder in the new profile.
 

ssolveig

New Member
OBS is trying to use the coreaudio audio encoder installed by Itunes. You seem to have removed Itunes, so OBS isn't able to find this encoder any more. I don't know if you can switch the audio encoder in Settings→Output→Streaming and Settings→Output→Streaming away from coreaudio, (default should be "AAC (Default)" resp. "FFmpeg AAC" in advanced mode), but if there is something different, switch to the defaults I mentioned. In case this doesn't change anything, create and use a new profile in OBS. This will forget the coreaudio encoder in the new profile.
That fixed it!!! You were entirely correct. I had no idea when it started to use the coreaudio encoder, I can't remember switching to that at all. But I appreciate the help!! :)
 
Top