Resource icon

TeamSpeak 3 Plugin

mihawk90

New Member
Heya, found this plugin a few days ago and it's working quite well so far.

One little issue I'm having is when being on multiple TeamSpeak servers at once. It appears to only change the name on the currently active Tab (or the first one, which is the active one for me most of the time).
I'm usually on one and the same TeamSpeak server, but sometimes I'm in a second as well just listening/idling or waiting if someone has something to discuss with me. I would like for both (or rather all, in case someone is using even more servers) to be set to the new name, maybe even make it selectable but I don't know if the TS3 API allows that.
 
Heya, found this plugin a few days ago and it's working quite well so far.

One little issue I'm having is when being on multiple TeamSpeak servers at once. It appears to only change the name on the currently active Tab (or the first one, which is the active one for me most of the time).
I'm usually on one and the same TeamSpeak server, but sometimes I'm in a second as well just listening/idling or waiting if someone has something to discuss with me. I would like for both (or rather all, in case someone is using even more servers) to be set to the new name, maybe even make it selectable but I don't know if the TS3 API allows that.
Short answer: Yes. I had a nose around and did some test and it's possible.

Long answer is still yes but made me realise that multiple servers have a problem if a user accidentally closes the first server tab they connected to. Doing this will switch the server that the plugin is grabbing names for the overlay for. This can't be fixed unless all the other servers' tabs are closed and reopened once the original server is reopened. Basically, don't close the first server you connect to's tab and make sure the first server you connect to is the one you want the overlay to display. Most of this isn't really relevant to the question but thought I'd write it anyway.

Just a heads up, this will be a "one or all" option. You can't select specific servers to do this to (well you can but it looks hard or impossible to do in a way that makes sense), it will work on the server in the first tab or all of them.
 
adocilesloth updated TeamSpeak 3 Plugin with a new update entry:

@mihawk90

Multi Server Prefix/Suffix and Mute/Deafen Support plus config crash fixes.

At the request of mihawk90, added the ability to add the prefix and suffix across all TS3 servers the client is connected to. You can now choose to add the prefix/suffix on the active server or all server but not specific servers.

Added the ability to mute and deafen TS3 across all TS3 servers the client is connected to. You can now choose to mute/deafen on the active server or all server but not specific servers.

The TeamSpeak 3 Plugin Config has been updated to reflect this....
Read the rest of this update entry...

Also, turns out what I said in the "Long answer" in the post above is wrong. The overlay grabs names from which ever server is in focus at the time.
 
Any chanse this plugin will be made for "OBS MultiPlatform" version ?
Eventually. I'm not 100% on where the MP API is (through not really giving it a good look). If it had what a brief scan makes me think it has then it is something I will try to do. Timing at the moment is a bit of an issue with RL stuff being a bit hectic atm.

It is planned. When I can start work on it is not known.
 

phonz

New Member
I think the 64bit plugin needs to be updated for Windows 10.
I attempted to run 64bit OBS (v0.653b) with the 64bit Teamspeak3 Extended plugin (https://dl.dropboxusercontent.com/u/50203063/TS3Plugin64_Extended.zip) and OBS reports that the plugin is designed for 32bit OBS.
I also tried using that same plugin on the 32bit OBS and it said it was designed for 64bit OBS.
I tried the 32bit build plugin with 32bit OBS and that actually worked.

I run OBS as admin in all cases.
 
I think the 64bit plugin needs to be updated for Windows 10.
I attempted to run 64bit OBS (v0.653b) with the 64bit Teamspeak3 Extended plugin (https://dl.dropboxusercontent.com/u/50203063/TS3Plugin64_Extended.zip) and OBS reports that the plugin is designed for 32bit OBS.
I also tried using that same plugin on the 32bit OBS and it said it was designed for 64bit OBS.
I tried the 32bit build plugin with 32bit OBS and that actually worked.

I run OBS as admin in all cases.
Weird, I'd expected it to just work. I don't have a Win 10 system up to test with so I'm not sure what's going on.
If you've not already, try re-downloading the 64bit version to see if that fixes it. Else, you'll have to wait until I get a Win 10 system up so I can test.
 

JohnnyGrey

New Member
I'm in the same boat. 64bit plugin inside the 64bit installation doesn't get recognized. I, however, get no warning message. It jus doesn't see it. 32 bit inside the 32 bit installation works fine. What's the benefit of running OBS as 64 bit?

EDIT: Is there anthing those of us with Win10 installations can do to help solve this? I personally don't need to run the 64 bit version, as I am using my GPU's encoder rather than x264, but would like to see it get solved regardless!
 
Last edited:
@phonz @JohnnyGrey
I've recompiled the 64bit plugin. If you could grab the newer version from the OP or here and see if it works it would be greatly appreciated.

Make sure the plugin is in:
Program Files/OBS/plugins
or
Program Files (x86)/OBS/64bit/plugins

depending how old your installation is.
 
Last edited:
@phonz @JohnnyGrey
Got Win 10 set up and I've recompiled the 64bit plugin in Windows 10. It shows up and works in my OBS so hopefully it fixes the issues you are having. Grab the lates plugin from the post above or the OP.
 

phonz

New Member
Unfortunately I'm still receiving the dialogue box saying the plugin was designed for 32bit.

(08.09.2015)
The OBS update that I got today seems to have fixed it.
Joy.
 
Last edited:

Zoeff

New Member
Any chanse this plugin will be made for "OBS MultiPlatform" version ?
+1 on this, because the MP version is supposed to replace the old one from what I can tell. So I'd rather switch now rather than later so I can get used to this newer interface.

Pretty please, adocilesloth? :D
 
+1 on this, because the MP version is supposed to replace the old one from what I can tell. So I'd rather switch now rather than later so I can get used to this newer interface.

Pretty please, adocilesloth? :D
The below still sands. I haven't forgotten (and won't forget), just have other stuff to do.

Eventually. I'm not 100% on where the MP API is (through not really giving it a good look). If it had what a brief scan makes me think it has then it is something I will try to do. Timing at the moment is a bit of an issue with RL stuff being a bit hectic atm.

It is planned. When I can start work on it is not known.
 
Very nice Plugin ... just found it and simply love it!

Is there a way to change "oUsername" to "o Username"? That means to add a little space between the speaking Symbol and the username!

Greetings ... :D
 
Top