Resource icon

TeamSpeak 3 Plugin

Jeffrey Dolan

New Member
I am still having the problem with the inconsistencies, however, since it always adds the prefix, I can work around it. Most of the time when I stop streaming, I close TS3 anyways. (Seems like there's a 64 bit version that I didn't notice before, so when I get back home I can try that).
 
Yes, still meaning to find time to find the issue and fix it (I haven't forgotten). I have a hunch of what it could be but finding time to test is being a pain. Hopefully closer to Christmas I'll get some time to sit down and work this through.
 

Wolfbane

Member
Awesome plugin. Nice work.

Any chanse to get a few more options ?

Option in plugin to remove me from the people displayed. So I can have the overlay always running in OBS. But if Im in TS myself then its not an irritating nametag on the screen.

First auto fade away users after XX seconds. So that names in the channel who have not spoken they will no longer be displayed after XX second whatever one set its to. Also an option for how fast that will fade away.
 
@Jeffrey Dolan @Wolf68k
Ok, I managed to grab a few mins to work on the prefix not being removed. I'm not sure what's causing it and I still can't reproduce the problem on my system. My current theory is that some of the messages aren't being received by OBS properly. I've set up a test plugin for 32 bit OBS. If you could download it from here (link to .dll) and use it. Can you then post a log of a stream when your name didn't change back. If I'm right, the log should now show some clues as to what's going on.

@Wolfbane
They are possible to do. I have no idea if I'll get time to add them in. If I do, it won't be for a while.
 

Nananea

New Member
For some reason the overlay only shows 10 people at one time. I'm using custom text extents but I have them extended MUCH further down the screen than what 10 people fills up. Here's a pic (didn't want to mess up the posts): http://puu.sh/dFVXw/17190fa488.png

Any way this could be fixed by me or is it an issue with the plugin? Thanks!
 
For some reason the overlay only shows 10 people at one time. I'm using custom text extents but I have them extended MUCH further down the screen than what 10 people fills up. Here's a pic (didn't want to mess up the posts): http://puu.sh/dFVXw/17190fa488.png

Any way this could be fixed by me or is it an issue with the plugin? Thanks!

Not an issue with the plugin in as much as it was designed to only show 10 people so there is nothing you can do. I never thought someone would be in a channel with more than 10 people but I have shown before that my assumptions are often bad. I can go away and have a look and make it show more but it may not be until after Christmas. Just for reference, what's the max number of people you have in your channel when you stream?
 

Nananea

New Member
Thanks for the quick response, @adocilesloth ! After Christmas is totally fine, I didn't even figure you'd respond until then.

This is a public community channel for our game. I'd like to show at least 25 if not more.

Thanks for your great work!
 
adocilesloth updated TeamSpeak 3 Plugin with a new update entry:

@Nananea and @Wolfbane may like some of the latest update

Overlay Tweaks

At the request of WolfBane the option to remove yourself from the overlay has been added. It is a check box in the Overlay Config (right click on the Overlay Source and click Properties)

At the request of Nananea the option to change the number of people visible has been added. It has a default value of 10 with a maximum of 128 and minimum of 1. If anyone needs more that 128 people visible in their stream, I feel sorry for your sanity. It's added as a box in the Overlay Config.

The new...

Read the rest of this update entry...
 

sneaky4oe

Member
Is there a way to make "speaking" symbol appear at right side? Sometimes I prefer to align strings to right edge of frame, but it isn't looking too pleasant.
8110f2661366.png
 
@sneaky4oe Yes. I'll see what I can do

@LtRoyalShrimp Can you be more specific about what's not working? Also, if possible can you post a log incase it's throwing in errors.

Made sure TS3 server is running query plugin.

I checked the OBS logs, and I see this error:

Warning -- Overlay: Started
Warning -- Overlay: whoami Receive Failure

And that whoami failure goes on about 100 or so times.
 
Last edited:
Warning -- Overlay: Started
Warning -- Overlay: whoami Receive Failure

And that whoami failure goes on about 100 or so times.

The first warning is just saying everything has started correctly. The second one is what is causing the problem and it repeating is to be expected.

Are you also using the plugin to add a prefix/suffix when streaming? If so, does that work properly?
 
The first warning is just saying everything has started correctly. The second one is what is causing the problem and it repeating is to be expected.

Are you also using the plugin to add a prefix/suffix when streaming? If so, does that work properly?
It is not. my username in teamspeak is not updated when I start streaming.
 
Ok, so now im getting the errors:

Warning -- Welcome to
Warning -- error id=0

Any tips?
They are just some debug stuff for the bug which caused (causes?) people's names not to switch back. You don't need to worry about them. Although, they do sort of explain why your name isn't changing.

After a bit of testing today, it looks like the connection is being dropped by something. Not sure if it's the TS3 client or my plugin (but I'm assuming the latter). The drop results in the whoami receive failure. Now I just need to find a solution.
 
They are just some debug stuff for the bug which caused (causes?) people's names not to switch back. You don't need to worry about them. Although, they do sort of explain why your name isn't changing.

After a bit of testing today, it looks like the connection is being dropped by something. Not sure if it's the TS3 client or my plugin (but I'm assuming the latter). The drop results in the whoami receive failure. Now I just need to find a solution.
Yep. Tried it on my local gaming PC. My nickname was switched to whoami.

The suffix was only applied every second time I started streaming, and removed every second time I stopped streaming.

The plugin on my second PC is still not working. Let me know if I can help test anything.
 

Wolfbane

Member
Thx for the option to remove ones own name. Sweet.

So, just need the fade in/fade out feature then ;O)

Also there is 3 other things on my mind, reguarding displaying who is talking.
Next to the name there is a circle that turnes into a full circle when someone is talking.

1* Is it possible to maybe have some other kind of symbol for indication who is talking ?
Nice to maybe have an => Arrow or something els. But really no big deal.

2* Is it possible to remove so there is no symbol at all
The reason for this suggestion is if the Fade In/Fade out names, then it is not needed for the symbol next to names.

3* Is it possible to instead of symbol have it display a differnt color of the person speaking.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Besides that, there is also a few user friendly features.
Inside the properties/settgings. In the top it saz "TeamSPeak 3 Overlay" maybe add version ? " v 1.02" or something.

At all the differnt "Colour" settings have a small box that indicates the colour selected ?

And also if it is possible "check for updates" button or something.

All of these suggestions are just personal preferenses, its your plugin, and I already love it. And it works really nice as it as now. And I have no program skills so I dont have a clue how hard these suggestions are to implement. But if I could prioritize I would personally love the fade in/fade out and the name change colour of the speaker.

Keep up the awesome plugin work at your own pace.
Once again, thx for an awesome plugin.
 
Top