Source Record

Source Record 0.3.4

Hello Exeldro!

Did intensive testing with your plugin yesterday night.

For me NVIDIA NVENC H.264/AVC (via FFmpeg) and H.265/HEVC (via FFmpeg) worked OK (incl. Audio) but crashed OBS from time to time in combination with Replay Source use. Had also to re-arrange my Audio settings to get what is needed in this recording

What I didnt figure out was, how the Replay Buffer setting in Source Record works in this context. Can you please give some advice.

Thanks
Andreas
 

Bigg_A

New Member
For some reason whenever I have a filter from this plugin setup on any source and close OBS then relaunch I can't seem to get the OBS program window to display. I know OBS is running because I can see it in the task manager, I just can't get the actual program to display. The only thing that works is ending the OBS task and uninstalling this plugin. Then launching OBS and deleting the filter. After that everything shows up properly. Even just having the plugin installed seems fine. It's just after creating an actual filter and closing OBS that I can't get the program window to display on a next launch. And I don't think the program is crashing because I'm not getting any new crash log files.
 

Andre Caleffi

New Member
If I have source recorder added in a source and change my scene collection, OBS crash.
 

Attachments

  • 2021-05-19 09-01-25.txt
    22.5 KB · Views: 38
  • 2021-05-19 09-01-53.txt
    22.4 KB · Views: 31
  • 2021-05-19 09-02-10.txt
    22.4 KB · Views: 30
  • 2021-05-19 09-02-30.txt
    33.3 KB · Views: 34

ASchneider

Member
@JuicyLemon at the moment it only records track 1 of the selected source, why would you need more tracks for a single source?
Hello @Exeldro!

Sorry to bother you but I'm unable to record audio from the recorded source. I've added the filter to a game capture (no audio) and set the alternative audio to my virtual audio device that is set to receive the game's audio (output source from that audio device). This audio device is set to only output to track 3 from the main output (track 1 is a downmix from my voicemeeter). Do you think this is why no audio is recorded to that source?

Also, I've noticed that the game source output vide file only has footage from when the source was active, showing on its scene. Is it possible to start capturing this source all the time, when I start recording/streaming (global) from the startup scene? This would help a lot to sync footage in the NLE from two different source records, like a game and webcam separate recordings.

Thanks!
 

Lyfesaver

New Member
Hello @Exeldro!

Sorry to bother you but I'm unable to record audio from the recorded source. I've added the filter to a game capture (no audio) and set the alternative audio to my virtual audio device that is set to receive the game's audio (output source from that audio device). This audio device is set to only output to track 3 from the main output (track 1 is a downmix from my voicemeeter). Do you think this is why no audio is recorded to that source?

Also, I've noticed that the game source output vide file only has footage from when the source was active, showing on its scene. Is it possible to start capturing this source all the time, when I start recording/streaming (global) from the startup scene? This would help a lot to sync footage in the NLE from two different source records, like a game and webcam separate recordings.

Thanks!

Have you used the other audio source option?

1621433074577.png
 

Lyfesaver

New Member
Hello,

I'm using this option, that's what I've explained earlier, this option does not work for me. I'm choosing from a specific audio device source, the one that I set only games to output audio to.

View attachment 71312

Thanks.
Weird because that is working for me but the audio is crackling.

Trying to capture Track 1 (basically not using that option) and setting my game audio to track 1 does not work for me at all at the moment.
 

kellemar

New Member
Hi, this is definitely a wonderful plugin to have. Unfortunately, it doesn't seem to record audio in my case :(

Current hardware: MacBook Pro M1.
OBS Version: 27rc4

I'm trying to record both video and audio from a browser source that links to an OBS.Ninja stream. The video was recorded fine, but no audio was recorded. I've tried using VT Hardware encoder, and software, and switched between mp4 and mov. No audio there.

I've attached the log.txt.
 

Attachments

  • 2021-05-20 23-44-04.txt
    25.9 KB · Views: 37

Andre Caleffi

New Member
OBS is crashing when I close OBS or change scene colection.
I test using V26.1.1 And V27r5
 

Attachments

  • Crash Report.txt
    150 KB · Views: 33
  • Crash Report2.txt
    150 KB · Views: 29

Andre Caleffi

New Member
Other problem here, if I use Software encoder record all my source (i tested using 5 diferent sources)
If I use NVENC or NVIDIA NVENC h.264 (new), record only 1 or 2 sources.
 

Exeldro

Active Member
@Andre Caleffi the crashes are in audio monitoring, I will test with that this weekend. Nvenc has limited number of encoding session in the default drivers. There are patched drivers that should allow you more encoding sessions.
 

ASchneider

Member
Hello @Exeldro!

I was wondering: testing with a 1080p source, resized inside the canvas to 720p, I've noticed that the source record file outputs to its original resolution (1080p). Is it possible to the source record filter outputs the canvas size resolution? This would be nice since most VR games I play are about 4K of resolutions but my stream is 1080p60.

Thanks!
 

norihiro

Member
It's great plugin. I was thinking the same idea but not yet implemented.
How about adding an option to encode with ffvhuff? Ffvhuff consumes just a little less CPU resource than x264 and no degradation (but consumes a lot of storage).
 
Top