Source Record

Source Record 0.3.4

retsofaj

New Member

Thus far my testing (on an iMac Pro with OBS 26.1.2) has worked flawlessly with Software, Apple VT H264 Software, and Apple VT H264 Hardware encoders. The new Record Modes also all seem to be working.

Oh - for what it's worth - having once scene in which all sources are present and using references in all other scenes works well for setting the Record Filter on the master and having everything "just work" as one switches scenes. There's probably some additional CPU load to this approach so YMMV.

Given the amount of encoding going on there's definitely a CPU hit - and the Apple VT H264 Hardware encoder isn't all that great - but it's a small price to pay for the feature. I'm going to explore settings to figure out how to reduce the CPU load without losing too much video quality.

I took a quick look at the source code and it seems that some of the infrastructure to record audio is present (yay!) but I'm definitely not qualified to submit a pull request.

Thanks again @Exeldro!
 

ASchneider

Member
Hi Schneider, did you by any chance install the 2019 redistributable and restart your pc?
I did that and now I can record with x264, Quick Sync 264, NVENC H264, NVENC H264 (via ffmpeg), all can record successfully. However, it is a performance hog, encoding lags hit 59%. Will share the screenshots later. My OBS Crashes when i attempt to close it, i use RC 27.0.0.4 so that could be one of the issues.
Hello! Thanks for advice but it did not worked for me... I've installed this package and the latest plugin version, nothing works. OBS crashes the moment I start recording globally, trigger just one source to record itself. Thanks.
 

RichieTee

Member
Hello! Thanks for advice but it did not worked for me... I've installed this package and the latest plugin version, nothing works. OBS crashes the moment I start recording globally, trigger just one source to record itself. Thanks.

Hi here's mine, the tests I did and how it all comes together, you can notice the performance hits.

Test PC: Asus ROG
Intel i7-6700HQ, 16gb RAM, 64-bits, running windows 10 20H2.

Graphics Card: Nvidia GeForce GTX 950M
Game Ready Driver Version: 466.27
 

Attachments

  • Source Record using NVIDIA NVENC H.264 via FFMPEG (RECORDED FILE).png
    Source Record using NVIDIA NVENC H.264 via FFMPEG (RECORDED FILE).png
    781.2 KB · Views: 95
  • Source Record using NVIDIA NVENC H.264 via FFMPEG.png
    Source Record using NVIDIA NVENC H.264 via FFMPEG.png
    934.3 KB · Views: 89
  • Source Record using NVIDIA NVENC H.264.png
    Source Record using NVIDIA NVENC H.264.png
    896.1 KB · Views: 85

AndersM

New Member
Fantastic to see ISO recording for OBS, great job!

A bit of a longshot, but have you looked into recording in the NDI codec for NDI sources? This would allow for "lossless" recording without any extra cpu or gpu usage. Newtek Studio Monitor, vmix, tricasters ect use this recording codec for ndi sources.
I assume ndi recording would have to be implemented through the ndi plugin...
 

ASchneider

Member
Hello again! Just tested again with the latest version, all types of video encoding and a bunch of settings, nothing seems to work here. Sometimes ir records and other times it just crashes OBS. I'm running a Ryzen 9 3900x with a 2080ti. Thanks.
 

iSvein

Member
I add two.
One is a recording of a video source, no audio selected in the box.
The other one is a recording from an Elgato capture card source, added an picture on how I set the audio.
 

Attachments

  • Recording_elgato_2021-05-17 10-48-50.txt
    47.7 KB · Views: 34
  • Recording_source_that_is_a_video_2021-05-17 10-44-42.txt
    47.6 KB · Views: 31
  • testCapture.PNG
    testCapture.PNG
    3.3 KB · Views: 43

Exeldro

Active Member
The plugin at the moment records only track 1 can you check if track 1 is enabled in the advanced audio properties for the audio sources you are trying to record? Is the source not muted or low volume in the OBS audio mixer?
 

iSvein

Member
The plugin at the moment records only track 1 can you check if track 1 is enabled in the advanced audio properties for the audio sources you are trying to record? Is the source not muted or low volume in the OBS audio mixer?
Yes, all the tracks are checked on track1 and was on 100% when I tested recording :)
When I use the default recording mode in OBS audio gets recorded fine, so I dont think it has anything to do with my audio setup that uses VoiceMeeter and not just default settings in the audio settings, but I can test that too.


Edit: Downloaded and installed a clean, portable mode, version of obs, with only this plugin installed, no change to any settings in the "Settings", same happens.
 

Attachments

  • Clean_install_test2021-05-17 11-28-08.txt
    16.1 KB · Views: 34
Last edited:

ASchneider

Member
Hello everyone!

Just to let you know that after updating my OBS to the latest beta RC5, source record now works just fine :)

Thanks!
 

JuicyLemon

New Member
@JuicyLemon at the moment it only records track 1 of the selected source, why would you need more tracks for a single source?
well if i was recording regularly then i have obs recording my mic, game, and discord separately. Atm though, it doesnt record ANY audio even if i set a specific source for it to record.

Edit: Im recording 2 different sources atm and i want one to record my mic and the other for my game
 

iSvein

Member
well if i was recording regularly then i have obs recording my mic, game, and discord separately. Atm though, it doesnt record ANY audio even if i set a specific source for it to record.

Edit: Im recording 2 different sources atm and i want one to record my mic and the other for my game
So you have the same problem as me.
 
Top