[SOLVED | Laptop Issue | Streaming to Twitch] Dropped frames as soon as a game is turned on.


New Member
Greeting Windows Support Community of OBS,

I'm currently having issues while streaming to Twitch at the moment and I tried using the discord but I thought the forum might be a better place at the same time, the results/solutions(if we ever get one) would be documented for someone else. So currently, the stream is working fine when I have no games up, I originally had the stream set to 5k, and it's running smoothly by itself but for the sake of testing, I lowered it down to 1k bitrate. But the moment I open up any game on steam, multiplayer or not, the example I'm using for this test is Half-Life and Team Fortress 2. The upload rate tanks from 1k kb/s to 0-200 kb/s ... and the drop frames goes to ~60%.

Some changes I've did were the following:
  • Ran OBS in Administrator
  • Used Direct Wiring
  • Lower the bitrate (5000 kb/s => 1000 kb/s).
  • Change the location of the server to several based on TwitchTest results.
  • Tried all the encoders (x264, QSV, NVENC).
  • Change fps to 30 fps.
  • Changed the screen resolution of the game and set it to windowed mode (1080 x 720) and lower to the absolute lowest of the low... I don't care if I have to stream games like it's a PS1 game.
  • Disable Browser Source Hardware Acceleration.
  • Deleted my McAfee security and disable window's firewall. (monkaS, I didn't need McAfee anyway FeelsOkayMan).
  • Followed the steps from the "Laptop GPU Selection Windows 10" thread.
  • Enabling "Dynamically change bitrate to manage congestion (beta).
  • Streamed on YouTube (HYPERDANSGAME).
  • Set OBS to use the Nvidia GPU in the Nvidia Control Panel itself.
  • Changed OBS compatibility mode to Windows 8.
  • Set OBS as a high priority in the task manager.
  • Deleted my scenes... (I had 25 scenes label top, bottom, right and left of a pepeJAM for the intro).

Resources from me:
Log File from one of my streams: https://obsproject.com/logs/mXvxJHhmSbtx47mz
Results from Twitchtest: https://i.imgur.com/bbFk2Ei.png

Resources already given to me thanks to the people of the OBS discord, so I don't get someone posting the same thing to me here (FeelsOkayMan):

Background info:
I had an AMD laptop before this that sadly died... I was able to stream on Twitch just fine with that laptop but that was from a laptop from HP, this new one I have is a Lenovo with a Nvidia GPU inside it. I don't know if that's the issue. But then again the last time I streamed was 1-2 years ago I think.
Last edited:


New Member
10 ms

93.76 Mbps

116.70 Mbps

ISP: Verizon
Natural Wireless
New York, NY

My internet is fine, so it's just really weird why this is happening cause I was able to stream before. This is my first time experiencing this issue, I used to stream TF2, The Adventures of PepeL, Half-Life 2, and other games. But then again, that was on the AMD computer. I have another laptop downstairs with a GTX 1050, but that's my younger brother's laptop that I gave him but I don't recall if I ever streamed on that one or not. I might try and see if that'll work on his one. Also no one else is drawing internet speed from the house, I tested it with them disconnected from the internet too.


New Member
Okay... now I really don't understand this issue... because literally I just ran downstairs. Used my brother's laptop with a GTX 1050m and lower specs pretty much. Same internet BUT NO WIRED connection... And installed OBS by default with automatic settings and literally was able to start up a game and have 0 drop frames when starting up a game on steam while the stream is still active and running--- and that old laptop was a Dell.


New Member
Okay here a new resource:

This is the log from my brother's laptop downstairs, different specs. Same internet and I literally just streamed this wirelessly just now with no dropped frames opening up Half-Life 2. I don't know if this will be help to anyone, but here's the log's just in case.


New Member
SOLVED: Apparently it was configuration error, I factory reset and just install everything 1 by 1, and now it's fixed. I came to the realization it was a configuration issue because I decided to install Epic Games Client (HYPERDANSGAME) and see if I can stream... and I was able to do it with a simple 2D game. So I uninstalled steam and reinstall and it didn't fix it so fudge it, I just factory reset.

If a mod can change the title to SOLVED, that'll be greatly appreciated.
Last edited: