Question / Help Screen capture black screen - changed GPU from nvidia to intel, still not working

DadVod

New Member
Getting the screen capture black screen from obs running on nvidia, but when I change nvidia settings to run obs on intel the program still launches with nvidia (from what I can see in the logs). I can't seem to find anything pointing me in the right direction. What am I missing?

Log file: https://obsproject.com/logs/sqgCxLb8ABpQMMkx - can see it is still loading nvidia even though I changed it to intel (see screenshot).
 

Attachments

  • Capture.PNG
    Capture.PNG
    62.2 KB · Views: 251

DadVod

New Member
You didn't set OBS to run on the intel.

That is exactly why i'm confused. I did change it. The screenshot from the nvidia control panel shows that I did set it to run on intel, but the log says it is still launching on nvidia.
 

Attachments

  • Capture.PNG
    Capture.PNG
    62.2 KB · Views: 178

Tarumes

Member
before you run into lag problems
Game DVR: On <--- sould be off
and then
what is listed under the dropdown with "Integrated Graphics"?
 

Narcogen

Active Member
10:39:12.221: Adapter 1: NVIDIA Quadro M1000M
10:39:12.221: Dedicated VRAM: 2107703296
10:39:12.221: Shared VRAM: 4231415808
10:39:12.221: output 1: pos={0, 0}, size={1920, 1080}, attached=true
10:39:12.221: output 2: pos={1920, 0}, size={1920, 1080}, attached=true
10:39:12.221: Adapter 2: Intel(R) HD Graphics 530
10:39:12.221: Dedicated VRAM: 134217728
10:39:12.221: Shared VRAM: 4231415808


From the graphic:

"Programs that launch on external displays that are driven by the NVIDIA GPU will always use the NVIDIA GPU"

The reason why I asked if this is a laptop is that the usual situation with laptops that have discrete GPUs is that they have a single onboard display and two GPUs: one integrated, one discrete.

In this mode, any application may launch on either GPU and appear on the monitor, but since the integrated GPU is "in charge" of the built-in display, OBS can only perform a display capture when OBS runs on the integrated GPU.

This means that capturing a high performance game that runs on the discrete GPU means running a game capture and not a display capture.

The above shows two displays connected to the Nvidia GPU and no displays driven by the integrated; perhaps a laptop in clamshell mode, driving two external displays?

I imagine that if OBS is launching its window on an external display that is connected to/driven by the Nvidia card, that is overriding your selection in the Nvidia control panel, and that note at the bottom of the screen is telling you it is going to do that.
 

DadVod

New Member
Interesting idea and cool catch. Any idea how I could find where to keep nvidia from overriding the selection? Or how to get the displays to run on the integrated GPU. I just have the laptop and a single external display connected through hdmi. As far as I can tell they are both connected to the intel gpu (see screenshot).
 

Attachments

  • Capture(2).PNG
    Capture(2).PNG
    26.5 KB · Views: 95

Narcogen

Active Member
No idea. Just that OBS is seeing the opposite-- two displays, both driven by Nvidia.

Do you have some other kind of software that is launching and causing the Nvidia card to be preferred? I think what I'm reading there is that if you've launched a program that prefers the Nvidia display, it will use that. So if a program that is running is launching on the external display and prefers the Nvidia GPU, then that display is driven by that GPU. So if you launch OBS after that, it doesn't have a choice. What else is running?

The only other thing I can think of is removing or perhaps disabling the Nvidia driver; that should force everything to run on Intel.
 

DadVod

New Member
Appreciate everyone that has helped look into this. At this point I still don't have a solution but I have more information.

I got on chat with nvidia and had them look into why my nvidia gpu was overriding the settings to have OBS run on the intel gpu. After a lot of searching the support tech from nvidia informed me that my laptop (MSI workstation) has factory settings that cannot be changed that tell it to run applications on the nvidia GPU. Apparently there is nothing I can do. I have a ticket in to MSI that I will hopefully get a response to soon, but it's looking grim.
 

noesmitipo

New Member
Reply from MSI: Its hardwired to do this by the NVIDIA Optimus Technology.

Laaaaaaaaame.
Did you make any workaround?
Are you using a different SW now?
I was trying to record MTGO with my new MSI and got the same problem.
Furthermore it didn't admit Game Capture for this concrete game :(
 

Ahmed_Adam

New Member
I had the same problem. but I managed to solve it using the following steps on Windows 10
1- right click on the desktop.
2- select " Display Settings"
3- Scroll down to " Graphics Settings" and click on it.
4- click on "Browse" and go to the directory where the app is installed. For me it was in " C:\Program Files\obs-studio\bin\64bit\obs64"
5- After selecting it, click on "Options" then "save power"
 

Attachments

  • Screenshot (147).png
    Screenshot (147).png
    150.7 KB · Views: 167
  • Screenshot (146).png
    Screenshot (146).png
    119.7 KB · Views: 163

ThinkWithP_body

New Member
I had the same problem. but I managed to solve it using the following steps on Windows 10
1- right click on the desktop.
2- select " Display Settings"
3- Scroll down to " Graphics Settings" and click on it.
4- click on "Browse" and go to the directory where the app is installed. For me it was in " C:\Program Files\obs-studio\bin\64bit\obs64"
5- After selecting it, click on "Options" then "save power"

This solved my problems, thanks.
 
Top